Bug 54641 - RFE: Installer needs progress bar/spinner
RFE: Installer needs progress bar/spinner
Status: CLOSED DUPLICATE of bug 52214
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
: FutureFeature
: 55010 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2001-10-15 03:52 EDT by Jesper Skov
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-10-24 13:51:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jesper Skov 2001-10-15 03:52:20 EDT
When installing/upgrading, some of the processes (analyzing the current
installed RPMs, dependencies, etc) take a very long time,
even on fast boxes. 

The problem is not that it takes a lot of time, but that it's impossible
to tell if the thing is actually doing anything or has crashed. It would
be nice with a progress bar (if the extend/progress of the jobs are known)
or at least a (pointer) spinner of some sort that's associated with
progress made (i.e., don't just add a interrupt driven spinner that
keeps spinning even if the process has tanked).

Comment 1 Brent Fox 2001-10-15 15:49:54 EDT
Changing this bug report into an RFE (Request For Enhancement).
Comment 2 Brent Fox 2001-10-17 16:36:37 EDT
I think we tried this in the past and found that the progress bar actually
causes the process to take even longer because of all the interrupts involved. 
Perhaps we could do a spinner or change the mouse pointer to an hourglass of
some type.
Comment 3 Brent Fox 2001-10-24 13:51:33 EDT
*** Bug 55010 has been marked as a duplicate of this bug. ***
Comment 4 Michael Fulbright 2002-01-15 15:29:42 EST

*** This bug has been marked as a duplicate of 52214 ***

Note You need to log in before you can comment on or make changes to this bug.