Bug 522152 - Bluetooth mouse gets stuck at regular intervals
Summary: Bluetooth mouse gets stuck at regular intervals
Keywords:
Status: CLOSED DUPLICATE of bug 516756
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 15:28 UTC by Pramod Dematagoda
Modified: 2009-09-17 17:06 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-17 17:06:06 UTC


Attachments (Terms of Use)

Description Pramod Dematagoda 2009-09-09 15:28:32 UTC
Description of problem: When a bluetooth mouse is used, the mouse pointer keeps freezing at regular intervals, probably because of a lack of input events at that time. I tried my laptop touchpad and a USB mouse and they both work flawlessly.


How reproducible: Configure a bluetooth mouse as an input device through gnome-bluetooth and move it around.


Steps to Reproduce:
1. Press the Bluetooth icon in the notification area and set up a new device.
2. Select the bluetooth mouse from the list.
3. Move it around.
  
Actual results: The mouse pointer keeps freezing at regular intervals for about 1 second and then keeps going like nothing happened.


Expected results: The mouse pointer should keep moving fluidly without interruption.


Additional info: The events seem to be coming in late at that time since if I right click the mouse the event does work after the mouse pointer gets unfrozen, but I cannot be sure since I did this manually, so I may just be slow. :)

Comment 1 Bastien Nocera 2009-09-09 17:29:03 UTC
Input devices are handled in the kernel.

Comment 2 Nathaniel McCallum 2009-09-17 16:13:31 UTC
This bug is a duplicate of 516756.

Comment 3 Bastien Nocera 2009-09-17 17:06:06 UTC

*** This bug has been marked as a duplicate of bug 516756 ***


Note You need to log in before you can comment on or make changes to this bug.