Bug 516756 - bluetooth mouse stops moving each approximately 5 seconds
bluetooth mouse stops moving each approximately 5 seconds
Status: CLOSED DUPLICATE of bug 528744
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Vladimir Benes
: Regression
: 522152 523990 526438 (view as bug list)
Depends On:
Blocks: F12Target fitandfinish
  Show dependency treegraph
 
Reported: 2009-08-11 08:15 EDT by Vladimir Benes
Modified: 2009-10-21 06:03 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 06:03:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2009-08-11 08:15:49 EDT
Description of problem:
moving around the screen with my Logitech bluetooth mouse is not smooth enough. It got stuck every five seconds (approx.) 
older kernel (version 2.6.30-0.97) was ok but after switching to 2.6.31-0.86(or 125) it doesn't work well
 
Version-Release number of selected component (if applicable):
kernel-2.6.31-0.125.rc5.git2
hal-0.5.13-7
gnome-bluetooth-libs-2.27.9-2
gnome-bluetooth-2.27.9-2


How reproducible:

Steps to Reproduce:
1.log into GNOME
2.connect bluetooth mouse
3.move around
  
Actual results:
lugs in motion

Expected results:
smooth motion

Additional info:
Comment 1 Vladimir Benes 2009-08-11 11:50:12 EDT
found which kernel causes this: kernel-2.6.31-0.74 (69 is good)
maybe more info: HP6510b Dual Core..

hope this helps.. if some more info needed, ping me ..
Comment 2 Nathaniel McCallum 2009-09-17 12:17:46 EDT
It appears that 522152 and 523990 are duplicates of this bug.

I'm having the same symptoms.  Another probably related sympppppptom is that wheeeen I type on mmmmy bluetooth keyboarrrrd, a single     keystrokkke will often resuuuult in multiple letters.  I have not corrected thhhhe spelling on this message to demonstraaaate the problem.

Problem still exiiiists on kernel kernel-2.6.31-23.fc12.x86_64.
Comment 3 Bastien Nocera 2009-09-17 13:05:22 EDT
*** Bug 523990 has been marked as a duplicate of this bug. ***
Comment 4 Bastien Nocera 2009-09-17 13:06:06 EDT
*** Bug 522152 has been marked as a duplicate of this bug. ***
Comment 5 Bastien Nocera 2009-09-30 05:51:36 EDT
*** Bug 526438 has been marked as a duplicate of this bug. ***
Comment 6 Krzysztof Urbaniak 2009-10-18 17:40:08 EDT
Bug seems to be fixed in 2.6.32-0.33.rc5.git1.fc13.x86_64 which i've downloaded from koji, but its not usable cause graphic on intel x3100 is broken.
Bluetooth mouse works perfectly.
Comment 7 Krzysztof Urbaniak 2009-10-18 17:52:36 EDT
On kernel 2.6.30.9-85.fc11.x86_64 from Fedora 11 the problem also didn't exists, so broken is only kernel from 2.6.31 series. I've personally rolled back to this kernel as long as kernel in rawhide/f12 will be broken.
Comment 8 Andy Burns 2009-10-18 18:31:09 EDT
(In reply to comment #6)

> Bug seems to be fixed in 2.6.32-0.33.rc5.git1.fc13.x86_64 which i've downloaded
> from koji, but its not usable cause graphic on intel x3100 is broken.
> Bluetooth mouse works perfectly.  

Confirm that my BT mouse is fine in 2.6.30 kernels in F11, but broken with 2.6.31 kernels on rawhide and works better with the 2.6.32rc one mentioned above. 

I say better rather than perfect, with 2.6.30 BT mouse is always smooth, with 2.6.31 it has regular pauses in movement, with 2.6.32rc the periodic disruption is gone, but it is susceptible to jerky movement e.g when starting other apps.

[Also confirm Intel 945GM is borked]
Comment 9 Chuck Ebbert 2009-10-21 06:03:44 EDT

*** This bug has been marked as a duplicate of bug 528744 ***

Note You need to log in before you can comment on or make changes to this bug.