Bug 522177 - drm: radeon r600 GPU lockup
drm: radeon r600 GPU lockup
Status: CLOSED DUPLICATE of bug 528593
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-09 12:48 EDT by Davide Cescato
Modified: 2009-11-01 17:32 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-01 17:32:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of LIBGL_DEBUG=1 glxinfo (15.45 KB, text/plain)
2009-09-09 12:48 EDT, Davide Cescato
no flags Details
Xorg.0.log (59.35 KB, text/plain)
2009-09-09 12:50 EDT, Davide Cescato
no flags Details
output of lspci -v (12.16 KB, text/plain)
2009-10-31 16:43 EDT, Davide Cescato
no flags Details
Xorg.0.log with traceback after lockup (78.10 KB, text/plain)
2009-10-31 17:25 EDT, Davide Cescato
no flags Details

  None (edit)
Description Davide Cescato 2009-09-09 12:48:48 EDT
Created attachment 360270 [details]
output of LIBGL_DEBUG=1 glxinfo

Description of problem:

GPU lockup happening minutes after login on a radeon r600 GPU. The smolt profile is at 
http://www.smolts.org/client/show/pub_af163702-5c2a-4d9f-bc54-2e4626b7be73

Version-Release number of selected component (if applicable):

kernel-2.6.31-0.219.rc9.git2.fc12.x86_64
xorg-x11-drv-ati-6.13.0-0.3.20090908git651fe5a47.fc12.x86_64
mesa-libGL-7.6-0.11.fc12.x86_64
mesa-dri-drivers-experimental-7.6-0.11.fc12.x86_64
mesa-libGLU-7.6-0.11.fc12.x86_64
mesa-dri-drivers-7.6-0.11.fc12.x86_64

The system is a F11 install turned into rawhide.


How reproducible:

Always


Steps to Reproduce:

1. boot system
2. log in
3. do some operations with windows, Xvideo, OpenGL until the bug triggers
  
Actual results:

Xv output, Compiz, xrandr screen rotation, switch to VT, ... works fine, until the screen suddenly freezes. In my case, it happens between 1 and 5 minutes after login. Most of the times, the mouse pointer can still be moved, and ssh access is still possible. Sometimes, neither is the case.

Expected results:

No freezes.


Additional info:

The last lines of the output of dmesg are as follows:
[drm:radeon_ib_get] *ERROR* radeon: IB(3:0x0000000020131000:691)
[drm:radeon_ib_get] *ERROR* radeon: GPU lockup detected, fail to get a IB
[drm:radeon_cs_ioctl] *ERROR* Failed to get ib !

The output of LIBGL_DEBUG=1 glxinfo (before the freeze) is attached.
Comment 1 Davide Cescato 2009-09-09 12:50:32 EDT
Created attachment 360271 [details]
Xorg.0.log
Comment 2 Adam Williamson 2009-09-16 12:35:53 EDT
seems to be some discussion of this in an upstream ML thread too:

http://www.mail-archive.com/dri-devel@lists.sourceforge.net/msg43065.html

re-assigning to driver package per developers' request, though the bug is indeed technically in the kernel, they find it easier to handle things this way.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Adam Williamson 2009-09-16 14:16:11 EDT
*** Bug 522178 has been marked as a duplicate of this bug. ***
Comment 4 Jérôme Glisse 2009-10-29 09:58:19 EDT
Can you try if following iso works :
http://adamwill.fedorapeople.org/radeon-20091028-x86_64.iso
Comment 5 Davide Cescato 2009-10-31 08:01:59 EDT
I tried running the live image linked from comment #4, but I get lockups as in the original bug report.
Comment 6 Adam Williamson 2009-10-31 15:18:19 EDT
I wonder if this was a different issue from the other reported r600 lockups at *first*, but with the live image you're now getting those lockups instead? Can we see your lspci -v output?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Davide Cescato 2009-10-31 16:43:40 EDT
Created attachment 366979 [details]
output of lspci -v
Comment 8 Davide Cescato 2009-10-31 16:46:29 EDT
Two more pieces of information, relative to the live image from comment #4.

The smolt profile is at
http://www.smolts.org/client/show/pub_e6984391-a9e4-42af-b3c6-9f66a27e4b2a

It seems that when booting with the nomodeset option, the lockups do not occur.
Comment 9 Davide Cescato 2009-10-31 16:51:58 EDT
My laptop has switchable graphics. I just realized that the smolt profile
linked in comment #1 is not relevant for this bug, as it was generated when I
was running on the Intel (integrated) GPU, not on the r600 (discrete) GPU.

I apologize for having provided misleading information.
Comment 10 Davide Cescato 2009-10-31 17:23:12 EDT
I found this in Xorg.0.log after a lockup occurred.

[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x49e758]
1: /usr/bin/Xorg (mieqEnqueue+0x1f4) [0x49e124]
2: /usr/bin/Xorg (xf86PostMotionEventP+0xce) [0x478ede]
3: /usr/bin/Xorg (xf86PostMotionEvent+0xa9) [0x479099]
4: /usr/lib64/xorg/modules/input/synaptics_drv.so (0x7f4ce9f0d000+0x36e9) [0x7f4ce9f106e9]
5: /usr/lib64/xorg/modules/input/synaptics_drv.so (0x7f4ce9f0d000+0x5a98) [0x7f4ce9f12a98]
6: /usr/bin/Xorg (0x400000+0x6bdf7) [0x46bdf7]
7: /usr/bin/Xorg (0x400000+0x116993) [0x516993]
8: /lib64/libpthread.so.0 (0x7f4cefbb5000+0xf320) [0x7f4cefbc4320]
9: /lib64/libc.so.6 (ioctl+0x7) [0x7f4cee441c07]
10: /usr/lib64/libdrm.so.2 (drmIoctl+0x23) [0x7f4cebeca203]
11: /usr/lib64/libdrm.so.2 (drmCommandWriteRead+0x1c) [0x7f4cebeca44c]
12: /usr/lib64/libdrm_radeon.so.1 (0x7f4ceb5bc000+0xff9) [0x7f4ceb5bcff9]
13: /usr/lib64/libdrm_radeon.so.1 (0x7f4ceb5bc000+0x1045) [0x7f4ceb5bd045]
14: /usr/lib64/xorg/modules/drivers/radeon_drv.so (0x7f4ceb7c0000+0xbc6b6) [0x7f4ceb87c6b6]
15: /usr/lib64/xorg/modules/drivers/radeon_drv.so (0x7f4ceb7c0000+0xbc723) [0x7f4ceb87c723]
16: /usr/lib64/xorg/modules/drivers/radeon_drv.so (0x7f4ceb7c0000+0xbb16a) [0x7f4ceb87b16a]
17: /usr/lib64/xorg/modules/libexa.so (0x7f4ceab78000+0xd5c9) [0x7f4ceab855c9]
18: /usr/lib64/xorg/modules/libexa.so (0x7f4ceab78000+0xeb4b) [0x7f4ceab86b4b]
19: /usr/lib64/xorg/modules/libexa.so (0x7f4ceab78000+0xb460) [0x7f4ceab83460]
20: /usr/bin/Xorg (0x400000+0xd1e9e) [0x4d1e9e]
21: /usr/bin/Xorg (0x400000+0xcc67e) [0x4cc67e]
22: /usr/bin/Xorg (0x400000+0x2c60c) [0x42c60c]
23: /usr/bin/Xorg (0x400000+0x21c9a) [0x421c9a]
24: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7f4cee386b4d]
25: /usr/bin/Xorg (0x400000+0x21849) [0x421849]

I will now attach the entire Xorg.0.log.
Comment 11 Davide Cescato 2009-10-31 17:25:54 EDT
Created attachment 366981 [details]
Xorg.0.log with traceback after lockup

Xorg.0.log as mentioned in comment #10
Comment 12 Davide Cescato 2009-10-31 17:28:55 EDT
After the lockup in comment #10, the output of dmesg does not contain the 3 lines reported in comment #1.
Comment 13 Adam Williamson 2009-11-01 14:04:15 EST
Jerome - as per the lspci output, this is another r600-on-ICH9 case; do you think the lockups he's seeing now are those ones? Or is this still a different bug?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Adam Williamson 2009-11-01 17:32:03 EST
Jerome mentioned in 528593 that he does think this is a dupe, so let's close this. The r600+ICH9 hardware combination strongly indicates this is now another case of 528593.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 528593 ***

Note You need to log in before you can comment on or make changes to this bug.