Bug 52222 - type read: Operation not permitted
type read: Operation not permitted
Status: CLOSED DUPLICATE of bug 37592
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-21 15:23 EDT by John Pelster
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-27 15:18:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Pelster 2001-08-21 15:23:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
After selecting the packages and X server, the dialogue window for the 
install log pops up, and when you press "OK", the installer crashes.

It says "type read: Operation not permitted,"
then: "pfd: 9install exited abnormally"
then: "sending terminattion signals...done"  (you know the rest)

note, I've seen different numbers after the pfd, including 8,9, and 14, 
also the output of the crash has newlines, but no line feeds.

I have tried a variety of configurations: workstation, server, and 
custom.  I have also tried to install from CD-ROM and FTP, and booting 
from floppy and CD-ROM.  I am limited, however, a lowres or text install.

I've looked throught the anaconda source, and it seems to crash when it 
get to the todo.doInstall() method.

I've seen other reports of this error, search for "type read" 
and "operation not permitted" on Google Groups (Deja).  
<http://groups.google.com/groups?q=%22operation+not+permitted%22+%
type+read%22> Some reports have the same computer I have, a Celebris GL 
6180.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Go through normal installation steps...
2. When it tells you the location of the install log, say "OK"
3. Anaconda crashes.
	

Actual Results:

type read: Operation not permitted

                                  pfd: 9install exited abnormally
                                                                 sending 
termination signals...done

ETC.

Expected Results:  It should be formatting the filesystems.

Additional info:

I using an old Celebris GL 6180 (PII 180) with a 15GB Maxtor harddrive 
(16383C, 63S, 16H).
Comment 1 Matt Wilson 2001-08-21 16:21:07 EDT
try booting with "linux ide=nodma" at the boot: prompt.
Comment 2 John Pelster 2001-08-22 00:46:12 EDT
Tried "linux ide=nodma".  Again, it crashed with "type read: Operation no 
permitted."  Note, the error messages in the graphical install (this is the 
first time I could do a graphical install besides "lowres") are slightly 
different than the text install, it says:

type read: Operation not permitted

pfd: 16xlib: unexpected async reply (sequence 0x58b2)!

Also, nice enough, in this mode it doesn't send the term signals to everything, 
so the shell on "F2" is still working.  These results are the same, with or 
without ide=nodma.
Comment 3 John Pelster 2001-08-22 02:40:29 EDT
I just did an FTP install of SuSE 7.2 to see if it was specific to the RedHat 
distrobution or if it was a problem with Linux and my hardware.  SuSE's YaST 
worked quite well.  Nevertheless, I want RedHat, not SuSE.

I have also experienced this problem with the RedHat 7.0 distribution.
Comment 4 John Pelster 2001-08-22 14:22:54 EDT
I tried to upgrade to RedHat 7.1 from SuSE 7.2 to see if upgrading could 
provide a work around.  All seemed to go well until it said I didn't have 
enough free space on /usr.  Anaconda reported I needed 536MB under /usr, I have 
750MB free out of 1GB, and another 4GB free mounted as /usr/local.  There does 
seem to be a related bug on Anaconda not reading free space correctly, but I 
don't have the permmissions to view it.
Comment 5 Matt Wilson 2001-08-22 15:07:55 EDT
try booting with "linux nousb"
Comment 6 John Pelster 2001-08-22 15:23:23 EDT
Same results.

Note: in the Graphical install, the error message doesn't appear in the X 
session, but whan you go to the other console at "CTRL-ALT-F1".  If you don't 
look at the F1 console, the installer just appears to hang.
Comment 7 John Pelster 2001-08-22 19:25:00 EDT
Just to cover everything, I made some ISO images of the CDs and tried to 
install from the hard drive.  It still didn't work.  (Same error message.)
Comment 8 Brent Fox 2001-08-27 15:18:53 EDT
This looks like a dupe of bug #37592.  Red Hat just doesn't work on Celebris
machines, and we don't have the hardware to duplicate this bug.
Comment 9 Brent Fox 2001-08-27 15:21:11 EDT

*** This bug has been marked as a duplicate of 37592 ***

Note You need to log in before you can comment on or make changes to this bug.