Bug 522370 - Absent BuildRoot tag is not error nowadays
Absent BuildRoot tag is not error nowadays
Status: CLOSED DUPLICATE of bug 515185
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-10 04:40 EDT by Pavel Alexeev
Modified: 2009-09-10 16:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:44:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pavel Alexeev 2009-09-10 04:40:54 EDT
$ rpmlint -i Hubbitus-release-11.spec
Hubbitus-release-11.spec: E: no-buildroot-tag
The BuildRoot tag isn't used in your spec. It must be used in order to allow
building the package as non root on some systems.

Accordingly to guidelines https://fedoraproject.org/wiki/Packaging:Guidelines#BuildRoot_tag it is incorrect now.

So, I think until Epel require it, you should turn this error into warning with appropriate text and mention only when it is needed.
Comment 1 Ville Skyttä 2009-09-10 16:44:35 EDT

*** This bug has been marked as a duplicate of bug 515185 ***

Note You need to log in before you can comment on or make changes to this bug.