Bug 522507 - Missing ifcfg-* files while booting RHEL6 on s390x - egrep: /etc/sysconfig/network-scripts/ifcfg-*: No such file or directory
Summary: Missing ifcfg-* files while booting RHEL6 on s390x - egrep: /etc/sysconfig/ne...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: s390x
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 14:57 UTC by Martin Banas
Modified: 2009-10-06 00:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-06 00:52:23 UTC


Attachments (Terms of Use)
complete boot log (6.53 KB, text/plain)
2009-09-10 15:03 UTC, Martin Banas
no flags Details

Description Martin Banas 2009-09-10 14:57:12 UTC
Description of problem:
While booting RHEL6.0-20090909.7 on s390x, following error is shown:
egrep: /etc/sysconfig/network-scripts/ifcfg-*: No such file or directory


Version-Release number of selected component (if applicable):
RHEL6.0-20090909.7
anaconda 12.21-1
s390x

How reproducible:
always

Steps to Reproduce:
1. run instalation on s390x (exec r6gax exec d)

  
Actual results:
Many errors are shown, one of them is:
egrep: /etc/sysconfig/network-scripts/ifcfg-*: No such file or directory 

Expected results:
System should find ifcfg-* files in mentioned directory

Additional info:

bash-4.0# ls -l /etc/sysconfig/network-scripts
total 44 
-r--r--r-- 1 root root  9116 Aug 10 21:10 network-functions 
-r--r--r-- 1 root root 32208 Aug 10 21:10 network-functions-ipv6

Comment 2 Martin Banas 2009-09-10 15:03:46 UTC
Created attachment 360518 [details]
complete boot log

Comment 4 RHEL Product and Program Management 2009-09-10 15:46:33 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 David Cantrell 2009-09-17 00:38:03 UTC
I think this bug is a side effect of other bugs we've seen, most notably:

* bug #522519
* controlunits.sh not being installed as /sbin/controlunits
* missing /sbin/cmsfscat
* gawk/awk missing

We've fixed up those things in the most recent anaconda build, so I want to see if this bug surfaces with those changes in place.

Comment 6 David Cantrell 2009-10-06 00:52:23 UTC
I'm not seeing this problem in recent RHEL6 trees.  Fixing bug #522519 may or may not have fixed things.  At any rate, it seems to be working fine now.


Note You need to log in before you can comment on or make changes to this bug.