Bug 522519 - Missing modules ccw:t2540m00dtdm and ccw:t1403m00dtdm while booting RHEL6 on s390x
Summary: Missing modules ccw:t2540m00dtdm and ccw:t1403m00dtdm while booting RHEL6 on ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 15:15 UTC by Martin Banas
Modified: 2009-10-14 03:03 UTC (History)
5 users (show)

Fixed In Version: anaconda-12.31-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-14 03:03:29 UTC


Attachments (Terms of Use)
a complete boot log (6.53 KB, text/plain)
2009-09-10 15:15 UTC, Martin Banas
no flags Details

Description Martin Banas 2009-09-10 15:15:18 UTC
Created attachment 360519 [details]
a complete boot log

Description of problem:
Booting s390x shows following errors:
FATAL: Module ccw:t1403m00dtdm not found.
FATAL: Module ccw:t2540m00dtdm not found.

Version-Release number of selected component (if applicable):
RHEL6.0-20090909.7
anaconda 12.21-1
s390x

How reproducible:
always

Steps to Reproduce:
1. boot the RHEL6 installer on PPC ("exec r6gax exec d")
  
Actual results:
While booting following errors are shown (see boot.log for full output)

FATAL: Module ccw:t2540m00dtdm not found. 
FATAL: Module ccw:t2540m00dtdm not found. 
FATAL: Module ccw:t1403m00dtdm not found. 

Expected results:
Modules are loaded successfully

Additional info:
It's maybe related to bug 522507 . Please consider if yes/no.

Comment 1 RHEL Product and Program Management 2009-09-10 15:16:32 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Steffen Maier 2009-09-14 11:48:17 UTC
Since we have full udev in the installer init process (linuxrc.s390) to automatically load any driver module appearing on supported device buses by means of modalias, we probably need all kernel modules, that are referenced in modules.ccwmap, in the installer initrd in order not to get such error message. In this particular case kernel/drivers/s390/char/vmur.ko (puncher/reader/printer) was missing from initrd.img.

# cat /lib/modules/2.6.29.3-159.fc11.s390x/modules.ccwmap 
# ccw module         match_flags cu_type cu_model dev_type dev_model
dasd_eckd_mod        0x0005      0x3990  0x00      0x3390  0x00
dasd_eckd_mod        0x0005      0x2105  0x00      0x3390  0x00
dasd_eckd_mod        0x0005      0x3880  0x00      0x3390  0x00
dasd_eckd_mod        0x0005      0x3990  0x00      0x3380  0x00
dasd_eckd_mod        0x0005      0x2105  0x00      0x3380  0x00
dasd_eckd_mod        0x0005      0x9343  0x00      0x9345  0x00
dasd_eckd_mod        0x0005      0x2107  0x00      0x3390  0x00
dasd_eckd_mod        0x0005      0x2107  0x00      0x3380  0x00
dasd_eckd_mod        0x0005      0x1750  0x00      0x3390  0x00
dasd_eckd_mod        0x0005      0x1750  0x00      0x3380  0x00
dasd_fba_mod         0x0005      0x6310  0x00      0x9336  0x00
dasd_fba_mod         0x0005      0x3880  0x00      0x3370  0x00
tape_34xx            0x0005      0x3480  0x00      0x3480  0x00
tape_34xx            0x0005      0x3490  0x00      0x3490  0x00
tape_3590            0x0005      0x3590  0x00      0x3590  0x00
tape_3590            0x0005      0x3592  0x00      0x3592  0x00
vmur                 0x0001      0x2540  0x00      0x0000  0x00
vmur                 0x0001      0x1403  0x00      0x0000  0x00
cu3088               0x0003      0x3088  0x08      0x0000  0x00
cu3088               0x0003      0x3088  0x1f      0x0000  0x00
cu3088               0x0003      0x3088  0x1e      0x0000  0x00
cu3088               0x0003      0x3088  0x60      0x0000  0x00
cu3088               0x0003      0x3088  0x61      0x0000  0x00
qeth                 0x0003      0x1731  0x01      0x0000  0x00
qeth                 0x0003      0x1731  0x05      0x0000  0x00
qeth                 0x0003      0x1731  0x06      0x0000  0x00
zfcp                 0x000f      0x1731  0x03      0x1732  0x03
zfcp                 0x000f      0x1731  0x03      0x1732  0x04

However, I'm surprised to see the error message just now with RHEL 6, since vmur hasn't been in the initrd in Fedora and there it won't complain about the missing module.

Comment 4 David Cantrell 2009-09-15 22:20:17 UTC
Fix will be in anaconda-12.25-1.

Comment 5 Steffen Maier 2009-10-13 22:30:53 UTC
This has been fixed with commits
2986ed0578a758ffa692ee70d6b69a853c6cc233 (anaconda-12.31-1)
adbfcfb7602dee546786504b757f4eabc0653a3c (anaconda-12.30-1)
a7c45f4b2ca25407d8a959f05986cd6481dd905b (anaconda-12.27-1)
08c4b18dc972a862d4c8cdcc365ba5215399109f (anaconda-12.25-1)
Ever since I have not seen this issue any more.
Can we close this?


Note You need to log in before you can comment on or make changes to this bug.