Bug 522578 - rhn_register fails to prompt for satellite
Summary: rhn_register fails to prompt for satellite
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools
Version: 5.4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Milan Zázrivec
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
: 580162 (view as bug list)
Depends On: 580495
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 18:19 UTC by Tim Wilkinson
Modified: 2012-04-19 10:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-19 10:05:39 UTC


Attachments (Terms of Use)

Description Tim Wilkinson 2009-09-10 18:19:00 UTC
Description of problem:

After installing the rhn-org-trusted-ssl-cert-1.0-1.noarch RPM, rhn_register (when run on the ssh command line) opens a curses version of the GUI which bypasses the window that would offer the user the option to specify a satellite server over the default RHN server.



Version-Release number of selected component (if applicable):

rhn_register (Red Hat Network Client Tools) 0.4.20-9.el5



How reproducible:

Consistent.


Steps to Reproduce:
1. Create kvm-qemu guest on RHEL5.4 host.
2. Install the rhn-org-trusted-ssl-cert-1.0-1.noarch.rpm on the 5.4 guest
3. ssh to guest
4. run rhn_register
  

Actual results:
Curses verion of rhn_register GUI prompts with similar screens as the true GUI ... prompts "Are you sure you would like to continue" ... select "Yes, Continue" ... skip "why should I connect to RHN" and select "Next" ... next window prompts for Login/Password for the RHN server and does NOT present a window for opting to use a satellite.


Expected results:
Should be presented with a window for opting to use a satellite.

Additional info:

Workaround was to vnc to the guest desktop and run rhn_register from a command line there. The standard GUI (not curses) then prompts the user with the option to use a satellite. Once configured, "yum update" back on the guest works as expected.

Comment 2 Tim Wilkinson 2009-10-20 14:59:38 UTC
BZ says NEEDINFO but no request for information is present.

Comment 3 Jan Hutař 2009-10-21 06:47:47 UTC
Do I understand it correctly you want to add similar functionality GUI have
(possibility to configure target RHN server in the wizard) to the TUI? Am I
right?

Comment 4 Tim Wilkinson 2009-10-21 12:42:51 UTC
Correct, the TUI does not offer the same option (to use a satellite server rather than RHN) that is presented only in the GUI.

Comment 8 Milan Zázrivec 2010-07-12 11:26:21 UTC
*** Bug 580162 has been marked as a duplicate of this bug. ***

Comment 10 Milan Zázrivec 2011-01-21 13:27:19 UTC
Fixing this bug is contingent on fixing bug #580495, which I'm not sure
we can make into RHEL-6.1.

Comment 11 RHEL Product and Program Management 2012-04-02 10:40:39 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 12 Milan Zázrivec 2012-04-19 10:05:39 UTC
While I agree that this would be a nice to have, I don't see this
to be a material for RHEL-5.9, especially since this feature most
likely won't be even implemented for RHEL-6 nor in upstream.

I'm closing this with wontfix.


Note You need to log in before you can comment on or make changes to this bug.