Bug 522611 - 2.6.31-2 causes intel driver to be unusably slow
Summary: 2.6.31-2 causes intel driver to be unusably slow
Keywords:
Status: CLOSED DUPLICATE of bug 522909
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-10 20:10 UTC by Kevin Fenzi
Modified: 2009-09-17 16:36 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-17 16:36:14 UTC


Attachments (Terms of Use)
Xorg.0.log from 2.6.31-2 boot (8.15 MB, text/plain)
2009-09-10 20:10 UTC, Kevin Fenzi
no flags Details
Xorg.0.log from working boot/kernel (40.89 KB, text/plain)
2009-09-10 20:13 UTC, Kevin Fenzi
no flags Details
Xorg.0.log with 2.6.31-0.204.rc9.fc12.i686.PAE (83.32 KB, text/plain)
2009-09-16 08:29 UTC, Eric Ciroux
no flags Details
Xorg.0.log with 2.6.31-12.fc12.i686.PAE when gdm is sooo slow (259.73 KB, text/plain)
2009-09-16 08:34 UTC, Eric Ciroux
no flags Details

Description Kevin Fenzi 2009-09-10 20:10:34 UTC
Created attachment 360566 [details]
Xorg.0.log from 2.6.31-2 boot

The 2.6.31-2 kernel boots, but all X operations are unusably slow. I waited about 15minutes and it didn't finish drawing my desktop. Switching to a vty was fast and I could see almost no CPU/IO being used. 

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

Everything is fine with: kernel-2.6.31-0.204.rc9.fc12.x86_64

I have no /etc/X11/xorg.conf file. 

I will attach a log from my 2.6.31-2 boot and from the 2.6.31-0.204.rc9 boot. 
It looks like it's gotten into some kind of loop detecting connected displays. 

This is a laptop. I am only use the connected display, nothing else.

Comment 1 Kevin Fenzi 2009-09-10 20:13:21 UTC
Created attachment 360567 [details]
Xorg.0.log from working boot/kernel

Comment 2 darrell pfeifer 2009-09-14 17:50:27 UTC
Same problem here, also on a Dell Inspiron 1720 laptop. The 212 kernel is the last working one for me. Any of the newer 2.6.31 final kernels have the problem.

I have an desktop at work that I just updated and it works fine.

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

Comment 3 Chuck Ebbert 2009-09-15 09:47:00 UTC
It just keeps looping, with a block of output starting with this line repeating over and over:

(II) intel(0): EDID for output LVDS1

Comment 4 Nathaniel McCallum 2009-09-16 00:34:20 UTC
Same symptoms here.

Comment 5 Eric Ciroux 2009-09-16 08:29:51 UTC
Created attachment 361209 [details]
Xorg.0.log with 2.6.31-0.204.rc9.fc12.i686.PAE

Comment 6 Eric Ciroux 2009-09-16 08:32:39 UTC
Same problem here with 2.6.31-2 and -12.fc12.i686.PAE on the following hardware:
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 03)

2.6.31-0.204.rc9.fc12.i686.PAE is the last working kernel.

Comment 7 Eric Ciroux 2009-09-16 08:34:20 UTC
Created attachment 361210 [details]
Xorg.0.log with 2.6.31-12.fc12.i686.PAE when gdm is sooo slow

Comment 8 Stephen 2009-09-16 11:37:32 UTC
Problem still occurring in 2.6.31-12, I am using an Acer Aspire with an Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)

Comment 9 Stephen 2009-09-16 21:34:49 UTC
Still occurs on 2.6.31-14.  Is this ever going to be looked at ?  Priority is still low, I would also assume severity should be high as the system is virtually unusable

Comment 10 Kevin Fenzi 2009-09-16 21:41:14 UTC
Seems to be fixed here for me in 2.6.31-23. 

* Wed Sep 16 2009 Adam Jackson <ajax@redhat.com>
- Disable hotplug interrupts on TV connectors on i915.

seems to have been the fix.

Comment 11 darrell pfeifer 2009-09-16 23:48:28 UTC
Fixed for me too.

Comment 12 Will Woods 2009-09-17 16:36:14 UTC

*** This bug has been marked as a duplicate of bug 522909 ***


Note You need to log in before you can comment on or make changes to this bug.