Bug 522909 - many "[drm] TV-10: set mode NTSC 480i 0" in /var/log/messages
many "[drm] TV-10: set mode NTSC 480i 0" in /var/log/messages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 522611 522942 523940 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-12 00:38 EDT by John Reiser
Modified: 2010-01-09 17:48 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-18 16:06:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (1.16 MB, text/plain)
2009-09-12 18:29 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2009-09-12 00:38:19 EDT
Description of problem: Booting testday-20090909-i686.iso on Apple Macintosh Mini gives hundreds of lines "[drm] TV-10: set mode NTSC 480i 0" in /var/log/messages. The actual single monitor is a 1280x1024 LCD connected via DVI.


Version-Release number of selected component (if applicable):
kernel-2.6.31-0.219.rc9.git2.fc12.i686

How reproducible: every time


Steps to Reproduce:
1. boot testday-20090909-i686 CD-ROM on Apple Macintosh Mini (Core Duo i686 only)
2. switch to VT2 and inspect /var/log/messages
3.
  
Actual results: hundreds of lines "[drm] TV-10: set mode NTSC 480i 0" at about 3 or 4 lines per second.  The initialization and first several occurrences are:
-----
Sep 12 03:57:24 localhost kernel: [drm] Initialized drm 1.1.0 20060810
Sep 12 03:57:24 localhost kernel: i915 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
   ...
Sep 12 03:57:58 localhost kernel: [drm] TV-10: set mode NTSC 480i 0
Sep 12 03:57:58 localhost kernel: [drm] TV-10: set mode NTSC 480i 0
Sep 12 03:57:59 localhost kernel: [drm] TV-10: set mode NTSC 480i 0
Sep 12 03:57:59 localhost kernel: [drm] TV-10: set mode NTSC 480i 0
Sep 12 03:57:59 localhost kernel: [drm] TV-10: set mode NTSC 480i 0
Sep 12 03:57:59 localhost kernel: [drm] TV-10: set mode NTSC 480i 0
Sep 12 03:58:10 localhost kernel: [drm] TV-10: set mode NTSC 480i 0
Sep 12 03:58:10 localhost kernel: [drm] TV-10: set mode NTSC 480i 0
Sep 12 03:58:11 localhost kernel: [drm] TV-10: set mode NTSC 480i 0
Sep 12 03:58:11 localhost kernel: [drm] TV-10: set mode NTSC 480i 0
Sep 12 03:58:11 localhost kernel: [drm] TV-10: set mode NTSC 480i 0
Sep 12 03:58:12 localhost kernel: [drm] TV-10: set mode NTSC 480i 0
Sep 12 03:58:12 localhost kernel: [drm] TV-10: set mode NTSC 480i 0
Sep 12 03:58:12 localhost kernel: [drm] TV-10: set mode NTSC 480i 0
Sep 12 03:58:13 localhost kernel: [drm] TV-10: set mode NTSC 480i 0
Sep 12 03:58:13 localhost kernel: [drm] TV-10: set mode NTSC 480i 0
Sep 12 03:58:13 localhost kernel: [drm] TV-10: set mode NTSC 480i 0
Sep 12 03:58:13 localhost kernel: [drm] TV-10: set mode NTSC 480i 0
   ...
-----


Expected results: at most a few such lines


Additional info: lspci output:
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.0 0300: 8086:27a2 (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
        Subsystem: Intel Corporation Device 7270
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at 90380000 (32-bit, non-prefetchable) [size=512K] 
        I/O ports at 20f0 [size=8]
        Memory at 80000000 (32-bit, prefetchable) [size=256M]
        Memory at 90400000 (32-bit, non-prefetchable) [size=256K] 
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Kernel driver in use: i915
        Kernel modules: i915
Comment 1 Will Woods 2009-09-12 17:15:27 EDT
*** Bug 522942 has been marked as a duplicate of this bug. ***
Comment 2 Will Woods 2009-09-12 17:18:15 EDT
I'm seeing a very similar problem on an old ThinkPad T43. I think.

If you add 'nomodeset' to the commandline does GDM start as expected? (Note that you may need to disable Desktop Effects when 'nomodeset' is in use)
Comment 3 John Reiser 2009-09-12 18:29:54 EDT
Created attachment 360822 [details]
Xorg.0.log

Adding " nomodeset" to the kernel boot command line does make the "NTSC" messages disappear from /var/log/messages.  However, in /var/log/Xorg.0.log there are 177 copies of the EDID data, modeline determination, etc.

While graphics is coming up, the pointer jumps back and forth about 1 cm, at a frequency of about 1 Hz.  The pointer does track the mouse.  Moving the mouse quickly causes the pointer jumps to be longer, but still about 1 Hz.  So the jump is between the current position and the position 1 second ago?
Comment 4 John Reiser 2009-09-12 18:34:20 EDT
I switched to VT2 to capture the log files.  Upon switching back to graphics (VT1), most of graphics was there, but some text was missing on the top and bottom, and in the Automatic Login panel. The CD-ROM was silent, so it looked like a quiescent state had been achieved.  Further switching back and forth between VT2 (text) and VT1 (graphics) brought the graphics screen to all white.  I stopped then.
Comment 5 Pramod Dematagoda 2009-09-12 22:22:12 EDT
Adding nomodeset did the same thing for me that happened to John Reiser, except graphics were still very slow to respond as well which was there when the nomodeset option was not specified in addition to the hundreds of drm messages.

Also it should be noted that when using the latest Intel Xorg driver in rawhide with kernel 2.6.31-0.204.rc9.fc12.i686 the problems mentioned above do not show up anywhere, so I think this issue has more to do with the DRM than with the Intel Xorg driver.
Comment 6 Orion Poplawski 2009-09-15 16:42:32 EDT
Me too:

Dell Inspiron 6400
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
kernel-2.6.31-12.fc12.x86_64
libdrm-2.4.12-0.10.fc12.x86_64
xorg-x11-drv-intel-2.8.0-13.20090909.fc12.x86_64
xorg-x11-server-Xorg-1.6.99.901-1.fc12.x86_64
Comment 7 Orion Poplawski 2009-09-15 16:49:57 EDT
Also goes away when I shift to kdm.  No idea what gdm is trying to do.
Comment 8 Will Woods 2009-09-16 12:03:57 EDT
Still happening on my Mac Mini; I can confirm that reverting to the F12Alpha kernel (2.6.31-0.125.4.2.rc5.git2.fc12 [man that's a long version number]) without touching xorg-* packages fixes stuff. 

Switching component to kernel, but leaving assigned to ajax - he says he's got a handle on this bug and it's just a matter of giving him time to put together a proper fix.
Comment 9 Matěj Cepl 2009-09-17 10:26:19 EDT
*** Bug 523940 has been marked as a duplicate of this bug. ***
Comment 10 Will Woods 2009-09-17 12:36:14 EDT
*** Bug 522611 has been marked as a duplicate of this bug. ***
Comment 11 Adam Jackson 2009-09-18 11:59:19 EDT
This _should_ be sorted in 2.6.31-33 and later.  Anyone care to confirm?
Comment 12 Kevin Fenzi 2009-09-18 12:07:23 EDT
Coming in from bug 522611 here. 
It seems fixed for me after 2.6.31-23
Comment 13 Honza 'thingie' Bartoš 2009-09-18 12:12:20 EDT
Works for me with 2.6.31-23.
Comment 14 Will Woods 2009-09-18 12:30:04 EDT
Working as expected here (2.6.31-33).
Comment 15 Marcela Mašláňová 2009-09-18 12:47:57 EDT
It's working for me 2.6.31-33. Thanks
Comment 16 Adam Jackson 2009-09-18 16:06:07 EDT
Rockin'.  Closing, thanks all!

Note You need to log in before you can comment on or make changes to this bug.