This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 522675 - mouse,keyboard don't work when boot from LiveCD
mouse,keyboard don't work when boot from LiveCD
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 523359 (view as bug list)
Depends On:
Blocks: F12Beta/F12BetaBlocker
  Show dependency treegraph
 
Reported: 2009-09-10 23:27 EDT by Liam Li
Modified: 2013-01-08 20:16 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-13 16:12:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Liam Li 2009-09-10 23:27:51 EDT
Description of problem:

mouse,keyboard don't work when boot from LiveCD--testday-20090909-x86_64.iso,but work from i686 LiveCD

This is hardware of this machine from previous TestDay. I can not upload smolt ,because mouse and keyboard don't work on this LiveCD.

http://www.smolts.org/show?uuid=pub_cd53be26-268f-4fb8-9098-95c73ba5dcf0

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Boot from Testday's LiveCD, x86_64, system can boot to gdb and can log in, but mouse and keyboard don't work. keyboard does not work even during booting,so can not press F2 to text mode
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Williamson 2009-09-17 22:18:46 EDT
this is not a driver bug, then. re-assigning to kernel. does the keyboard work at the bootloader screen? if so, you can delete rhgb and quiet from the boot parameters and look at the boot messages, at least. may be something in there.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Adam Williamson 2009-09-18 11:55:03 EDT
*** Bug 523359 has been marked as a duplicate of this bug. ***
Comment 3 Adam Williamson 2009-09-18 11:55:46 EDT
can we get lspci -nn and lsusb output, as well? (obviously, from a working situation - from the i686 live image is fine). from both you and liam.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Adam Williamson 2009-09-18 11:56:12 EDT
beta blocker for now until we have a good impact assessment...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Andy Burns 2009-09-20 16:25:44 EDT
I've installed F12 snap2 onto a Dell Mini9 and updated to latest rawhide, 

Didn't have the problem while booted from the liveCD, but since then
I have had at least two instances where on boot only my bluetooth mouse has been active as an input device, no keyboard or touchpad activity

If it happens again I'll try hot plugging a USB device ...
Comment 6 Aioanei Rares 2009-09-21 12:23:05 EDT
Couldn't this be a HAL bug somewhere?
Comment 7 Chuck Ebbert 2009-09-24 11:31:59 EDT
Are these PS/2 or USB keyboards? Smolt doesn't give that information...
Comment 8 Liam Li 2009-09-30 02:54:03 EDT
I tested with USB keyboard and mouse, did not test with ps/2,because Dell's machine has no ps/2 port, does someone else have an old machine to test?
Comment 9 Chuck Ebbert 2009-09-30 14:09:44 EDT
(In reply to comment #8)
> I tested with USB keyboard and mouse, did not test with ps/2,because Dell's
> machine has no ps/2 port, does someone else have an old machine to test?  

We've had problems with USB keyboards before. Is the latest Dell BIOS installed on that machine?  When you report "can not press F2 to text mode" does that mean the keyboard doesn't even work on the GRUB boot screen?
Comment 10 Adam Williamson 2009-10-02 11:29:17 EDT
as liam seems to be the only confirmed sufferer (Andy's problem looks different), and others have tested the x86-64 live images and not seen this problem (including me), dropping from the beta blocker list unless other affected people come forward.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Andy Burns 2009-10-04 14:40:45 EDT
(In reply to comment #10)

> Andy's problem looks different

Fair enough, it did happen again today, I plugged in a USB keyboard, that worked and allowed me to login, I have lsusb/dmesg/xorg log files from when the problem existed if they're of any interest.
Comment 12 Adam Williamson 2009-10-04 15:08:35 EDT
Please file a new bug, as it's far more likely your issue is somewhere in the bluetooth stack and hence different to this problem. Of course we'd still like to fix your problem, but it should be handled separately from this bug :)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Andy Burns 2009-10-04 15:25:48 EDT
(In reply to comment #12)

> Please file a new bug

Done thanks, I was not sure which component to initially assign it to

https://bugzilla.redhat.com/show_bug.cgi?id=527125
Comment 14 James Laska 2009-10-13 07:48:19 EDT
(In reply to comment #9)
> (In reply to comment #8)
> > I tested with USB keyboard and mouse, did not test with ps/2,because Dell's
> > machine has no ps/2 port, does someone else have an old machine to test?  
> 
> We've had problems with USB keyboards before. Is the latest Dell BIOS installed
> on that machine?  When you report "can not press F2 to text mode" does that
> mean the keyboard doesn't even work on the GRUB boot screen?  

I'm not seeing this either on any of my systems.  Liam, do Chuck's suggestions help?  If the keyboard doesn't work during the grub screen, I suspect that might be more a BIOS configuration or BIOS version issue?
Comment 15 Liam Li 2009-10-13 07:58:05 EDT
anaconda 12.37 x86_64 still has such an issue. boot from DVD, it works on grup step,on check media
step,keyboard does not work.
machine smolt:
http://www.smolts.org/client/show/pub_7231b22f-cdfd-4dec-8c8c-08312c043dfd

USB mouse and keyboard.
Comment 16 Liam Li 2009-10-13 08:00:07 EDT
additionally: anaconda 12.36 i386 works well
Comment 17 Liam Li 2009-10-13 08:08:02 EDT
(In reply to comment #15)
> anaconda 12.37 x86_64 still has such an issue. boot from DVD, it works on grup
> step,on check media
> step,keyboard does not work.
> machine smolt:
> http://www.smolts.org/client/show/pub_7231b22f-cdfd-4dec-8c8c-08312c043dfd
> 
> USB mouse and keyboard.  

Sorry, it's an issue of Bios, after do some settings,it works now
Comment 18 Adam Williamson 2009-10-13 16:12:41 EDT
closing, then - not something we can do anything about.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.