Bug 522713 - X server cannot start after the update
Summary: X server cannot start after the update
Keywords:
Status: CLOSED DUPLICATE of bug 518748
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 11
Hardware: x86_64
OS: Linux
low
urgent
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-11 07:07 UTC by Panos Kavalagios
Modified: 2018-04-11 07:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-11 13:03:48 UTC


Attachments (Terms of Use)
Failing Xorg log file (35.76 KB, text/plain)
2009-09-16 06:50 UTC, Panos Kavalagios
no flags Details

Description Panos Kavalagios 2009-09-11 07:07:45 UTC
Description of problem: X server cannot start of intel driver after the update to 1.6.3 version


Version-Release number of selected component (if applicable): xorg-x11-server-Xorg-1.6.3-4.fc11.x86_64 and xorg-x11-drv-intel-2.7.0-7.fc11.x86_64


How reproducible: Reboot your system after the update to xorg 1.6.3


Steps to Reproduce:
1. Reboot the system after having issued "yum update" to get the new xorg server
2.
3.
  
Actual results: Boot process stacks after the plymouth screen with the fedora logo on the completed state. KDM cannot start. Issuing manually startx on run level 3 it produces error messages that cannot connect to X server


Expected results: KDM should have started and asked for user's credentials


Additional info: I have removed my /etc/X11/xorg.conf and have it recreated using system-config-display. KDM now can start, but when you give your credentials and you see KDE load screen, it throws you back to KDM login screen. I've switched the driver from "intel" to "vesa" in xorg.conf and now I was able to log in to my DE (KDE). My graphics card information has been given in details to Bug 508029 for having KMS problems. Now it does not work at all. I have tried to remove the kernel arguments "nomodeset" and "vga" to no avail.

Comment 1 Chris Ricker 2009-09-11 13:01:19 UTC
Similar issue here. On x86_64, xorg-x11-server-Xorg-1.6.3-4 segfaults:

Xorg[1741]: segfault at 0 ip 00000000004e8e0b sp 00007fff3fbbee98 error 4 in Xorg[400000+1b6000]
Xorg[2104]: segfault at 0 ip 00000000004e8e0b sp 00007fff1c8a8958 error 4 in Xorg[400000+1b6000]


I had to downgrade to:

xorg-x11-server-Xorg-1.6.1.901
xorg-x11-server-common-1.6.1.901


before X would work

I'm also using the Intel driver, have plymouth enabled, but use GDM. GDM starts after boot but the segfault occurs when logging into GDM as a user

Comment 2 Chris Ricker 2009-09-11 13:03:48 UTC
Looks like this is a duplicate

*** This bug has been marked as a duplicate of bug 518748 ***

Comment 3 udo 2009-09-12 17:48:38 UTC
Why is this a duplicate? compiz is not mentioned at all.

Comment 4 Panos Kavalagios 2009-09-14 06:03:18 UTC
Indeed, but we don't know yet if it is the same bug that caused the problem. Maybe a Fedora representative could give us some more information.

For the record the affected window manager is kwin for both my computers that faced the same problem. The other has an old ATI graphics card.

Comment 5 Carlo de Wolf 2009-09-14 06:26:38 UTC
Sep 14 07:51:13 nymph kernel: Xorg[7808]: segfault at 0 ip 0812d5b6 sp bf9663b8 error 4 in Xorg[8047000+1b8000]

The workaround mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=518748#c8 works for me.

(In reply to comment #8)
> ...
> I have line 19 in /usr/bin/compiz-gtk commented out:
> 
> # export LIBGL_ALWAYS_INDIRECT=1
> ...

Comment 6 Panos Kavalagios 2009-09-14 06:33:57 UTC
> ls -al /usr/bin/compiz-gtk
ls: cannot access /usr/bin/compiz-gtk: No such file or directory

I'm a sad panda!

Comment 7 Matěj Cepl 2009-09-14 22:52:40 UTC
(In reply to comment #3)
> Why is this a duplicate? compiz is not mentioned at all.  

Could you please upgrade your Xorg server to packages from http://koji.fedoraproject.org/koji/buildinfo?buildID=131217 please? Does it help?

Comment 8 Panos Kavalagios 2009-09-15 07:36:26 UTC
I've updated to xorg-x11-server-common-1.6.4-0.1.fc11.x86_64 and xorg-x11-server-Xorg-1.6.4-0.1.fc11.x86_64 (the other packages are not installed at all to my box) to no avail. The problem is still there.

Comment 9 udo 2009-09-15 13:57:19 UTC
To #7: no it doesn't help updating to that build. :-(
(no compiz here, just radeonhd)

Comment 10 Panos Kavalagios 2009-09-16 06:50:36 UTC
Created attachment 361195 [details]
Failing Xorg log file

Just for the history, it seems to be a different problem. Backtrace is different at least. The directions of

http://wiki.x.org/wiki/Development/Documentation/ServerDebugging

cannot be applied to my F11 box (no /usr/X11R6/bin/X exists and debuginfo-install does not work). 

I might try the compile option to get a proper debugging information, but I'm too busy at the moment. This is only what I have. I hope someone else to fire another bug, because as it seems there is no love for non-compiz window managers. Add compiz usage to the list of the known workarounds.

Comment 11 udo 2009-09-16 14:12:01 UTC
Can I use compiz on ATI rv635 gpu with radeonhd driver? Don't think so yet.

Comment 12 Panos Kavalagios 2009-09-16 15:56:28 UTC
Koji updates needed to remove "nomodeset" and "vga" parameters from kernel command line and also I had to remove "AutoAddDevices" option from ServerLayout to have my X server working again with the "intel" driver.

Comment 13 udo 2009-09-21 14:40:08 UTC
Hmmm...
Autoadd devices? No Compiz? See https://bugzilla.redhat.com/show_bug.cgi?id=522936


Note You need to log in before you can comment on or make changes to this bug.