Bug 522728 - Software Update Error - Caching enabled but no local cache
Summary: Software Update Error - Caching enabled but no local cache
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 11
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-11 08:19 UTC by Frederick N. Brier
Modified: 2014-01-21 23:11 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-22 16:15:29 UTC


Attachments (Terms of Use)

Description Frederick N. Brier 2009-09-11 08:19:38 UTC
Description of problem:

Running System Update fails with the exception trace in the Actual Results section below.  Attempts to install just a few of the 162 updates results in a same error, "Caching enabled but no local cache", minus the exception trace.  I have tried yum clean all, as well as deleting deleting the cache (/var/cache/yum) and recreating the cache (yum makecache).  The same error results.

Version-Release number of selected component (if applicable):

An F11 KVM (x86_64) running on an F11 host (x86_64).

How reproducible:

Very (on my system).  I have 3 F11 KVM VMs.  Two were cloned from another.  All reconfigured with different static IPs and are able to resolve domain names on the Internet.  All (as expected) have the same exact error and exception trace.

Steps to Reproduce:
1. Run "Software Update" from the System->Administration menu
  
Actual results:

----------------------
Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 1240, in _get_depends_not_installed
    rc, msgs =  self.yumbase.buildTransaction()
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 720, in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 728, in resolveDeps
    for po, dep in self._checkFileRequires():
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 967, in _checkFileRequires
    if not self.tsInfo.getOldProvides(filename) and not self.tsInfo.getNewProvides(filename):
  File "/usr/lib/python2.6/site-packages/yum/transactioninfo.py", line 423, in getNewProvides
    for pkg, hits in self.pkgSack.getProvides(name, flag, version).iteritems():
  File "/usr/lib/python2.6/site-packages/yum/packageSack.py", line 327, in getProvides
    return self._computeAggregateDictResult("getProvides", name, flags, version)
  File "/usr/lib/python2.6/site-packages/yum/packageSack.py", line 497, in _computeAggregateDictResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 882, in getProvides
    return self._search("provides", name, flags, version)
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 44, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 858, in _search
    for pkg in self.searchFiles(name, strict=True):
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 44, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 559, in searchFiles
    self.populate(repo, mdtype='filelists')
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 170, in populate
    db_fn = repo._retrieveMD(mydbtype)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1468, in _retrieveMD
    self)
RepoError: Caching enabled but no local cache of /var/cache/yum/fedora/0301ed1cbf01c00cdf9c42b71df6c74947d9c76a3c9767e8f85a99ef6fdccb86-filelists.sqlite.bz2 from fedora
----------------------

Expected results:

No error.

Additional info:

Comment 1 seth vidal 2009-09-11 15:17:25 UTC
The code that's not catching the exception is in PK. I'm going to reassign there unless there is something I've missed.

Comment 2 Richard Hughes 2009-09-11 15:29:19 UTC
Are the VM's running NetworkManager?


Note You need to log in before you can comment on or make changes to this bug.