Bug 522849 - Gamma fade when performing Switch User leaves screen greyish
Summary: Gamma fade when performing Switch User leaves screen greyish
Status: CLOSED DUPLICATE of bug 515306
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F12Blocker, F12FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2009-09-11 18:54 UTC by Walter Francis
Modified: 2018-04-11 08:07 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-10-09 12:01:54 UTC


Attachments (Terms of Use)
dmesg after switching users (46.62 KB, text/plain)
2009-09-18 16:15 UTC, Walter Francis
no flags Details
Xorg 0 log after switching users (96.83 KB, text/plain)
2009-09-18 16:16 UTC, Walter Francis
no flags Details
Xorg 1 log after switching users (55.95 KB, text/plain)
2009-09-18 16:16 UTC, Walter Francis
no flags Details

Description Walter Francis 2009-09-11 18:54:41 UTC
When doing Fast User Switching, the screen fades out to black before it goes to the GDM.  To me, I think this is likely a gamma/LUT fade similar to how some screensavers work.  Once this happens, the scren stays an ugly greyish hue after,
like it doesn't restore the gamma/LUTs properly.  I can't attempt to reproduce this with screensaver as screensaver is not working for me, already logged as bugzilla 522844.  Interestingly, if I suspend the machine the gamma/LUT fade from that does look fine, but if I switch users, then suspend, the gamma/LUT still looks bad.

This is likely NOT Intel driver specific, as another user says he also sees it on an ATi controller, but honestly not sure what package to log it against.

Dell Latitude X1
http://www.smolts.org/client/show/pub_99359cea-215f-4505-98a8-c86ba9e3fa18

Testing on the Intel Test Day image, testday-20090909-i686.iso

100% reproducible

Steps to Reproduce:
1. Login to desktop
2. Click username in top-right corner to switch user
3. Note screen (gamma) looks bad from this point on

Comment 1 Antal KICSI 2009-09-11 18:57:24 UTC
I have the same problem with i845.
Smolt profile : 
http://www.smolts.org/client/show/pub_50c9b678-9c49-4072-b7a6-c5eb9a36c342

Comment 2 Tomasz Chrzczonowicz 2009-09-11 23:21:05 UTC
Same here with both Intel i945 and ATI (r300)

Also testday-20090909-i686.iso

Comment 3 Tomasz Chrzczonowicz 2009-09-12 00:14:50 UTC
Sometimes it makes the screen go completely black (but still working otherwise)

Comment 4 Walter Francis 2009-09-12 00:16:46 UTC
What's bad is my i855GM fades more and more and more, after a few switches it's almost completely black.  http://www.smolts.org/client/show/pub_99359cea-215f-4505-98a8-c86ba9e3fa18

Comment 5 Walter Francis 2009-09-12 00:23:16 UTC
I just realized I over-wrote my smolt profile using a USB Live stick, so I'll have to re-gather the profile for the Dell Latitude X1 on Monday.

Comment 6 Walter Francis 2009-09-14 15:11:46 UTC
Actual Latitude X1 Smolt profile (since I accidentally over-wrote the original one with a later test):  http://www.smolts.org/client/show/pub_3c125281-78f5-4b36-bdd1-9f339dcf9ae8

Comment 7 Ondrej Zary 2009-09-14 15:17:35 UTC
On i865G, the screen goes black and remains like that. System still works but nothing is visible on the screen.

Comment 8 Adam Williamson 2009-09-18 04:22:01 UTC
some similar issues were reported in the radeon test day, interestingly..

can we get /var/log/Xorg.0.log and dmesg output from after the problem happens, please? Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 9 Walter Francis 2009-09-18 16:15:59 UTC
Created attachment 361685 [details]
dmesg after switching users

Comment 10 Walter Francis 2009-09-18 16:16:17 UTC
Created attachment 361686 [details]
Xorg 0 log after switching users

Comment 11 Walter Francis 2009-09-18 16:16:36 UTC
Created attachment 361687 [details]
Xorg 1 log after switching users

Comment 12 Walter Francis 2009-09-18 16:17:15 UTC
Logs attached!  I assume Xorg.1.log is interesting too, since it's the new X session, but I can't begin to guess which 'causes' the problem, the original or new server.

Comment 13 Walter Francis 2009-09-18 16:18:36 UTC
By the way I've tested this on F11 on the same laptop, it does not fade the way this is described.

Comment 14 Ondrej Zary 2009-10-03 20:51:25 UTC
With desktop-i386-20091001.15.iso, the screen goes very grey after user switch on i865G.

Comment 15 Matthias Clasen 2009-10-06 16:36:15 UTC
I'm still seeing the same problem with 2.9.0

Comment 16 Matěj Cepl 2009-10-09 12:01:54 UTC

*** This bug has been marked as a duplicate of bug 515306 ***


Note You need to log in before you can comment on or make changes to this bug.