Bug 522863 - kernel 2.6.30.5-43, can't login to desktop with intel 945GM/GMS graphics
Summary: kernel 2.6.30.5-43, can't login to desktop with intel 945GM/GMS graphics
Keywords:
Status: CLOSED DUPLICATE of bug 522742
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 11
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-11 21:01 UTC by Ian Malone
Modified: 2017-11-30 19:36 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-12 06:12:32 UTC


Attachments (Terms of Use)
xorg.log from failed login attempt (41.24 KB, text/plain)
2009-09-11 21:01 UTC, Ian Malone
no flags Details

Description Ian Malone 2009-09-11 21:01:21 UTC
Created attachment 360725 [details]
xorg.log from failed login attempt

Description of problem:

After a recent yum update I can't login to the desktop.  On entering login details, the login dialog disappears, a busy cursor plays for a while then X appears to restart and takes me back to the login screen.

Version-Release number of selected component (if applicable):
kernel-2.6.30.5-43.fc11.x86_64
xorg-x11-drivers-7.3-11.fc11.x86_64
xorg-x11-server-common-1.6.3-4.fc11.x86_64
xorg-x11-server-Xorg-1.6.3-4.fc11.x86_64
xorg-x11-drv-intel-2.7.0-7.fc11.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Attempt to login with valid details
2.
3.
  
Actual results:
Get booted back to login screen.

Expected results:
Get to desktop

Additional info:
Disabling selinux didn't help.  Restarting with the previous kernel (2.6.29.6-217.2.16.fc11.x86_64) works.

The following extract from /var/log/messages may correspond to the failed login:
Sep 11 21:16:56 prometheus gnome-keyring-daemon[2132]: Couldn't unlock login keyring with provided password
Sep 11 21:16:56 prometheus gnome-keyring-daemon[2132]: Failed to unlock login on startup
Sep 11 21:17:00 prometheus kernel: [drm:edid_is_valid] *ERROR* Raw EDID:
Sep 11 21:17:00 prometheus kernel:
Sep 11 21:17:00 prometheus kernel: i915 0000:00:02.0: LVDS-1: EDID invalid.
Sep 11 21:17:00 prometheus kernel: [drm] TV-11: set mode NTSC 480i 0
Sep 11 21:17:00 prometheus kernel: [drm] TV-11: set mode NTSC 480i 0
Sep 11 21:17:01 prometheus kernel: [drm:edid_is_valid] *ERROR* Raw EDID:
Sep 11 21:17:01 prometheus kernel:
Sep 11 21:17:01 prometheus kernel: i915 0000:00:02.0: LVDS-1: EDID invalid.
Sep 11 21:17:01 prometheus kernel: [drm] TV-11: set mode NTSC 480i 0
Sep 11 21:17:01 prometheus kernel: [drm] TV-11: set mode NTSC 480i 0
Sep 11 21:17:02 prometheus kernel: [drm:edid_is_valid] *ERROR* Raw EDID:
Sep 11 21:17:02 prometheus kernel:
Sep 11 21:17:02 prometheus kernel: i915 0000:00:02.0: LVDS-1: EDID invalid.
Sep 11 21:17:02 prometheus kernel: [drm] TV-11: set mode NTSC 480i 0
Sep 11 21:17:02 prometheus kernel: [drm] TV-11: set mode NTSC 480i 0
Sep 11 21:17:04 prometheus pulseaudio[2233]: pid.c: Stale PID file, overwriting.
Sep 11 21:17:06 prometheus kernel: fuse init (API version 7.11)
Sep 11 21:17:09 prometheus pulseaudio[2283]: pid.c: Daemon already running.
Sep 11 21:17:15 prometheus kernel: Xorg[1978]: segfault at 0 ip 00000000004e8e0b sp 00007fff739e5898 error 4 in Xorg[400000+1b6000]
Sep 11 21:17:16 prometheus kernel: [drm] LVDS-8: set mode 1280x800 13
Sep 11 21:17:16 prometheus gnome-keyring-daemon[2132]: dbus failure unregistering from session: Connection is closed
Sep 11 21:17:18 prometheus kernel: [drm:edid_is_valid] *ERROR* Raw EDID:
Sep 11 21:17:18 prometheus kernel:

Xorg from the previous login is attached.

Comment 1 Sam Sharpe 2009-09-11 21:11:07 UTC
+1 for this exact graphics config.

In my case, I disabled Compiz/Desktop Effects and was back in the desktop - I don't know if Ian is also using 3D/Compiz etc.

Comment 2 Adam D. Ligas 2009-09-12 05:10:55 UTC
I'm receiving the same error.  I've got a Thinkpad T61, running x86-64 w/ i965 graphics.

I found that if I kept trying to login it would eventually "catch", but then I would have a slew of "gnome panels" running, most of them pegging a CPU.  Killing all but the highest PID seemed to bring things back closer to normal.

Per Sam's comment, disabling Compiz/Desktop Effects seems to give me normal desktop operation again.  After doing that, I was able to login on the first shot.

Here is the segfault line from my attempts to login prior to Sam's workaround:

Sep 11 18:24:46 Q kernel: Xorg[2244]: segfault at 0 ip 00000000004e8e0b sp 00007fff153e1b98 error 4 in Xorg[400000+1b6000]

Also, if it helps, when I disabled Desktop Effects it appears that Compiz took a dive.  Here is that segault line as as well:

Sep 12 00:54:19 Q kernel: compiz[6436]: segfault at 38a8e2ea80 ip 00000038a8e2ea80 sp 00007fff96aa0818 error 14 in libICE.so.6.3.0[38ab200000+17000]

Comment 3 Gabriel Ramirez 2009-09-12 05:51:59 UTC
(In reply to comment #2)
> I'm receiving the same error.  I've got a Thinkpad T61, running x86-64 w/ i965
> graphics.
> 
> I found that if I kept trying to login it would eventually "catch", but then I
> would have a slew of "gnome panels" running, most of them pegging a CPU. 
> Killing all but the highest PID seemed to bring things back closer to normal.
> 
> Per Sam's comment, disabling Compiz/Desktop Effects seems to give me normal
> desktop operation again.  After doing that, I was able to login on the first
> shot.


if you add nomodeset to the kernel 2.6.30 options line  can you after that enable desktop effects???

or boot previous kernel 2.6.29 with desktop effects enabled???

Comment 4 Jonathan Dieter 2009-09-12 06:12:32 UTC

*** This bug has been marked as a duplicate of bug 522742 ***


Note You need to log in before you can comment on or make changes to this bug.