Bug 522742 - Xorg crashes intermittently when compiz is enabled
Xorg crashes intermittently when compiz is enabled
Status: CLOSED DUPLICATE of bug 518748
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
11
All Linux
high Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
: 522863 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-11 05:41 EDT by Jonathan Dieter
Modified: 2009-09-17 08:17 EDT (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 08:17:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (62.22 KB, text/plain)
2009-09-11 05:42 EDT, Jonathan Dieter
no flags Details
/etc/gdm/PreSession/Default (313 bytes, text/plain)
2009-09-11 06:28 EDT, Jonathan Dieter
no flags Details
/etc/gdm/Init/Default (2.86 KB, text/plain)
2009-09-11 06:29 EDT, Jonathan Dieter
no flags Details
Xorg log file from T400 starting Compiz post-login (36.98 KB, text/plain)
2009-09-12 12:27 EDT, Christopher A. Williams
no flags Details
repofile containing a location with rpms which maybe fix this bug (728 bytes, application/octet-stream)
2009-09-12 13:31 EDT, Gabriel Ramirez
no flags Details
repofile disabled by default containing a location with rpms which maybe fix this bug (728 bytes, application/octet-stream)
2009-09-13 23:56 EDT, Gabriel Ramirez
no flags Details

  None (edit)
Description Jonathan Dieter 2009-09-11 05:41:54 EDT
Description of problem:
After today's set of updates, Xorg now crashes when a user logs in.  If I install gnome-power-manager, everything works fine.  I have removed gnome-power-manager because of some problems with it turning off the monitor when we don't want it to, and our school policy is that the monitor is on if the computer is on (it helps us know which computers are on and which are off in the labs).

Version-Release number of selected component (if applicable):
kernel-PAE-2.6.30.5-43.fc11.i686
kernel-2.6.30.5-43.fc11.x86_64
xorg-x11-server-Xorg-1.6.3-4.fc11.i586
xorg-x11-server-Xorg-1.6.3-4.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Remove gnome-power-manager
2. Log in
  
Actual results:
Xorg crashes

Expected results:
Normal login
Comment 1 Jonathan Dieter 2009-09-11 05:42:35 EDT
Created attachment 360652 [details]
Xorg.0.log
Comment 2 Jonathan Dieter 2009-09-11 06:27:41 EDT
I'm afraid I jumped the gun when I assumed that it was a problem with gnome-power-manager.  It appears that it's an intermittent problem.  If I log in *immediately* after gdm loads up, everything works.  If I wait a few seconds, Xorg segfaults during the login.

I do have custom files for /etc/gdm/Init/Default and /etc/gdm/PreSession/Default, which I will attach.  They do things like start x11vnc as root and, on PreSession, kill gnome-screensaver.
Comment 3 Jonathan Dieter 2009-09-11 06:28:47 EDT
Created attachment 360661 [details]
/etc/gdm/PreSession/Default
Comment 4 Jonathan Dieter 2009-09-11 06:29:39 EDT
Created attachment 360662 [details]
/etc/gdm/Init/Default
Comment 5 Jonathan Dieter 2009-09-11 06:40:59 EDT
Ok, I've tracked it down to compiz being enabled.  If I disable compiz, there are no problems at all.  Not sure what the issue with compiz is, but there it is.  Again, if I log in immediately after gdm starts, everything works fine with compiz.  If I disable compiz, everything works fine.  If I have compiz enabled and login 15+ seconds after gdm starts, Xorg crashes.
Comment 6 Bob Relyea 2009-09-11 15:00:07 EDT
I'm seeing the same thing, though I don't even get 15 seconds.
uninstalling compiz seems to fix the problem. (sigh). I really like my desktop effects....;(

bob
Comment 7 Mike Bonnet 2009-09-11 15:09:11 EDT
Same here, I don't think I even get 15 seconds.  Changing the window manager from compiz-gtk to metacity allows me to login again.  I'm seeing messages about X segfaulting in /var/log/messages:

Sep 11 09:30:04 maunalani kernel: Xorg[3278]: segfault at 0 ip 00000000004e8e0b sp 00007fff8623e158 error 4 in Xorg[400000+1b6000]

I'll try to get a backtrace from X when running compiz --replace.
Comment 8 Jonathan Dieter 2009-09-12 02:12:33 EDT
*** Bug 522863 has been marked as a duplicate of this bug. ***
Comment 9 Davide Cescato 2009-09-12 03:11:41 EDT
Same here. Downgrading xorg-x11-server-Xorg-1.6.3-4.fc11.x86_64 to xorg-x11-server-Xorg-1.6.1.901-1.fc11.x86_64 seems to solve the issue, and compiz works.

This bug is critical. Without graphical login, users can not even run PackageKit to download an update.
Comment 10 Ian Malone 2009-09-12 03:42:25 EDT
I'm the poster of bug 522863, so I'll reply to Gabriel Ramirez's questions here:

> if you add nomodeset to the kernel 2.6.30 options line  can you after that enable desktop effects???
>

nomodeset didn't seem to make any difference.  (I've been seeing the "[drm:edid_is_valid] *ERROR* Raw EDID:" errors for a while before this)


> or boot previous kernel 2.6.29 with desktop effects enabled???  

I hadn't knowingly disabled desktop effects when booting to the previous kernel.  After the first replies on 522863 I disabled it (while runnning on the older kernel) and booted into 2.6.30 okay.  The desktop immediately crashed on enabling desktop effects.  Now when I try to enable desktop effects on the older (previous 2) kernels the desktop crashes.  However at the very least I did boot into a 2.6.29 kernel to disable desktop effects and I had been using them previously, so something seems to have changed.
Comment 11 Gabriel Ramirez 2009-09-12 11:36:17 EDT
(In reply to comment #10)
> I'm the poster of bug 522863, so I'll reply to Gabriel Ramirez's questions
> here:
> 
> > if you add nomodeset to the kernel 2.6.30 options line  can you after that enable desktop effects???
> >
> 
> nomodeset didn't seem to make any difference.  (I've been seeing the
> "[drm:edid_is_valid] *ERROR* Raw EDID:" errors for a while before this)
> 
> 
> > or boot previous kernel 2.6.29 with desktop effects enabled???  
> 
> I hadn't knowingly disabled desktop effects when booting to the previous
> kernel.  After the first replies on 522863 I disabled it (while runnning on the
> older kernel) and booted into 2.6.30 okay.  The desktop immediately crashed on
> enabling desktop effects.  Now when I try to enable desktop effects on the
> older (previous 2) kernels the desktop crashes.  However at the very least I
> did boot into a 2.6.29 kernel to disable desktop effects and I had been using
> them previously, so something seems to have changed. 

I was betting which with nomodeset you will have 2.6.30 with Desktop Effects enabled, but seems wrong.

because I have kernel kernel-2.6.30.5-43 working with xorg-x11-server-Xorg-1.6.3-4 and desktop effect enabled in two intel machines 

I has running that xorg-version running under kernel 2.6.29 as by https://bugzilla.redhat.com/show_bug.cgi?id=518532#c5 but with mesa7.5.1 and libdrm 2.4.12 and intel driver 2.8.1 

if your intel configuration don't have any xorg.conf, maybe you want to try install my rpms to see if them solved the bug
Comment 12 Christopher A. Williams 2009-09-12 12:25:42 EDT
Reproduced the problem on my ThinkPad T400 with Intel graphics as well running F11 x86_64.

Downgrading to previous version of xorg-x11-server-Xorg also worked for me. Fortunately, I do not login with Desktop Effects or Compiz enabled by default. Instead, I use the Compiz Fusion Icon to launch Compiz as a post-login step. With the latest version of xorg-x11-server-Xorg, X crashes only when trying to launch Compiz. I'm attaching a copy of my Xorg log file for reference (as Xorg.0.log.broken)
Comment 13 Christopher A. Williams 2009-09-12 12:27:04 EDT
Created attachment 360794 [details]
Xorg log file from T400 starting Compiz post-login

Log file from ThinkPad T400 with Intel graphics where X crashes upon trying to launch Compiz post login.
Comment 14 Gabriel Ramirez 2009-09-12 13:31:44 EDT
Created attachment 360801 [details]
repofile containing a location with rpms which maybe fix this bug

if your machine don't any xorg.conf and try my rpms drop this file myrepo.repo in your /etc/yum.repos.d, and run yum update --enablerepo=myrepo that will:

will downgrade to mesa 7.5.1 because a leak memory bug fixed in http://intellinuxgraphics.org/2009Q2.html bug#20704 described in https://bugs.freedesktop.org/show_bug.cgi?id=20704

will update:
to intel driver to 2.8.1 
to libdrm-2.4.12-0.9 recompiled for F11 from F12
glew-1.5.1-3.fc11.x86_64 recompiled for libdrm 2.4.12

will downgrade:
to mesa 7.5.1 because a leak memory in mesa 7.6 bug fixed in http://intellinuxgraphics.org/2009Q2.html bug#20704 described in https://bugs.freedesktop.org/show_bug.cgi?id=20704

also look to update to xorg-x11-server-Xorg-1.6.3-4 from fedora because is required by the intel driver 2.8.1 by http://lists.freedesktop.org/archives/xorg/2009-August/046978.html in "New fixes in 2.8.1 compared to 2.8.0"

write down the list of packages updated for if the problem persist in your case can run  yum downgrade the list of packages updated
Comment 15 udo 2009-09-12 14:02:55 EDT
Happens immediately without compiz here. No logon possible.
Custom 2.6.30.5 kernel, radeonhd from git. 
See https://bugzilla.redhat.com/show_bug.cgi?id=522936
Comment 16 Nanley Chery 2009-09-12 18:09:56 EDT
Gabriel's repo works for my Intel G965.
Comment 17 Gabriel Ramirez 2009-09-12 18:20:22 EDT
(In reply to comment #16)
> Gabriel's repo works for my Intel G965.  

can you tell if that is with desktop effects enabled and Kernel modesetting active with kernel-2.6.30.5-43.fc11??

I will remove a kernel-2.6.30.5-45.fc11 which I has in my repo I forgot about it,  but can cause problems because no kmod from rpmfusion are built against it.
the kernel-2.6.30.5-45 is removed
Comment 18 Nanley Chery 2009-09-12 19:37:42 EDT
Your packages work with Desktop Effects and KMS enabled on the main/older kernel.
Comment 19 Gabriel Ramirez 2009-09-12 23:06:14 EDT
well thanks, so maybe an update to one or more of the following packages is necessary to work with xorg-x11-server-Xorg-1.6.3-4:

xorg-x11-drv-intel-2.8.1 the showstopper to this is which don't support or XAA EXA, only UXA so maybe don't work where EXA or XAA is specified in the xorg.conf 
but my two computers don't have any X freezes with it

libdrm-2.4.12-0.9 intel driver required a version >= 2.4.11 but the .12 from F12 compiled fine at the time so I use it

mesa-7.5.1-0.4 have a fix to a memory leak which affted one of my two machines

all SRPMS are in myrepo too so can be downloaded with:
yumdownloader --enablerepo=myrepo --source xorg-x11-drv-intel mesa

and are based in Fedora rpms
Comment 20 Thomas Groß 2009-09-13 16:52:06 EDT
I have the same problem. Intel G45 Graphics Set. Disabling compiz fixes the problem.

Additionally since the kernel 2.6.30 update i get a X Login Screen with a
a ~90pt font. This does not happen with older kernel releases.

I'm not quite sure if this is related. If it's not i can open an extra bug for this.
Comment 21 Gabriel Ramirez 2009-09-13 19:16:16 EDT
(In reply to comment #20)
> I have the same problem. Intel G45 Graphics Set. Disabling compiz fixes the
> problem.
> 
 do you want to try updated packages of intel driver, mesa and libdrm? described in comment #14 maybe fix your issue with Compiz https://bugzilla.redhat.com/show_bug.cgi?id=522742#c14
Comment 22 Gabriel Ramirez 2009-09-13 23:38:24 EDT
Comment on attachment 360801 [details]
repofile containing a location with rpms which maybe fix this bug

I uploaded the file with the repo enabled by default, so always will update 
please change the line 
enabled=1
to enabled=0
Comment 23 Gabriel Ramirez 2009-09-13 23:56:56 EDT
Created attachment 360869 [details]
repofile disabled by default containing a location with rpms which maybe fix this bug

I uploaded a corrected repofile disabled by default so execute:
yum update --enablerepo=myrepo
and will update to intel driver, libdrm and mesa only with the option --enablerepo specified 

again be sure to update Xorg-1.6.3-4 from fedora because is
required by the intel driver 2.8.1 by 
http://lists.freedesktop.org/archives/xorg/2009-August/046978.html in "New
fixes in 2.8.1 compared to 2.8.0
Comment 24 Anthony Horton 2009-09-14 00:22:39 EDT
This seems to be the same issue as this bug: https://bugzilla.redhat.com/show_bug.cgi?id=518748
Comment 25 Valent Turkovic 2009-09-16 16:27:37 EDT
latest xorg update renders many fedora users unable to use fedora, this is really, really bad!
Comment 26 Davide Cescato 2009-09-17 04:39:09 EDT
I agree with comment #24, this should be closed as duplicate of bug 518748.
https://bugzilla.redhat.com/show_bug.cgi?id=518748#c50 says that a fixed X server is on the way.
Comment 27 Jonathan Dieter 2009-09-17 08:17:21 EDT
The updated packages in https://bugzilla.redhat.com/show_bug.cgi?id=518748#c50 fixed it for me.

*** This bug has been marked as a duplicate of bug 518748 ***

Note You need to log in before you can comment on or make changes to this bug.