Bug 522876 - kernel BUG at arch/powerpc/kernel/setup-common.c:653!
kernel BUG at arch/powerpc/kernel/setup-common.c:653!
Status: CLOSED DUPLICATE of bug 521703
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
powerpc Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-11 18:28 EDT by JPS
Modified: 2009-09-25 00:21 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-25 00:21:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screen capture of panic (1.31 MB, image/jpeg)
2009-09-20 12:15 EDT, Matthew McGillis
no flags Details

  None (edit)
Description JPS 2009-09-11 18:28:38 EDT
Description of problem:
Kernel crash. First lines of output are:
  kernel coherency:off != device tree_coherency:on
  -------------[ cut here ]-------------
  kernel BUG at arch/powerpc/kernel/setup-common.c:653!
  Oops: Exception in kernel mode, sig:5 [#1]
  PowerMac
  ...etc.

Version-Release number of selected component (if applicable):
Kernel 2.6.30.5-43

How reproducible:
Booting with this kernel version

Additional info:
Machine used is a B&W G3.
Using yum for maintaining system up to date.
Kernels 2.6.29.6-217.2.16 and 2.6.29.6-217.2.8 were ok.
Comment 1 Vlado Plaga 2009-09-15 11:18:03 EDT
This kernel is also crashing my system in the same way.

This is a G4 iMac, a "7455" (according to /proc/cpuinfo).

I could not boot my Fedora 11 system with the previous kernels either, but unlike with this kernel I did not get any usable output before. I can only boot Fedora with a Debian kernel, but then I don't get a graphical login (since Debian kernels do not include "nouveau" support, the very reason I wanted to try Fedora for).

I took a picture of the screen when the bug occured, so I can provide some more details (although I don't know if it could help):

usbcore: registered new interface driver usbhid
usbhid: v2.6: USB HID core driver
nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use nf_conntrack.acct=1 kernel paramater, acct=1 nf_conntrack module option or sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
ip_tables: (C) 2000-2006 Netfilter Core Team
TCP cubic registered
Initializing XFRM netlink socket
NET: Registered protocol family 17
kernel coherency:off != device tree_coherency:on
------------[ cut here ]------------
kernel BUG at arch/powerpc/kernel/setup-common.c:653!
Oops: Exception in kernel mode, sig: 5 [#1]
PowerMac
Modules linked in:
NIP: c06acd84 LR: c06acd84 CTR: 00000000
REGS: ef887e90 TRAP: 0700   Not tainted  (2.6.30.5-43.fc11.ppc)
[ 8 lines not copied ... ]
Call Trace:
[ 4 lines not copied ... ]
Instruction dump:
[ 3 lines not copied ... ]
Kernel panic - not syncing: Attempted to kill init!
Call Trace:
[ 8 lines not copied ... ]
--- Exception: 700 at check_cache_coherency+0x6c/0x98
    LR check_cache_coherency+0x6c/0x98
[ 3 lines not copied ... ]
Rebooting in 180 seconds..
Comment 2 andrei_zamfir 2009-09-15 17:09:37 EDT
I can also confirm this on an iBook G3 (500mhz)
To reproduce this the kernel including all the updates before 2.6.30.5-43 work fine, but as soon as you update the kernel to 2.6.30.5-43 it crashes. As stated above, same thing happens on a clean install.
Comment 3 Nikolay Nikolov 2009-09-16 09:13:14 EDT
Confirmed on a PowerPC-based Mac Mini. Kernel 2.6.30.5-43.fc11.ppc crashes, kernel 2.6.29.6-217.2.16.fc11.ppc and earlier works fine.

Crash screen looks as described by Vlado Plaga.

/proc/cpuinfo:
processor	: 0
cpu		: 7447A, altivec supported
clock		: 1249.999995MHz
revision	: 1.2 (pvr 8003 0102)
bogomips	: 82.94
timebase	: 41620907
platform	: PowerMac
model		: PowerMac10,1
machine		: PowerMac10,1
motherboard	: PowerMac10,1 MacRISC3 Power Macintosh 
detected as	: 287 (Mac mini)
pmac flags	: 00000010
L2 cache	: 512K unified
pmac-generation	: NewWorld
Memory		: 256 MB
Comment 4 Jon Hull 2009-09-18 18:42:03 EDT
Same crash same errors as original post on iMac G3 700mhz slot load.

I installed this system today from netinstall thus I had no other kernels available to boot from. I installed the previous version by downloading the kernel packages with yumdownloader while booted into the install cd in rescue mode chrooted to the system / partition. It boots fine with previous versions. Only crashes on 2.6.30.5-43.
Comment 5 Matthew McGillis 2009-09-20 12:13:29 EDT
Installed Fedora 11 after install when it reboots get this:

kernel coherency: off != device tree_coherency: on
------------[ cut here ]------------
kernel BUG at arch/powerpc/kernel/setup-common.c:653!
Oops: Exception in kernel mode, sig: 5 [#1]
PowerMac
Modules linked in:
NIP: c06acd84 LR: c06acd04 CTR:00000000
REGS: ef81e90 TRAP: 0700 Not tainted (2.6.30.5-43.fcli.ppc)
NSR: 00029032 <EE,ME,CE,IR,DR> CR: 24000022 XER: 00000000
TASK = ef868000[1] 'swapper' THREAD: ef870000
GPR00: c06acd84 ef871f40 ef868000 00000034 00003ed0 ffffffff fffffffff 00000000
GPR08: ef92aed0 c0742164 00000000 ef871f40 24000042 00000000 011fb067 011fb64d
GPR16: c06f25ar 000000bb 011fb52e 011fb52e ffbc0900 011fb990 00c000000 00234000
GPR24: 00000000 007e1000 40c00000 c0750000 00000000 00000000 efffa7ac ef071f40
NIP [c06acd04] check_cache_coherency+0x6c/0x98
LR [c06acd04] check_cache_coherence+0x6c/0x98
Call Trace:
[ef871f40] [c06acd04] check_cache_coherency+0x6c/098 (unreliable)
[ef871f60] [c0003d44] do_one_initcall+07c/0x1f0
[ef871fd0] [c06a6278] kernel_init+0x90/0x10c
[ef871ff0] [c00197c0] kernel_thread+0x4c/0x68
Instruction dump:
7c7d1b70 7fc3f378 4b969b69 2f9d0000 40be0028 3c60c060 3c80c060 3ca0c063
8884a69d 38a5e5d0 3863b281 4be6481d <0fe00000> 48000000 38600000 397f0020
---[ end trace 184e3dcfb12dd98c ]---
Kernel panic - not syncing: Attempted to kill init!
Call Trace:
[ef871e20] [c000a844] show_stack+0c4/0x1b0 (unreliable)
[ef871c60] [c05113fc] dump_stack+0x2c/044
[ef871c70] [c05114c0] panic+0xac/0x188
[ef871cc0] [c005d8ef] do_exit+0x9c/0x688
[ef871d10] [c0017254] die+0x234/0x260
[ef871d40] [c001751c] _exception+0x7c/0x190
[ef871e30] [c050d790] program_check_exception+0x5b8/0x604
[ef871e80] [c0019fffc] ret_from_except_full+0x0/0x4c
--- Exception: 700 at check_ache_coherency+0x6c/0x90
    LR = check_cache_coherency+0x6c/0x98
[ef8871f60] [c0003d44] do_one_initcall+0x7c/0x1f0
[ef871fd0] [c06a6278] kernel_init+0x90/0x10c
[ef871ff0] [c00197c0] kernel_thread+0x4c/0x68
Rebooting in 180 seconds..


Note some of the above hex values may have mistakes in them it was translated from attached image.
Comment 6 Matthew McGillis 2009-09-20 12:15:28 EDT
Created attachment 361826 [details]
Screen capture of panic
Comment 7 schlauf 2009-09-20 12:27:55 EDT
A very similar kernel panic as depicted by Matthew (comparing the screen shot with my own computer) occurs to me on my iBook G4. After NetInstall (where the most recent kernel is being downloaded) and the subsequent reboot, not even the first splash screen is shown; instead, the reboot loop is entered.

If any help from my side is needed (exact wording of failure etc.), feel free to contact me!
Comment 8 macro 2009-09-22 15:44:50 EDT
Me too on a G4 cube:

- 2.6.29.6-213.fc11.ppc works as normal
- 2.6.30.5-43.fc11.ppc exhibits this bug


$ cat /proc/cpuinfo 
processor	: 0
cpu		: 7400, altivec supported
temperature 	: 36 C (uncalibrated)
clock		: 450.000000MHz
revision	: 2.9 (pvr 000c 0209)
bogomips	: 49.66
timebase	: 24907667
platform	: PowerMac
model		: PowerMac5,1
machine		: PowerMac5,1
motherboard	: PowerMac5,1 MacRISC2 MacRISC Power Macintosh
detected as	: 68 (PowerMac G4 Cube)
pmac flags	: 00000014
L2 cache	: 1024K unified
pmac-generation	: NewWorld
Memory		: 1536 MB
Comment 9 Chuck Ebbert 2009-09-25 00:21:29 EDT

*** This bug has been marked as a duplicate of bug 521703 ***

Note You need to log in before you can comment on or make changes to this bug.