Bug 521703 - kernel panic: powerpc coherency mismatch: 2.6.30.5-43 setup-common.c:653
kernel panic: powerpc coherency mismatch: 2.6.30.5-43 setup-common.c:653
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
powerpc Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 521597 522876 522963 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-07 16:33 EDT by Stefan Schulze Frielinghaus
Modified: 2009-10-12 17:43 EDT (History)
11 users (show)

See Also:
Fixed In Version: 2.6.30.8-64.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-26 04:52:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel panic at boot time (150.42 KB, image/jpeg)
2009-09-07 16:33 EDT, Stefan Schulze Frielinghaus
no flags Details
higher quality screenshot of concerned kernel panic (152.11 KB, image/png)
2009-09-13 21:55 EDT, bugz102
no flags Details

  None (edit)
Description Stefan Schulze Frielinghaus 2009-09-07 16:33:33 EDT
Created attachment 360016 [details]
kernel panic at boot time

Description of problem:
A kernel panic appears as soon as the yaboot boot manager loads the kernel.

Version-Release number of selected component (if applicable):
2.6.30.5-43

How reproducible:
Just boot

Additional info:
I've included a "screenshot" done via my quite old camera ... the focus hmm yeah the focus sucks ;-)
Comment 1 Chuck Ebbert 2009-09-08 12:48:24 EDT
kernel coherency:on != device tree_coherency: off

kernel BUG at arch/powerpc/kernel/setup-common.c:653!
Comment 2 Chuck Ebbert 2009-09-08 13:03:24 EDT
Caused by having Amiga One support enabled. Fixed in 2.6.30.5-50
Comment 3 Chuck Ebbert 2009-09-08 13:15:17 EDT
*** Bug 521597 has been marked as a duplicate of this bug. ***
Comment 4 bugz102 2009-09-13 21:55:02 EDT
Created attachment 360868 [details]
higher quality screenshot of concerned kernel panic

I wasn't sure if this would help, but I was able to photograph it more legibly.
Comment 5 Stefan Schulze Frielinghaus 2009-09-14 03:58:32 EDT
(In reply to comment #4)
> Created an attachment (id=360868) [details]
> higher quality screenshot of concerned kernel panic
> 
> I wasn't sure if this would help, but I was able to photograph it more legibly.  

Actually the bug should be already fixed (see comment #2). I will close this bug as soon as a new kernel release is made public and I could test that release.
Comment 6 Chuck Ebbert 2009-09-25 00:20:29 EDT
*** Bug 522963 has been marked as a duplicate of this bug. ***
Comment 7 Chuck Ebbert 2009-09-25 00:21:29 EDT
*** Bug 522876 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2009-09-25 12:02:20 EDT
kernel-2.6.30.8-64.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/kernel-2.6.30.8-64.fc11
Comment 9 Stefan Schulze Frielinghaus 2009-09-26 04:52:38 EDT
The new version (2.6.30.8-64) works fine. Thanks!
Comment 10 Joel Rees 2009-09-27 02:01:18 EDT
How do you get 2.6.30.8-64?

I try yum update, and it doesn't see it. And yum info only shows to 5-43.fc11 .

https://www.redhat.com/archives/fedora-list/2009-September/msg02010.html
Comment 11 Stefan Schulze Frielinghaus 2009-09-27 03:37:47 EDT
(In reply to comment #10)
> How do you get 2.6.30.8-64?
> 
> I try yum update, and it doesn't see it. And yum info only shows to 5-43.fc11 .

It takes some time until the package is shipped completely. For example at the moment it is only available in the testing tree. Additionally it takes some time to sync the mirrors.

If you still want to update (take note that it is still in the testing tree), then you have two options:

- run "yum update --enablerepo=updates-testing kernel"

- or you can use the link from comment #8, click on builds and download all the needed RPMs manually. Then run "rpm -Uvh kernel-*" and the new ones get installed.

Or just wait until it gets pushed to the stable tree.
Comment 12 Francesco Vollero 2009-09-28 09:20:35 EDT
But until now, no one can install fedora on ppc because of this bug. How long we have to wait?
Comment 13 Jason Ritzke 2009-09-28 19:30:34 EDT
(In reply to comment #12)
> But until now, no one can install fedora on ppc because of this bug. How long
> we have to wait?  

This is a valid point. The anaconda bug on the Fedora 11 ppc DVD forces even full dvds to netinst, unless you use an additional dvd as a repo (which is a problem in certain systems). This means that any new installations on such machines will fail until this bugfix is put through the system. Basically, atm fedora 11 stable is *BROKEN* for ppc users who only have one internal dvd-rom drive and no external dvd-rom drive.
Comment 14 Francesco Vollero 2009-09-29 09:19:33 EDT
(In reply to comment #13)

> This is a valid point. The anaconda bug on the Fedora 11 ppc DVD forces even
> full dvds to netinst, unless you use an additional dvd as a repo (which is a
> problem in certain systems). This means that any new installations on such
> machines will fail until this bugfix is put through the system. Basically, atm
> fedora 11 stable is *BROKEN* for ppc users who only have one internal dvd-rom
> drive and no external dvd-rom drive.  

Thanks, as i read here, the kernel update is in updates-testing, i added it as additional repository, but still missing at all, at least on italian repository.
Comment 15 Alexey Kuznetsov 2009-09-29 09:24:06 EDT
update still not in testing repo, and here is no official itallian one
Comment 16 Alexey Kuznetsov 2009-09-29 09:24:47 EDT
ups, it here....

http://koji.fedoraproject.org/koji/buildinfo?buildID=133596
Comment 17 Fedora Update System 2009-09-29 10:33:36 EDT
kernel-2.6.30.8-64.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Vlado Plaga 2009-09-30 13:40:05 EDT
Maybe I did something wrong, but I still can't boot with this kernel. Now I get a "vmlinuz-2.6.30.8-64.fc11.ppc: Not a valid ELF image" when I try to boot my iMac with the latest F11 kernel. Before I had the problem described in #522876 (now a duplicate of this bug).
Comment 19 Francesco Vollero 2009-09-30 15:02:53 EDT
A rough fix for installation process is to start installing FC10 and after moving to FC11 with the new 2.6.30.8-64 and work perfect!
Comment 20 Vlado Plaga 2009-10-12 17:43:18 EDT
Indeed I had done something wrong when I reported the problem with the kernel image (2009-09-30), a mistake in my handwritten yaboot.conf bootloader configuration file. Now I have a working F11 setup. I still had to slightly change the kernel 'append' line, though: with the default 'append="rhgb quiet"' I always got a non-fatal "kernel failure" in the nvidiafb driver, which extremely slowed down the boot process (to more than four minutes). I fixed that by changing the 'append' line to "quiet video=ofonly".

Note You need to log in before you can comment on or make changes to this bug.