Bug 522941 - 64-bit Wine 1.1.29 breaks audio tab, 32 bit apps will not load and WINE icons gone
Summary: 64-bit Wine 1.1.29 breaks audio tab, 32 bit apps will not load and WINE icons...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: wine
Version: 11
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-12 13:00 UTC by Rob Whalley
Modified: 2010-06-28 14:37 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-28 14:37:12 UTC


Attachments (Terms of Use)
Howto switch to wine-git (32-bit only) (3.53 KB, text/plain)
2009-09-13 12:54 UTC, Rob Whalley
no flags Details
wine.menu (300 bytes, application/octet-stream)
2009-09-16 21:26 UTC, Rob Whalley
no flags Details
Wine.directory (66 bytes, application/octet-stream)
2009-09-16 21:27 UTC, Rob Whalley
no flags Details

Description Rob Whalley 2009-09-12 13:00:52 UTC
Description of problem:

I have just updated my Fedora 11 system and part of the update included Wine 1.1.29 from the previous version (1.1.23 or 1.1.26, I cannot recall now). This seems to have caused several problems on my system.

Basic system info:
Fedora 11 64-bit
2x AMD Athlon(tm) 64 X2 Dual Core Processor 5600+
GNOME 2.26.3
Kernel 2.26.30.5-43.fc11.x86_64

1. The Audio tab in winecfg crashes wine.

When I click on the Audio tab, winecfg first displays this message:

"There is no audio driver currently specified in the registry.
A recommended driver has been selected for you. You can use this driver or
select another driver if available.
You must click Apply for the selection to take effect."

If the OK button is pressed then a windows appears advising an error with winecfg.exe has occurred.
If this error is acknowledged then a winedbg.exe error occurs.
Clicking OK on this message just cycles the error over and over. Termianl output when performing the above steps:

[rob@fedora ~]$ winecfg
wine: Unhandled page fault on write access to 0x8041d5f0 at address 0x39244826e3 (thread 0009), starting debugger...
wine: Unhandled page fault on read access to 0x00000028 at address 0x7f8b65330fc7 (thread 001c), starting debugger...
wine: Unhandled page fault on read access to 0x00000028 at address 0x7f6745890fc7 (thread 001e), starting debugger...
wine: Unhandled page fault on read access to 0x00000028 at address 0x7f8532de0fc7 (thread 0020), starting debugger...
wine: Unhandled page fault on read access to 0x00000028 at address 0x7f8866530fc7 (thread 0022), starting debugger...
wine: Unhandled page fault on read access to 0x00000028 at address 0x7f69a9140fc7 (thread 0024), starting debugger...
wine: Unhandled page fault on read access to 0x00000028 at address 0x7f3de4c90fc7 (thread 0026), starting debugger...
wine: Unhandled page fault on read access to 0x00000028 at address 0x7f84e4a70fc7 (thread 0028), starting debugger...

I tried starting from fresh, as in removing all wine applications then reinstalling from scratch.
I also ensured I tried a fresh .wine folder after restarting the machine by doing:

[rob@fedora ~]$ mv .wine wine
[rob@fedora ~]$ winecfg
wine: created the configuration directory '/home/rob/.wine'
err:mshtml:install_cab Could not extract package: 80070002
Could not load wine-gecko. HTML rendering will be disabled.
wine: configuration in '/home/rob/.wine' has been updated.

I still get the crash when clicking on the Audio tab.

The relevant section of the user.reg file the audio tab seems to be trying to set is:
[Software\\Wine\\Drivers] 1252521555
"Audio"="pulse"

Note, this is the setting that worked find with the previous of wine - in my tests, this key was not created when I tried a blank .wine folder. It seems to not like Pulseaudio at all.


2. Some programs that did run with the previous version do not run now

Starting Oblivion from the command line now shows an error that seems to indicate 32 bit apps will no longer run on my 64 bit system: 

env WINEPREFIX="/home/rob/.wine" WINEDEBUG=-all wine "C:\Program Files\Bethesda Softworks\Oblivion\OblivionLauncher.exe"
Trying to load PE image for unsupported architecture (I386)
Trying to load PE image for unsupported architecture (I386)

Notepad works fine.


3. All WINE icons have now disappeared from the Applications menu

Noted two buxfixes when the new version of wine was installed:
https://bugzilla.redhat.com/show_bug.cgi?id=495953
https://bugzilla.redhat.com/show_bug.cgi?id=479649

However, neither of the above two pages explains why there are no menus at all now.


Version-Release number of selected component (if applicable): 1.1.29


How reproducible:
Always

Steps to Reproduce:
1. Install new version of wine using yum install wine
2. Load winecfg
3. Click on the Audio tab and wine will crash after first prompt
  
Actual results:
After starting winecfg, then clicking on the Audio tab, get an unhandled page fault in both winecfg.exe and windedbg.exe

Expected results:
To be able to select audio options. Also, to be able to load the same 32 bit programs as under previous version of wine. Where are the wine icons that were present before? Does not seem to be properly explained in bug fixes as far as I can see.

Additional info:

Comment 1 Rob Whalley 2009-09-12 13:11:12 UTC
Hmm. With reference to part 2 above (problems with 32 bit applications), I may have been a bit hasty. It seems that if I change the command to...

env WINEPREFIX="/home/rob/.wine" WINEDEBUG=-all wine32 "C:\Program Files\Bethesda
Softworks\Oblivion\OblivionLauncher.exe"

...then the program will load. Seems as though I need to now specify using a 32-bit version of wine. Unsure why this is the case, unless before there was only a 32-bit version installed and now the 64-bit version is installed as well

[rob@fedora ~]$ yum list *wine*.i586

Installed Packages
wine-capi.i586                         1.1.29-1.fc11                    @updates
wine-cms.i586                          1.1.29-1.fc11                    @updates
wine-core.i586                         1.1.29-1.fc11                    @updates
wine-ldap.i586                         1.1.29-1.fc11                    @updates
wine-pulseaudio.i586                   1.1.29-1.fc11                    @updates
wine-twain.i586                        1.1.29-1.fc11                    @updates

[rob@fedora ~]$ yum list *wine*.X86_64

Installed Packages
wine.x86_64                             1.1.29-1.fc11                   @updates
wine-capi.x86_64                        1.1.29-1.fc11                   @updates
wine-cms.x86_64                         1.1.29-1.fc11                   @updates
wine-core.x86_64                        1.1.29-1.fc11                   @updates
wine-ldap.x86_64                        1.1.29-1.fc11                   @updates
wine-pulseaudio.x86_64                  1.1.29-1.fc11                   @updates
wine-twain.x86_64                       1.1.29-1.fc11                   @updates

Note that I am using my pre-1.1.29 user.reg file and I also get sound, so it just seems to be the winecfg app that doesn't like it.

Comment 2 Daniel McNamara 2009-09-13 09:15:08 UTC
Concur similar issues happening here. Not at all happy with the way this package change was handled.

Using wine32 will launch the app (in this case WoW) but no sound and application will freeze if alt-tabbed out of. Did not occur prior to this package change.

I appear to have all the correct 32bit versions of wine package installed. No output from wine or the OS logs seems indicate the reason for the lack of sound or application freeze behaviour

Comment 3 Andreas Bierfert 2009-09-13 10:16:00 UTC
1. This is a bug in 64bit wine. See http://bugs.winehq.org/show_bug.cgi?id=19316. To run the 32bit winecfg type 'wine32 winecfg'

2. Starting with 1.1.26 wine is build as 32bit and 64bit version. However wine currently can run 32bit binaries only on the 32bit version (and 64bit on the 64bit build). Therefore both the 64bit and the 32bit build are available on x86_64 as most people do only need the 32bit version. /usr/bin/wine has been changed to act as a dispatcher between the 32bit and the 64bit version /usr/bin/wine{32,64}. I am open to suggestions to improve this little script.

3. As to why you are having trouble with the desktop entries I am not sure. Do you see a Wine menu containing the default wine apps? Do you have the wine-desktop package installed?

Comment 4 Rob Whalley 2009-09-13 10:54:49 UTC
1. Excellent, that answers a lot of my questions, thank you for the swift response - I should have checked that myself! 

I can confirm that works as expected. Worth noting in passing that sometimes starting a wine app this way it doesn't work the first time due to pulseaudio being weird:

pulse.c:716: PULSE_WaveInit: Assertion `PULSE_context' failed.
err:module:attach_process_dlls "winmm.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"C:\\windows\\system32\\winecfg.exe" failed, status 80000101

Works on the second attempt though, so not a big problem.

2. Ah, well that's what I was wondering - in my defence I did have a quick scan of the Wine release notes for the latest version, but if this has been in since 1.1.26, that would explain why I didn't see it ;)

Re: the /usr/bin/wine script, it looks good to my untrained eyes, just a slight typo in the lines:
echo "Your are trying to run a 64bit application. Please install the 64bit version of wine."
echo "Your are trying to run a 64bit application on a 32bit installation of Fedora. You need a 64bit version of Fedora to run this application."
echo "Your are trying to run a 32bit application. Please install the 32bit version of wine."

Should be "You're" or "You are" - probably the latter ;)

3. I'm afraid that no matter how many times I remove and reinstall the wine packages (including the wine-desktop package), the icons do not show up under Gnome. Apologies, the wine-desktop and wine-common pacakages didn't show up in my earlier post as I forgot to check for packages with noarch...

I have right-clicked the Applications menu and gone to Edit Menus, but they are not present at all as far as I can see - it's a mystery :(

Comment 5 Daniel McNamara 2009-09-13 11:23:06 UTC
Also confirm that wine32 winecfg works - however test sounds work fine from the winecfg control panel but still not getting anything from the application itself.

Attempting to get wine to give me more information regarding this and the alt-tab freezing off the application.

Comment 6 Daniel McNamara 2009-09-13 11:25:35 UTC
Sound issue resolved after giving pulseaudio a bit of a kick. Application freezing issue when an alt-tab (or ctrl-tab) still occuring

Comment 7 Rob Whalley 2009-09-13 11:29:29 UTC
Re: missing icons, did following tests
Removed:
~/.local/share/desktop-directories
~/.local/share/applications

Logged out of Gnome and back in again.

Did:
sudo yum remove wine-capi.i586 wine-cms.i586 wine-core.i586 wine-ldap.i586
wine-pulseaudio.i586 wine-twain.i586 wine.x86_64 wine-capi.x86_64
wine-cms.x86_64 wine-core.x86_64 wine-ldap.x86_64 wine-pulseaudio.x86_64
wine-twain.x86_64

(this also removed wine-desktop and wine-common)

Then:
sudo yum clean all

Then re-installed wine

Still no icons... it would help if I knew how the "hard coded" icons are stored
(for want of a better term). Certainly customised icons don't seem to be
causing the problem.

Comment 8 Daniel McNamara 2009-09-13 11:41:53 UTC
OK.. so it might be some weird overlay issue with the new wine and WoW. Run at standard full screen mode you get the freezing behaviour. Run WoW windowed at the same resolution and maximised it works just fine. Very odd.

Comment 9 Rob Whalley 2009-09-13 11:56:18 UTC
It's very possible the new wine has broken a few things...

WoW WineApp page looks to have some interesting info...
http://appdb.winehq.org/objectManager.php?sClass=version&iId=17421

Don't have the game myself, but in the notes it states "Currently, you MUST downgrade to wine 1.1.26 or lower to install WoW due to regressions."

Might be worth posting on that page too in case someone else is aware of this issue?

As a side note, Steam is also broken - See: http://appdb.winehq.org/appview.php?iVersionId=1554

"As other have said, 1.1.29 completely breaks the UI, to where it flashes all sorts of different colors.  It's mostly black for me, so I can't really find anything.  It's basically unusable."

I may try the wine-git 32-bit version and see how I get on with that...

Comment 10 Rob Whalley 2009-09-13 12:54:04 UTC
Created attachment 360840 [details]
Howto switch to wine-git (32-bit only)

If there are applications that break under the current version of wine, you can always try compiling the git version yourself - these are the steps I had to follow to fix Steam.

Comment 11 Andreas Bierfert 2009-09-13 21:02:27 UTC
(In reply to comment #9)
> As a side note, Steam is also broken - See:
> http://appdb.winehq.org/appview.php?iVersionId=1554

This is fixed in 1.1.29-3

Comment 12 Rob Whalley 2009-09-13 22:52:13 UTC
Nice, hopefully this will sort out the problems. Notice it hasn't been pushed to testing yet - see https://admin.fedoraproject.org/updates/wine-1.1.29-3.fc11
...but I'll try it when it is. Looking at https://fedoraproject.org/wiki/QA/Updates_Testing this should be as simple as:

sudo yum install wine --enablerepo=updates-testing

Will feedback more information later - thanks again Andreas.

Comment 13 Rob Whalley 2009-09-15 07:34:12 UTC
Status is now showing as in testing but I think it hasn't been pushed out to mirrors yet as yum install wine --enablerepo=updates-testing still wants to install 1.1.29-1. Will be away for a couple of days so will check again on my return.

Comment 14 Rob Whalley 2009-09-16 21:25:17 UTC
Confirmed that 1.1.29-3 solves the problem with Steam. Also briefly tried Oblivion, both seem to be working ok (hl2.exe seems to crash when exiting the game but is otherwise fine).

Still no menu items so we can probably assume that this is something on my machine... though I wish I knew what.

Unless anyone else has the problem with disappearing menus, I'd say this bug can be closed - although if anyone has any pointers on why my Wine menu items are missing, I'd be grateful!

Anyone able to shed light on how rpm packages create menus under "application" in Gnome (they're obviously different from user created menus, but I can't work out how...)?

Have looked at:
http://standards.freedesktop.org/menu-spec/menu-spec-1.0.html#third-party-howto

Confirmed wine icons were located here:
/usr/share/applications

fedora-wine.desktop
fedora-wine-wineboot.desktop
fedora-wine-mime-msi.desktop
fedora-wine-winecfg.desktop
fedora-wine-notepad.desktop
fedora-wine-winefile.desktop
fedora-wine-oleview.desktop
fedora-wine-winemine.desktop
fedora-wine-regedit.desktop
fedora-wine-winhelp.desktop
fedora-wine-uninstaller.desktop
fedora-wine-wordpad.desktop

Did:
locate applications-merged
/etc/xdg/menus/applications-merged

wine.menu suggested the category was named X-Wine
<Category>X-Wine</Category>
Checked and confirmed that a test icon (wine-config.desktop) has this as its category.

Please could someone else running 64-bit Fedora 11 post the contents of the following files? - this may give me a clue as to what is wrong with my setup:

/etc/xdg/menus/applications-merged/wine.menu
/usr/share/desktop-directories/Wine.directory

Comment 15 Rob Whalley 2009-09-16 21:26:03 UTC
Created attachment 361380 [details]
wine.menu

Attached wine.menu

Comment 16 Rob Whalley 2009-09-16 21:27:38 UTC
Created attachment 361381 [details]
Wine.directory

Attached Wine.directory

Please can someone post back if their versions of the above two files are different?

Comment 17 Andre Robatino 2009-09-16 21:36:45 UTC
Both files belong to the wine-desktop package, which you can verify with "rpm -V wine-desktop".  My version of this package verifies correct, and my versions of the two files are identical to yours.

Comment 18 Rob Whalley 2009-09-17 11:09:15 UTC
Confirmed, I get:
.......T.    /etc/xdg/menus/applications-merged/wine.menu
.......T.    /usr/share/applications/fedora-wine-wineboot.desktop
.......T.    /usr/share/applications/fedora-wine.desktop

I created a new user account on the same box and found the menus with no problem. This confirms it isn't a bug as far as I can tell. The offending file was /home/rob/.config/menus/applications.menu. I had to comment out some of the lines as shown below:

<Name>Applications</Name>
<MergeFile type="parent">/etc/xdg/menus/applications.menu</MergeFile>
<Menu>
	<Name>Other</Name>
	<Include>
		<Filename>alacarte-made-1.desktop</Filename>
	</Include>
	<AppDir>/home/rob/.local/share/applications</AppDir>
	<!-- <Exclude> -->
	<!-- 	<Filename>fedora-wine.desktop</Filename> -->
	<!-- </Exclude> -->
</Menu>
<!-- <Menu> -->
<!-- 	<Name>wine-wine</Name> -->
<!-- 	<Deleted/> -->
<!-- </Menu> -->

I think I know what caused this problem. At one point, I had two wine menus - one with the wine package apps in (e.g. winecfg), and one which was created when an application was installed. I'm not sure why a duplicate menu item was created. After removing the application, I removed the duplicate wine folder as it had not been removed automatically.

In other words, the problem with the icons was my fault, due to not fully understanding how the menus work under Gnome. Thank you for all the assistance and sorry for not picking up on this earlier - at least I know where to look in future.

From my point of view, all issues have now been addressed and this bug can be closed - though worth noting that the corrections to the echoed text in the /usr/bin/wine script still need to be made. Would also be interesting to know if the testing package resolved Daniel's problems with WoW, as I do not have this application to test with.

Comment 19 Rob Whalley 2009-09-17 11:25:34 UTC
Actually only following lines need commenting:
<!-- <Menu> -->
<!--  <Name>wine-wine</Name> -->
<!--  <Deleted/> -->
<!-- </Menu> -->

The lines showing as Exclude should be there as there's a "Wine Windows Program Loader" that sits under the Other category if it's not excluded... ;)

Comment 20 Peter Robinson 2009-11-06 13:24:47 UTC
I'm seeing the same crash with the same crash in winecfg with the Audio.

[perobinson@neo ~]$ winecfg
fixme:seh:execute_cfa_instructions 7fc14a4e221d: DW_CFA_remember_state not implemented
fixme:seh:execute_cfa_instructions 7fc14a4e2220: DW_CFA_restore_state not implemented
err:seh:call_stack_handlers no exception data found in system library for function 7fc100000054
err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr 0x7fc1551a5983
[perobinson@neo ~]$

Comment 21 Robin Bowes 2009-11-15 01:26:26 UTC
I'm currently having similar problems. I have the latest wine packages (as of today):

$ rpm -qa | grep wine | sort
wine-1.1.32-1.fc11.i586
wine-capi-1.1.32-1.fc11.i586
wine-cms-1.1.32-1.fc11.i586
wine-common-1.1.32-1.fc11.noarch
wine-core-1.1.32-1.fc11.i586
wine-core-1.1.32-1.fc11.x86_64
wine-desktop-1.1.32-1.fc11.noarch
wine-esd-1.1.32-1.fc11.i586
wine-fonts-1.1.32-1.fc11.noarch
wine-jack-1.1.32-1.fc11.i586
wine-ldap-1.1.32-1.fc11.i586
wine-nas-1.1.32-1.fc11.i586
wine-pulseaudio-1.1.32-1.fc11.i586
wine-pulseaudio-1.1.32-1.fc11.x86_64
wine-twain-1.1.32-1.fc11.i586

I have problems running EAC and mp3tag from the menu items:

$ env WINEPREFIX="/home/robin/.wine" wine "C:\Program Files\Exact Audio Copy\EAC.exe"
Trying to load PE image for unsupported architecture (I386)
Trying to load PE image for unsupported architecture (I386)


env WINEPREFIX="/home/robin/.wine" wine "C:\Program Files\Mp3tag\MP3TAG.EXE"

Also, winecfg crashes when I hit the Audio tab.

$ env WINEPREFIX="/home/robin/.wine" wine "C:\Program Files\Mp3tag\MP3TAG.EXE"
Trying to load PE image for unsupported architecture (I386)
Trying to load PE image for unsupported architecture (I386)

Both of these issues are fixed if I explicitly run wine32, eg:

$ env WINEPREFIX="/home/robin/.wine" wine32 "C:\Program Files\Exact Audio Copy\EAC.exe" 
# normal output - runs OK

$ env WINEPREFIX="/home/robin/.wine" wine32 "C:\Program Files\Mp3tag\MP3TAG.EXE"
# normal output - runs OK

$ wine32 winecfg

Looking at the /usr/bin/wine script, it appears to be basically broken.

The first thing it does is look for the program to be run to test its architecture. Well, if the file is specified using its windows name (eg. "C:\Program Files\Mp3tag\MP3TAG.EXE") then [ -f "${1}" ] won't find it. This means the script drops through and uses wine64 by default.

I'm working round this by explicitly specifying wine32 for those programs that I use regularly. However, the script should probably be fixed. 

I *think* the fix is to simply convert "C:\Program Files\Mp3tag\MP3TAG.EXE" to a physical linux path before testing its architecture, and I'm sure there must be an easy "wine" way to , but I'm afraid I don't know it!

R.

Comment 22 Bug Zapper 2010-04-28 10:19:22 UTC
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 23 Bug Zapper 2010-06-28 14:37:12 UTC
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.