Bug 522942 - Drm keeps trying to set the video mode for the monitor with Intel 945GM
Summary: Drm keeps trying to set the video mode for the monitor with Intel 945GM
Keywords:
Status: CLOSED DUPLICATE of bug 522909
Alias: None
Product: Fedora
Classification: Fedora
Component: libdrm
Version: rawhide
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-12 13:39 UTC by Pramod Dematagoda
Modified: 2009-09-12 21:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-12 21:15:27 UTC


Attachments (Terms of Use)

Description Pramod Dematagoda 2009-09-12 13:39:37 UTC
Description of problem: The DRM keeps trying to set the video mode of the monitor in an infinite loop which prevents logging in through GDM quickly enough to do anything at all due to the very slow speed of rendering, the CPU is unaffected in this as it is possible to login through the terminal and top does not show anything out of the ordinary.


Version-Release number of selected component (if applicable): 2.4.12-0.10


How reproducible: Install the latest kernel and libdrm updates and restart the PC to use them.


Steps to Reproduce:
1. Install the latest kernel and libdrm updates.
2. Restart the PC.
3. Try and log in.
  
Actual results: GDM takes ages to load up and it takes even more time to try and login.


Expected results: GDM should load up in seconds and login should be very quick.


Additional info: I did not log in to see if the problem persisted, but I don't think it's really necessary to go that far when dmesg has tons of lines of this:-
kernel: [drm] TV-14: set mode NTSC 480i 0
even at GDM. This is on an Intel 945GM.

Comment 1 Will Woods 2009-09-12 21:15:27 UTC

*** This bug has been marked as a duplicate of bug 522909 ***


Note You need to log in before you can comment on or make changes to this bug.