Bug 523005 - making video full screen on external monitor freezes X
Summary: making video full screen on external monitor freezes X
Keywords:
Status: CLOSED DUPLICATE of bug 499895
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 11
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-13 09:22 UTC by Peter Janakiev
Modified: 2009-10-26 08:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-26 08:08:13 UTC


Attachments (Terms of Use)

Description Peter Janakiev 2009-09-13 09:22:19 UTC
Description of problem:When I connect external monitor to the laptop and start a video playback (totem or gnome-mplayer) and then try to make the video fullscreen the picture freezes, sometimes I am able to move the mouse, sometimes even the pointer does not responds. I cannot then switch to VT to try and see the logs, the only way to continue is to reset the machine.


Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.7.0-7.fc11.i586.rpm

How reproducible:
always

Steps to Reproduce:
1. Connect external monitor and activate it in non-mirrored mode from the monitor configuration (LVDS might be off or on, it does not matter)
2. play a video with Video overlay output
3. make the video fullscreen (with totem it takes 2 tries sometimes, so make it full screen then back to normal and then again fullscreen), with mplayer it freezes from the first try
  
Actual results:
The picture freezes and X stops responding

Expected results:
Normal playback on external monitor

Additional info:
I have followed some threads on Xvideo issues on intel hardware and added Tiling -> False option (the hardware is X3100/965) - it does not seem to have any effect on this issue. It only appears when I use external monitor (22inches samsung - 1650x1200), when I use LVDS output it plays okay always. I use the external monitor mainly for video playback and this is a show stopper really. 
I am not sure how to collect logs as switching to VT does not work when this happens and I have to reset the laptop by pressing powerbutton and holding it until the machine stops. 
This is lspci:
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

Comment 1 Kieran Clancy 2009-10-26 06:46:59 UTC
Dupe of bug 499895 ?

Comment 2 Peter Janakiev 2009-10-26 08:08:13 UTC
Yes, a duplicate. However the freze is related to Video overlay only as output driver, using GL for video works fine and as it seem to not have any performance impact on X3100 is use that for now, until Video overlay is fixed.

*** This bug has been marked as a duplicate of bug 499895 ***


Note You need to log in before you can comment on or make changes to this bug.