Bug 523064 - ifup/ifdown should call NM for NM-controlled devices
Summary: ifup/ifdown should call NM for NM-controlled devices
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 513453 525816 (view as bug list)
Depends On:
Blocks: 550154
TreeView+ depends on / blocked
 
Reported: 2009-09-13 20:09 UTC by W. Michael Petullo
Modified: 2014-03-17 03:20 UTC (History)
9 users (show)

Fixed In Version: initscripts-9.08-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 550154 (view as bug list)
Environment:
Last Closed: 2010-03-03 21:34:39 UTC
Type: ---


Attachments (Terms of Use)

Description W. Michael Petullo 2009-09-13 20:09:51 UTC
Description of problem:
I have configured a wireless network adapter using nm-connection-editor. Ifup fails to bring up the interface.

Version-Release number of selected component (if applicable):
initscripts-8.98-1.1.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Configure a wireless adapter using nm-connection-editor (select "available to all users")
2. Try to bring the interface up using ifup "Conf"
  
Actual results:
Usage: grep [OPTION]... PATTERN [FILE]...
Try `grep --help' for more information.
Usage: grep [OPTION]... PATTERN [FILE]...
Try `grep --help' for more information.

Determining IP information for ... done.
cat: /sys/class/net//ifindex: No such file or directory
/etc/sysconfig/network-scripts/ifup-eth: line 302: 1000 + : syntax error: operand expected (error token is "+ ")
Missing config file ifcfg-ifcfg-Flyn_Computing.

Expected results:
The interface is up.

Additional info:
My wireless adapter uses akmod-wl.

Comment 1 W. Michael Petullo 2009-09-13 23:15:07 UTC
The configuration that NetworkManager wrote was:

ESSID="XXX"
MODE=Managed
KEY_MGMT=WPA-PSK
TYPE=Wireless
BOOTPROTO=dhcp
PEERDNS=yes
PEERROUTES=yes
NAME="XXX"
UUID=XXX
ONBOOT=yes

I found that this was fixed by adding:

DEVICE=eth1

akmod-wl sets up /etc/udev/rules.d/70-persistent-net.rules so that my device is eth1.

So, since this was fixed by adding a DEVICE=eth1 line, should this be a NetworkManager bug?

Comment 2 Bill Nottingham 2009-09-14 20:12:43 UTC
Yes - if it's not named after the device, there needs to be a DEVICE= line.

Comment 3 Dan Williams 2009-09-30 14:48:14 UTC
NM doesn't add DEVICE= because your device names can change, irregardless of the udev rules to keep them the same because that doesn't always work.  In any case, that connection can apply fine to *any* device you plug in, not just eth1, and you didn't choose to limit it to only eth1 in the connection editor (by locking the connection to the device's MAC address).  I seem to recall that if there's an HWADDR, the initscripts will try to find that device even without a DEVICE= line Bill?  Or is that just that when there's both DEVICE and HWADDR, it makes sure DEVICE actually has that specific HWADDR?

Comment 4 Dan Williams 2009-09-30 14:48:41 UTC
*** Bug 525816 has been marked as a duplicate of this bug. ***

Comment 5 Bill Nottingham 2009-09-30 19:59:24 UTC
It's just used to make sure config + hwaddr match. We *could* make it try to automatically figure out the device, but there's no code for that now.

Comment 6 Dan Williams 2009-10-01 15:37:35 UTC
Ok, moving this to a bug about ifup/ifdown integration like we'd talked about for a long time making ifup/ifdown direct NM for NM-controlled devices.

Comment 7 Dan Williams 2009-10-01 15:38:04 UTC
*** Bug 526317 has been marked as a duplicate of this bug. ***

Comment 8 IBM Bug Proxy 2009-10-19 22:20:50 UTC
------- Comment From kumarr@linux.ibm.com 2009-10-19 18:14 EDT-------
Mirroring

Comment 9 Dan Williams 2009-10-26 22:13:25 UTC
*** Bug 513453 has been marked as a duplicate of this bug. ***

Comment 10 Bug Zapper 2009-11-16 12:20:20 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 11 Bill Nottingham 2010-03-03 21:33:15 UTC
The first cut of this will be in 9.07-1.

Comment 12 Fedora Update System 2010-03-03 21:44:30 UTC
initscripts-9.07-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/initscripts-9.07-1.fc13

Comment 13 W. Michael Petullo 2010-03-03 23:35:37 UTC
The new initscripts-9.07-1.fc13 package seems to work. Thanks, Bill and Dan.

Comment 14 Bill Nottingham 2010-03-04 14:46:01 UTC
Cool. Note that configurations that don't specify a device (like some wireless connections) aren't fully supported yet; ifup will work, but ifdown won't.

Comment 15 Fedora Update System 2010-03-20 03:49:21 UTC
initscripts-9.08-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.