Bug 525816 - wlan0 associates with nm-applet but "ifup wlan0" doesn't associate
Summary: wlan0 associates with nm-applet but "ifup wlan0" doesn't associate
Keywords:
Status: CLOSED DUPLICATE of bug 523064
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 10
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-25 21:21 UTC by Thomas Meyer
Modified: 2009-09-30 14:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-30 14:48:41 UTC


Attachments (Terms of Use)

Description Thomas Meyer 2009-09-25 21:21:02 UTC
Description of problem:
nm-applets manages somehow to connect the wireless network card to my AP.
Switching to runlevel 3, i.e. no X server and trying to manually connect the wireless network interface via "ifup wlan0" doesn't work.

iwconfig setup looks the same, i.e essid, WEP keys, but in non X server runlevel the wlan0 network interface just doesn't associate with the AP. I have no idea why is that. "iwlist wlan0 scan" works and shows my AP in non X server runlevel

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. switch to runlevel 3
2. try to bring fully and correct configured network interface wlan0 up; as root: "ifup wlan0"
3. Watch the connection fail.
  
Actual results:
"ifup wlan0" fails for no obvious reason, as it doesnt associate with the AP.

Expected results:
"ifup wlan0" should also associate with the AP and connect the computer to the internet.

Additional info:
T:  Bus=01 Lev=01 Prnt=01 Port=03 Cnt=01 Dev#=  2 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=02(comm.) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=0411 ProdID=00bc Rev= 0.06
S:  Manufacturer=Broadcom
S:  Product=WLI-U2-KG125S
S:  SerialNumber=8057
C:* #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=02(comm.) Sub=02 Prot=ff Driver=rndis_wlan
E:  Ad=81(I) Atr=03(Int.) MxPS=  16 Ivl=1ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=rndis_wlan
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=125us

Comment 1 Dan Williams 2009-09-30 14:48:41 UTC

*** This bug has been marked as a duplicate of bug 523064 ***


Note You need to log in before you can comment on or make changes to this bug.