Bug 523157 - Xorg crashes on login with compiz enabled
Summary: Xorg crashes on login with compiz enabled
Keywords:
Status: CLOSED DUPLICATE of bug 518748
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 11
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-14 09:19 UTC by Staffan Gimåker
Modified: 2018-04-11 06:53 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-30 15:04:36 UTC


Attachments (Terms of Use)
Xorg log from the crash (73.98 KB, text/plain)
2009-09-14 09:19 UTC, Staffan Gimåker
no flags Details
Updates applied before the problem surfaced (3.56 KB, text/plain)
2009-09-14 09:20 UTC, Staffan Gimåker
no flags Details
sudo lspci -v (8.43 KB, text/plain)
2009-09-14 09:23 UTC, Staffan Gimåker
no flags Details

Description Staffan Gimåker 2009-09-14 09:19:35 UTC
Created attachment 360903 [details]
Xorg log from the crash

Description of problem:
After entering the password in GDM and hitting enter, Xorg crashes and brings me back to the GDM screen. This happens only when compiz is enabled.

The logs read:
Xorg[1891]: segfault at 0 ip 00000000004e8e0b sp 00007fff5d85fb18 error 4 in Xorg[400000+1b6000]

The problem starting occurring after applying a batch up updates on Sept 13 (see attached yum.log). There's also a new kernel oops that started occurring after applying those updates, which I suspect might be related to the segfault.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Make sure Compiz is enabled.
2. Try to login.
  
Actual results:
Xorg crashes and brings you back to the login screen.

Expected results:
To be able to successfully login and arrive at the GNOME desktop.

Additional info:
The kernel oops can be found here: http://www.kerneloops.org/submitresult.php?number=714894

For others hitting the same problem, you can disable compiz from the console by typing: gconftool-2 --set --type string /desktop/gnome/session/required_components/windowmanager "metacity"

Comment 1 Staffan Gimåker 2009-09-14 09:20:22 UTC
Created attachment 360904 [details]
Updates applied before the problem surfaced

Comment 2 Staffan Gimåker 2009-09-14 09:23:02 UTC
Created attachment 360907 [details]
sudo lspci -v

Comment 3 Staffan Gimåker 2009-09-14 16:30:22 UTC
I'm still getting the same kernel oopses, so I guess that's not the cause of the problem.

Comment 4 Jeremy Fitzhardinge 2009-09-14 18:57:54 UTC
I'm seeing this crash on login, but no kernel oopses.

Comment 5 Andrey Petrov 2009-09-17 07:19:37 UTC
In addition, if you're not using compiz, and select System->Preferences->desktop-effects->enable desktop effects from the GNOME menu, you'll get the same crash and will be sent back to the login screen.

Comment 6 Luiz 2009-09-23 12:12:04 UTC
Compiz still crashes X with default kernel parameters on grub.conf and sends back to gdm. 

But odd enough, booting without kernel parameter "quiet" compiz works perfectly! Confirmed multiple times.

Kernel command line: ro root=UUID=106d3e94-d339-4f49-8db8-a0a2668a13e8 rhgb nosmp

00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

kernel-2.6.30.5-43.fc11.i586
mesa-dri-drivers-7.6-0.1.fc11.i586
mesa-libGL-7.6-0.1.fc11.i586
mesa-libGLU-7.6-0.1.fc11.i586
mesa-libGLw-6.5.1-7.fc11.i586
mesa-libOSMesa-7.6-0.1.fc11.i586
xorg-x11-drv-intel-2.7.0-7.fc11.i586
xorg-x11-server-common-1.6.4-0.1.fc11.i586

(WW) intel(0): Disabling Xv because no adaptors could be initialized.
(II) intel(0): direct rendering: DRI2 Enabled

xv still disabled... :(

Comment 7 Matěj Cepl 2009-09-23 14:24:15 UTC
Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x26) [0x4e8c46]
1: /usr/bin/Xorg(xf86SigHandler+0x6f) [0x47d99f]
2: /lib64/libc.so.6 [0x33dda33370]
3: /usr/lib64/dri/i965_dri.so(intelDestroyContext+0x116) [0x7fdae4b750a2]
4: /usr/lib64/dri/i965_dri.so [0x7fdae4b6d886]
5: /usr/lib64/xorg/modules/extensions//libglx.so [0x7fdae634ad79]
6: /usr/lib64/xorg/modules/extensions//libglx.so(__glXFreeContext+0x6c) [0x7fdae634074c]
7: /usr/lib64/xorg/modules/extensions//libglx.so [0x7fdae6340acb]
8: /usr/bin/Xorg(CallCallbacks+0x4c) [0x44b58c]
9: /usr/bin/Xorg(CloseDownClient+0x58) [0x441e38]
10: /usr/bin/Xorg(Dispatch+0x210) [0x446f70]
11: /usr/bin/Xorg(main+0x3b5) [0x42d145]
12: /lib64/libc.so.6(__libc_start_main+0xfd) [0x33dda1ea2d]
13: /usr/bin/Xorg [0x42c5c9]

Fatal server error:
Caught signal 11.  Server aborting

Comment 8 Michal Schmidt 2009-09-30 15:04:36 UTC
Staffan's issue is a duplicate of 518748. Luiz's issue looks like a different bug.

*** This bug has been marked as a duplicate of bug 518748 ***


Note You need to log in before you can comment on or make changes to this bug.