Bug 523175 - setroubleshoot: SELinux is preventing /bin/loadkeys access to a leaked /dev/mapper/control file descriptor.
setroubleshoot: SELinux is preventing /bin/loadkeys access to a leaked /...
Status: CLOSED DUPLICATE of bug 526782
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:dad98351c60...
:
: 523176 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-14 07:42 EDT by andreasfrische+redhat
Modified: 2009-10-05 11:00 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-05 11:00:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description andreasfrische+redhat 2009-09-14 07:42:25 EDT
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /bin/loadkeys access to a leaked /dev/mapper/control file
descriptor.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by the loadkeys command. It looks like this is
either a leaked descriptor or loadkeys output was redirected to a file it is not
allowed to access. Leaks usually can be ignored since SELinux is just closing
the leak and reporting the error. The application does not use the descriptor,
so it will run properly. If this is a redirection, you will not get output in
the /dev/mapper/control. You should generate a bugzilla on selinux-policy, and
it will get routed to the appropriate package. You can safely ignore this avc.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385)

Additional Information:

Source Context                unconfined_u:unconfined_r:loadkeys_t:s0-s0:c0.c102
                              3
Target Context                system_u:object_r:lvm_control_t:s0
Target Objects                /dev/mapper/control [ chr_file ]
Source                        loadkeys
Source Path                   /bin/loadkeys
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           kbd-1.15-9.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.31-2.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   leaks
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-2.fc12.x86_64
                              #1 SMP Thu Sep 10 00:25:40 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Mon 14 Sep 2009 01:39:11 PM EDT
Last Seen                     Mon 14 Sep 2009 01:39:11 PM EDT
Local ID                      3fc59f0a-9776-42de-b000-609803c2f26c
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252949951.768:42): avc:  denied  { read write } for  pid=2266 comm="loadkeys" path="/dev/mapper/control" dev=tmpfs ino=3161 scontext=unconfined_u:unconfined_r:loadkeys_t:s0-s0:c0.c1023 tcontext=system_u:object_r:lvm_control_t:s0 tclass=chr_file

node=(removed) type=SYSCALL msg=audit(1252949951.768:42): arch=c000003e syscall=59 success=yes exit=0 a0=3924150 a1=390bd60 a2=3002bb0 a3=7fffb5f1a4f0 items=0 ppid=2131 pid=2266 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="loadkeys" exe="/bin/loadkeys" subj=unconfined_u:unconfined_r:loadkeys_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= loadkeys_t ==============
allow loadkeys_t lvm_control_t:chr_file { read write };
Comment 1 andreasfrische+redhat 2009-09-19 15:40:32 EDT
*** Bug 523176 has been marked as a duplicate of this bug. ***
Comment 2 Milan Broz 2009-10-05 11:00:07 EDT

*** This bug has been marked as a duplicate of bug 526782 ***

Note You need to log in before you can comment on or make changes to this bug.