Bug 52318 - Mozilla: Flash Plugin
Mozilla: Flash Plugin
Status: CLOSED DUPLICATE of bug 52844
Product: Red Hat Public Beta
Classification: Retired
Component: mozilla (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Depends On:
  Show dependency treegraph
Reported: 2001-08-22 14:33 EDT by Piet E Barber
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-09-04 19:07:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Picture of about:plugins showing no flash action (54.67 KB, image/jpeg)
2001-08-22 14:36 EDT, Piet E Barber
no flags Details
strace of mozilla -- going to URL about:plugins (1.14 MB, text/plain)
2001-09-04 19:04 EDT, Piet E Barber
no flags Details

  None (edit)
Description Piet E Barber 2001-08-22 14:33:33 EDT
Description of Problem:
libflash plugin is installed, yet not present in the about:plugins page in
Mozilla (works fine under Netscape 4.78)

[pbarber@roswell 4ym1ajzi.slt]$ file `locate libflashplayer.so`
/usr/lib/mozilla/plugins/libflashplayer.so:  symbolic link to
/usr/lib/netscape/plugins/libflashplayer.so: ELF 32-bit LSB shared object,
Intel 80386, version 1, not stripped
[pbarber@roswell loopy]$ md5sum `locate libflashplayer.so`
8ab54cbdc7c5388c6344e3f006ba0f65  /usr/lib/mozilla/plugins/libflashplayer.so
8ab54cbdc7c5388c6344e3f006ba0f65  /usr/lib/netscape/plugins/libflashplayer.so

Version-Release number of selected component (if
applicable):[pbarber@roswell loopy]$ rpm -qf

How Reproducible:
1a) Load any page with Flash content, and you get the ugly puzzle piece
1b) Go to the URL about:plugins and you will see the libnullplugin, and no
shockwave plugin, despite the file being there. 

Additional Information:

libflashplugin.so with mozilla 0.9.1_ximian (on RH7.1) works just fine. 
libflashplugin.so on Roswell machine works fine in Netscape 4.78
Comment 1 Piet E Barber 2001-08-22 14:36:31 EDT
Created attachment 28994 [details]
Picture of about:plugins showing no flash action
Comment 2 Glen Foster 2001-08-22 18:12:08 EDT
We (Red Hat) should really try to fix this before next release.
Comment 3 Christopher Blizzard 2001-08-30 16:26:51 EDT
This is working for me here with both the version 4 and version 5 flash plugins.
Comment 4 David Mansfield 2001-09-04 15:52:13 EDT
I bet 10-to-1 that the opener doesn't have xfree86-devel installed, and that
this is a dup of the bug I opened (52844), and the essential problem is that the
 mozilla plugin code attempts to do 'dlopen' on libraries without major version
info.  Thus, it tries to open libXt.so which doesn't exist until xfree86-devel
is installed.
Comment 5 Piet E Barber 2001-09-04 18:44:58 EDT
No soup.  Installed XFree86-devel-4.1.0-0.9.13.i386.rpm and still flash doesn't
show up in plugins. 

It's got to be some sort of package interdependency, because I have another
machine which has the package show up just fine. 

I would hate to have to run 'strace' on mozilla (pages and pages!), but it looks
like that is what I'm going to have to do. 
Comment 6 Piet E Barber 2001-09-04 19:04:36 EDT
Created attachment 30902 [details]
strace of mozilla -- going to URL about:plugins
Comment 7 Piet E Barber 2001-09-04 19:07:09 EDT
In the above strace, there are bunches of circumstances where the program is
looking for something specifically in /usr/lib/mozilla/plugins, but it's not
there (and lots of times that exact same file is in /usr/lib/)
these are specifically library files like libXt.so and libgtksuperwin.so, etc. I
don't know if this normal behaviour or not. 

The strace shows libflash in lines 3266 through 3294
and again in lines 18252 through 18280

Hope this helps. 
Comment 8 Piet E Barber 2001-09-04 19:13:14 EDT
Hah!  dummy me forgot to type 'ldconfig'. 

After installing XFree86-devel AND typing /sbin/ldconfig, the mozilla program
will show the libflashplayer plugin. 

I'm marking this as a duplicate of bug 52844, since that's what this really is.

Thanks, Mr. "redhat-bugzilla@dm.ultramaster.com"


*** This bug has been marked as a duplicate of 52844 ***

Note You need to log in before you can comment on or make changes to this bug.