This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 52844 - mozilla (and galeon) plugins require XFree86-devel
mozilla (and galeon) plugins require XFree86-devel
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: mozilla (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
:
: 52318 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-29 18:18 EDT by David Mansfield
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-28 13:00:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mansfield 2001-08-29 18:18:25 EDT
Description of Problem:
This is an almost identical bug to 52788, where the lack of the libxxx.so
symlink causes some apps' dlopen() to fail.  In this case, mozilla plugins
like flash (comes with product) and java (added by me separately), fail to
open libXt.so and libXext.so unless:

1) the XFree86-devel package is installed to get the symlinks 
_AND_
2) ldconfig is run to update /etc/ld.so.cache or whatever it's called.


Version-Release number of selected component (if applicable):
probably all mozilla/xfree rpms from redhat

How Reproducible:
always

Steps to Reproduce:
1. see above
2. 
3. 

Actual Results:
using strace, you see ENOENT trying to open shared libs at dlopen time

Expected Results:
find the library in search path

Additional Information:
Comment 1 Piet E Barber 2001-09-04 19:13:09 EDT
*** Bug 52318 has been marked as a duplicate of this bug. ***
Comment 2 Kyle Gonzales 2001-09-25 11:36:39 EDT
I get the same issues using Mozilla RPMS from ftp.mozilla.org.  This is an ugly
problem... is this problem going to be fixed before 7.2 is released, or at least
some mention of the problem put into the RELEASE NOTES or on the support webpage?
Comment 3 Kyle Gonzales 2002-06-28 13:00:34 EDT
There has been no update on this since last year.  Was it fixed ever?
Comment 4 Christopher Blizzard 2002-08-29 17:15:17 EDT
This is fixed in recent mozilla builds.  We open Xt.

Note You need to log in before you can comment on or make changes to this bug.