Bug 523201 - ext4 kernel: (EDQUOT) This should not happen.!! Data will be lost
Summary: ext4 kernel: (EDQUOT) This should not happen.!! Data will be lost
Keywords:
Status: CLOSED DUPLICATE of bug 522615
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: e4fsprogs
Version: 5.4
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Eric Sandeen
QA Contact: BaseOS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-14 13:17 UTC by procaccia
Modified: 2009-09-14 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-14 16:48:14 UTC


Attachments (Terms of Use)

Description procaccia 2009-09-14 13:17:51 UTC
Description of problem:
I regularly receive on the console these kind of messages:

"Message from syslogd@ at Mon Sep 14 15:07:41 2009 ...
gizeh kernel: This should not happen.!! Data will be lost
Message from syslogd@ at Mon Sep 14 15:07:48 2009 ...
gizeh kernel: mpage_da_map_blocks block allocation failed for inode 409873 at logical offset 0 with max blocks 7 with error -122
"

Version-Release number of selected component (if applicable):
$ rpm -q e4fsprogs
e4fsprogs-1.41.5-3.el5
 uname -a 
Linux gizeh.int-evry.fr 2.6.18-164.el5 #1 SMP Tue Aug 18 15:51:48 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
Often, every minutes , sometimes seconds ...


Steps to Reproduce:
1. let NFS , samba service operational on ext4 filesystems, hundred of users
2.
3.
  
Actual results:

Message from syslogd@ at Mon Sep 14 15:07:41 2009 ...
gizeh kernel: This should not happen.!! Data will be lost

but for now , no one reported data loss ... anyway I'am afraid of having users comming back with requests for backups ...

Expected results:

no error message !

Additional info:
These ext4 filsystem are located on an atteached iscsi storage disk
it used LVM and have quotas .
here's a result of the mount command in order to show mount options and devices:

[root@gizeh ~]
$ mount
/dev/mapper/VolGroup00S2IA-LogVol00 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/mapper/VolGroup00S2IA-LogVol01 on /usr type ext3 (rw)
/dev/mapper/VolGroup00S2IA-LogVol03 on /usr/local type ext3 (rw)
/dev/mapper/VolGroup00S2IA-LogVol02 on /var type ext3 (rw)
/dev/mapper/VolGroup00S2IA-LogVol05 on /tmp type ext3 (rw)
/dev/sda1 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
/dev/mapper/VolGroup01S2ia-LVVG01Users01 on /disk01 type ext4dev (rw,_netdev,acl,usrquota,grpquota)
/dev/mapper/VolGroup01S2ia-LVVG01Users02 on /disk02 type ext4dev (rw,_netdev,acl,usrquota,grpquota)
/dev/mapper/VolGroup01S2ia-LVVG01Users03 on /disk03 type ext3 (rw,_netdev,acl,usrquota,grpquota)
/dev/mapper/VolGroup02S2IA-LVVG02Users07 on /disk07 type ext4dev (rw,_netdev,acl,usrquota,grpquota)
/dev/mapper/VolGroup02S2IA-LVVG02Users08 on /disk08 type ext4dev (rw,_netdev,acl,usrquota,grpquota)
/dev/mapper/VolGroup02S2IA-LVVG02Users09 on /disk09 type ext4dev (rw,_netdev,acl,usrquota,grpquota)
/dev/mapper/VolGroup03S2IA-LogVolS2ia01 on /disk00 type ext4dev (rw,_netdev,acl,usrquota,grpquota)
/dev/mapper/VolGroup03S2IA-LVVG03Users13 on /disk13 type ext4dev (rw,_netdev,acl,usrquota,grpquota)
/dev/mapper/VolGroup03S2IA-LVVG03Users14 on /disk14 type ext4dev (rw,_netdev,acl,usrquota,grpquota)
/dev/mapper/VolGroup03S2IA-LVVG03Users15 on /disk15 type ext4dev (rw,_netdev,acl,usrquota,grpquota)
/dev/mapper/VolGroup04S2IA-LVVG04Users19 on /disk19 type ext4dev (rw,_netdev,acl,usrquota,grpquota)
/dev/mapper/VolGroup04S2IA-LVVG04Users20 on /disk20 type ext4dev (rw,_netdev,acl,usrquota,grpquota)
/dev/mapper/VolGroup04S2IA-LVVG04Users21 on /disk21 type ext4dev (rw,_netdev,acl,usrquota,grpquota)
nfsd on /proc/fs/nfsd type nfsd (rw)
/disk19/artemis/zaharia on /mci/artemis/zaharia type none (rw,bind)
/disk09/em0912/hariss_e on /mci/em0912/hariss_e type none (rw,bind)
/disk14/msc2009/balassou on /mci/msc2009/balassou type none (rw,bind)


perhaps related to https://bugzilla.redhat.com/show_bug.cgi?id=515529 ?

Comment 1 Eric Sandeen 2009-09-14 16:40:05 UTC
errno 122 is quota, and quota support is still being hashed out even upstream.

Note that quota is not yet supported in RHEL5, even quota userspace in RHEL5 does not yet recognize ext4 (see Bug 500231 -  RFE: quota support for ext4 in RHEL5)

Disabling quotas on these filesystems should work around this problem for now.

But, thanks for reporting the bug, it's something that will get fixed at some point, certainly.

-Eric

Comment 2 Eric Sandeen 2009-09-14 16:48:14 UTC
Actually, this is a dup of 522615.

-Eric

*** This bug has been marked as a duplicate of bug 522615 ***


Note You need to log in before you can comment on or make changes to this bug.