Bug 523228 - libvirt-0.7.0-4 failed to build during RHEL-6 mass rebuild
libvirt-0.7.0-4 failed to build during RHEL-6 mass rebuild
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.0
s390x Linux
high Severity high
: beta
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks: 522407 523231 523241
  Show dependency treegraph
 
Reported: 2009-09-14 10:24 EDT by Karsten Hopp
Modified: 2010-09-08 02:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-30 05:53:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
New libvirt.spec to only build on libvirtd / QEMU on x86_64 RHEL-6 (25.91 KB, text/plain)
2009-09-14 13:09 EDT, Daniel Berrange
no flags Details
Updated RHEL-6 spec to fix RHEL-5/Fedora regressions (25.91 KB, text/plain)
2009-09-14 13:27 EDT, Daniel Berrange
no flags Details

  None (edit)
Description Karsten Hopp 2009-09-14 10:24:21 EDT
Description of problem:
libvirt failed to build on s390x as there's no numactl-devel package and no package providing /usr/bin/qemu-img on that architecture. 


Steps to Reproduce:
1. run a brew scratch build with the target RHEL-6-rebuild, don't try without --scratch as that won't work

Actual results:
https://brewweb.devel.redhat.com/taskinfo?taskID=1949417


Additional info:
It needs to be discussed with IBM if we need qemu, libvirt, ... on s390x at all. Maybe an ExcludeArch will be sufficient.
We need the exact n-v-r of the fixed package so that we can import it into our RHEL-6 tree.
Comment 1 RHEL Product and Program Management 2009-09-14 10:27:35 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Mark McLoughlin 2009-09-14 10:38:38 EDT
IMHO, we'll want libvirt-client, at most, on s3890 - not libvirt itself or qemu
Comment 3 Daniel Berrange 2009-09-14 10:45:44 EDT
My recommendation is that 

 - x86_64  - build libvirtd, build test, remote & QEMU drivers. Build storage, network, interface, node device drivers

 - i386, ppc, s390, ia64, etc -  build only the remote driver.

this will avoid the need to ExludeArch on countless downstream RPMs depending on libvirt - we explicitly created the new libvirt-client sub-RPM to allow for client-only deps which suits this scenario quite well. The only technical issue is to figure out the RPM conditional rules to make sure that *only* the libvirt-client RPM is output, with no 'libvirt' base RPM.
Comment 4 Daniel Berrange 2009-09-14 13:09:31 EDT
Created attachment 360972 [details]
New libvirt.spec to only build on libvirtd / QEMU on x86_64  RHEL-6

The following is an updated specfile against libvirt upstream GIT repo.

It aims to do the following:

 RHEL-6
    - x86_64  build libvirtd, QEMU, LXC, Test & Remote driver and other secondary drivers (network, interface, hal node device, selinux)
    - All other archs:  build libvirt Remote & Test drivers only.  No libvirtd, or base RPM

This scratch build has verified it

   https://brewweb.devel.redhat.com/taskinfo?taskID=1984675

With this, there should be no need to conditionalize any other libvirt related downstream RPM
Comment 5 Daniel Berrange 2009-09-14 13:27:40 EDT
Created attachment 360976 [details]
Updated RHEL-6 spec to fix RHEL-5/Fedora regressions 

The previous spec i uploaded didn't work for RHEL-5/Fedora. This one fixes the conditionals i broke, so it works on all RHEL and all Fedora now
Comment 6 Daniel Berrange 2009-09-17 08:16:04 EDT
After more consideration this was all wrong.

We *DO* want a full libvirt build on all architectures, since we intend to include the LXC container virt driver which is available on all Linux archs. Therefore the need to build libvirtd everywhere, LXC everywhere, and QEMU only on x86_64.
Comment 7 Daniel Berrange 2009-09-22 11:55:33 EDT
The latest RHEL6 build now includes s390

http://porkchop.devel.redhat.com/brewroot/packages/libvirt/0.7.1/2.el6.1/
Comment 8 Daniel Veillard 2009-09-30 05:53:40 EDT
Yeah I think this is fixed, let's close this,

Daniel
Comment 9 wangyimiao 2010-09-08 02:10:46 EDT
Verified passed
The latest RHEL6 build now includes s390

http://porkchop.devel.redhat.com/brewroot////packages/libvirt/0.8.1/27.el6/s390x/

Note You need to log in before you can comment on or make changes to this bug.