Bug 523319 - setroubleshoot: SELinux is preventing /usr/sbin/abrtd (deleted) "remove_name" access on pyhook-1252962118-1888.lock.
Summary: setroubleshoot: SELinux is preventing /usr/sbin/abrtd (deleted) "remove_name"...
Keywords:
Status: CLOSED DUPLICATE of bug 523315
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:129fbfc1c5f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-14 21:07 UTC by al morris
Modified: 2009-09-16 02:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-14 21:16:42 UTC


Attachments (Terms of Use)

Description al morris 2009-09-14 21:07:58 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /usr/sbin/abrtd (deleted) "remove_name" access on
pyhook-1252962118-1888.lock.

Detailed Description:

[abrtd has a permissive type (initrc_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:initrc_t:s0
Target Context                system_u:object_r:var_t:s0
Target Objects                pyhook-1252962118-1888.lock [ dir ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd (deleted)
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.31-3.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-2.fc12.x86_64 #1 SMP Thu Sep
                              10 00:25:40 EDT 2009 x86_64 x86_64
Alert Count                   2
First Seen                    Mon 14 Sep 2009 04:01:58 PM CDT
Last Seen                     Mon 14 Sep 2009 04:01:58 PM CDT
Local ID                      26071fd3-70d1-4aa0-a38f-79716447adfc
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252962118.697:127): avc:  denied  { remove_name } for  pid=1253 comm="abrtd" name="pyhook-1252962118-1888.lock" dev=sda2 ino=109190 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:var_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1252962118.697:127): avc:  denied  { unlink } for  pid=1253 comm="abrtd" name="pyhook-1252962118-1888.lock" dev=sda2 ino=109190 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:var_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252962118.697:127): arch=c000003e syscall=87 success=yes exit=0 a0=976dc8 a1=0 a2=0 a3=7fff1f591010 items=0 ppid=1 pid=1253 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe=2F7573722F7362696E2F6162727464202864656C6574656429 subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t var_t:dir remove_name;
allow initrc_t var_t:file unlink;

Comment 1 Daniel Walsh 2009-09-14 21:16:42 UTC

*** This bug has been marked as a duplicate of bug 523315 ***


Note You need to log in before you can comment on or make changes to this bug.