Bug 523315 - setroubleshoot: SELinux is preventing /usr/sbin/abrtd (deleted) "add_name" access on package.
Summary: setroubleshoot: SELinux is preventing /usr/sbin/abrtd (deleted) "add_name" ac...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:b36f01135c9...
: 523316 523317 523318 523319 523322 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-14 21:05 UTC by al morris
Modified: 2015-02-01 22:49 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-14 21:15:36 UTC


Attachments (Terms of Use)

Description al morris 2009-09-14 21:05:16 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /usr/sbin/abrtd (deleted) "add_name" access on package.

Detailed Description:

[abrtd has a permissive type (initrc_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:initrc_t:s0
Target Context                unconfined_u:object_r:var_t:s0
Target Objects                package [ dir ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd (deleted)
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.31-3.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-2.fc12.x86_64 #1 SMP Thu Sep
                              10 00:25:40 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Mon 14 Sep 2009 04:01:58 PM CDT
Last Seen                     Mon 14 Sep 2009 04:01:58 PM CDT
Local ID                      618efe64-585d-4320-8cec-3f09468dd0bf
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252962118.989:131): avc:  denied  { add_name } for  pid=1253 comm="abrtd" name="package" scontext=system_u:system_r:initrc_t:s0 tcontext=unconfined_u:object_r:var_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1252962118.989:131): arch=c000003e syscall=2 success=yes exit=8 a0=9770c8 a1=241 a2=1b6 a3=3131323639323532 items=0 ppid=1 pid=1253 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe=2F7573722F7362696E2F6162727464202864656C6574656429 subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t var_t:dir add_name;

Comment 1 Daniel Walsh 2009-09-14 21:15:36 UTC
Fixed in selinux-policy-3.6.31-4.fc12.noarch

Comment 2 Daniel Walsh 2009-09-14 21:15:59 UTC
*** Bug 523316 has been marked as a duplicate of this bug. ***

Comment 3 Daniel Walsh 2009-09-14 21:16:15 UTC
*** Bug 523317 has been marked as a duplicate of this bug. ***

Comment 4 Daniel Walsh 2009-09-14 21:16:29 UTC
*** Bug 523318 has been marked as a duplicate of this bug. ***

Comment 5 Daniel Walsh 2009-09-14 21:16:43 UTC
*** Bug 523319 has been marked as a duplicate of this bug. ***

Comment 6 Daniel Walsh 2009-09-14 21:18:14 UTC
*** Bug 523322 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.