Bug 523322 - setroubleshoot: SELinux is preventing /usr/sbin/abrtd "write" access on pyhook.conf.
Summary: setroubleshoot: SELinux is preventing /usr/sbin/abrtd "write" access on pyhoo...
Keywords:
Status: CLOSED DUPLICATE of bug 523315
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:d9819f14108...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-14 21:12 UTC by al morris
Modified: 2009-09-14 21:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-14 21:18:14 UTC


Attachments (Terms of Use)

Description al morris 2009-09-14 21:12:26 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /usr/sbin/abrtd "write" access on pyhook.conf.

Detailed Description:

[abrtd has a permissive type (initrc_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:initrc_t:s0
Target Context                system_u:object_r:etc_t:s0
Target Objects                pyhook.conf [ file ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-0.0.8.5-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.31-3.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-2.fc12.x86_64 #1 SMP Thu Sep
                              10 00:25:40 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Mon 14 Sep 2009 12:54:19 PM CDT
Last Seen                     Mon 14 Sep 2009 12:54:19 PM CDT
Local ID                      6a7153c3-905b-4126-8921-140ee6072d3a
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252950859.884:13): avc:  denied  { write } for  pid=1253 comm="abrtd" name="pyhook.conf" dev=sda2 ino=57059 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:etc_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252950859.884:13): arch=c000003e syscall=2 success=yes exit=4 a0=7f0f45e8e655 a1=241 a2=1b6 a3=238 items=0 ppid=1252 pid=1253 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t etc_t:file write;

Comment 1 Daniel Walsh 2009-09-14 21:18:14 UTC

*** This bug has been marked as a duplicate of bug 523315 ***


Note You need to log in before you can comment on or make changes to this bug.