Bug 523439 - s-c-d not working
s-c-d not working
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-15 10:05 EDT by Hiemanshu
Modified: 2010-03-02 12:46 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-02 12:46:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hiemanshu 2009-09-15 10:05:46 EDT
Description of problem:
s-c-d is not working from runlevel 5 or 3
when i run s-c-d from runleve 5 i get the following output(KDE0
/usr/share/themes/Clearlooks/gtk-2.0/gtkrc:51: Invalid symbolic color 'bg_color'
/usr/share/themes/Clearlooks/gtk-2.0/gtkrc:51: error: invalid identifier `bg_color', expected valid identifier
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 376, in <module>
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, rhpxl.videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 641, in __init__
    if len(self.xconfig.layout[0].adjacencies) > 1:
IndexError: index out-of-bounds

and from runlevel 3 i run s-c-d --reconfig
It says could not start X server, Display not found.

Version-Release number of selected component (if applicable):
system-config-display-1.1.3-3.fc12.noarch

Steps to Reproduce:
1. run s-c-d from Konsole/teminal
2. rum s-c-d --reconfig from runlevel 3
3.
Comment 1 lexual 2009-09-24 03:30:11 EDT
similar issue here on rawhide with firefox:

/usr/share/themes/Clearlooks/gtk-2.0/gtkrc:51: Invalid symbolic color
'bg_color'
/usr/share/themes/Clearlooks/gtk-2.0/gtkrc:51: error: invalid identifier
`bg_color', expected valid identifier
/usr/lib/firefox-3.5.3/run-mozilla.sh: line 131:  2249 Segmentation fault     
(core dumped) "$prog" ${1+"$@"}



Installed Packages
firefox.i686                            3.5.3-1.fc12                   
@rawhide
xulrunner.i686                          1.9.1.3-1.fc12                 
@rawhide

i686 fedora version.  

Possibly related to
https://bugzilla.redhat.com/show_bug.cgi?id=525154
Comment 2 Matěj Cepl 2009-11-05 12:16:40 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages (at least F12Beta, but even better if the very latest versions).

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 3 Bug Zapper 2009-11-16 07:26:00 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Christoph Wickert 2009-11-18 06:18:03 EST
The gtkrc or the Firefox problems are not related to this bug. However this bug is still reproducible on F11 with all updates applied and F12 as well.

It might be worth noting that I'm running the binary nvidia driver, just like the people in bug 505972. Hiemanshu, are you also using that driver?
Comment 5 Matěj Cepl 2009-11-20 13:19:06 EST
For nvidia binary only driver I am starting to suspect also bug 539426 as its possible victim.
Comment 6 Matěj Cepl 2009-11-20 13:20:44 EST
Sorry, forget the last comment ... that's Firefox over there.
Comment 7 Matěj Cepl 2010-02-26 07:24:03 EST
Could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[Note please, that this is machine generated comment for large amount of bugs; due to some technical issues, it is possible we've missed some of the responses -- it is happens, please, just a make a comment about that; that we will see. Thank you]
Comment 8 Hiemanshu Sharma 2010-02-26 08:24:29 EST
Yes I am running the nVidia Binary Driver as well.
Comment 9 Matěj Cepl 2010-03-02 12:46:42 EST
Thanks for the report. We are sorry that we cannot help you with your problem, but we are not able to support binary-only drivers. If you would be able to reproduce this issue using only open source software, please, reopen this bug with the additional information, but in meantime I have no choice than to close this bug as CANTFIX (because we really cannot fix it).

The open source 'nouveau' driver (in package xorg-x11-drv-nouveau) is the recommended alternative for users of Nvidia graphic chips.  It is used by default in Fedora 11 and later if you remove any customizations that explicitly set the video driver.  The older "nv" driver may be needed in some cases.  It is also available in older Fedora releases.  Install the packages xorg-x11-drv-nouveau or xorg-x11-drv-nv and override the X server's default choice if necessary.  See https://fedoraproject.org/wiki/Features/NouveauAsDefault for more information.

If you used a non-packaged version of the driver from the Nvidia website please clean your system from additional libraries and software it installed. For users who are experiencing problems installing, configuring, or using the unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides indirect customer support via an online web based support forum.  Nvidia monitors these web forums for commonly reported problems and passes them on to Nvidia engineers for investigation.  Once they've isolated a particular problem, it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

	http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have experienced the particular problem may be able to assist.  If there is a real bug occuring, Nvidia will be able to determine this, and will likely resolve the issue in a future driver update for the operating system releases that they officially support.

While we does not support the proprietary nvidia driver, users requiring technical support may also find the various X.Org, XFree86, and Red Hat/Fedora mailing lists helpful in finding assistance:

X.Org mailing lists:
	http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
	http://www.xfree86.org/sos/lists.html

Red Hat/Fedora mailing lists:
	https://listman.redhat.com/mailman/listinfo

Note You need to log in before you can comment on or make changes to this bug.