Bug 523454 - [ml_IN] Fontconfig settings for Meera font not working properly
[ml_IN] Fontconfig settings for Meera font not working properly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-themes (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
: Triaged
: 526420 (view as bug list)
Depends On:
Blocks: 574355
  Show dependency treegraph
 
Reported: 2009-09-15 11:19 EDT by Santhosh Thottingal
Modified: 2010-05-14 01:04 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 574355 (view as bug list)
Environment:
Last Closed: 2010-05-14 01:04:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OpenOffice document using Meera, rachana and suruma fonts with size 12 (167.55 KB, image/png)
2009-09-16 02:08 EDT, Manilal
no flags Details
Desktop with Meera font as default (size 12) (102.79 KB, image/png)
2009-09-16 02:12 EDT, Manilal
no flags Details
Gedit with Meera size 10 (92.24 KB, image/png)
2009-10-12 14:51 EDT, Rajeesh
no flags Details
Gedit with Rachana size 10 (84.84 KB, image/png)
2009-10-12 14:51 EDT, Rajeesh
no flags Details
Screenshot with Meera 10 (329.69 KB, image/png)
2009-10-29 02:45 EDT, Ani Peter
no flags Details
Screenshot with Meera 12 (329.15 KB, image/png)
2009-10-29 02:46 EDT, Ani Peter
no flags Details
Screenshot with Rachana 10 (402.54 KB, image/png)
2009-10-29 02:47 EDT, Ani Peter
no flags Details
Screenshot with Rachana 12 (418.29 KB, image/png)
2009-10-29 02:48 EDT, Ani Peter
no flags Details
Underline issue resolved - screenshot (311.17 KB, image/png)
2010-04-09 05:56 EDT, Ani Peter
no flags Details

  None (edit)
Description Santhosh Thottingal 2009-09-15 11:19:42 EDT
Description of problem:
Meera font has a scaling property defined in /etc/fonts/conf.d/90-smc-fonts.conf file. It has a 1.2 times size scaling. But in Fedora 11 this scaling is not working properly. When Meera font is selected with size say, 12 for the applications, window titles etc, the entire desktop get ugly with expanded and overlapped titlebars or strings in application.

How reproducible:
Always

Steps to Reproduce:
1. Open abiword, type two words(english/malayalam), set the font of first word as Meera 12, second as Rachana 12 and compare the size. Meera font is bigger than Rachana font
  
OR

2. System->Preferences->Appearance->Fonts, , select the fonts for all types as Meera 12. Select theme as Clearlooks. See the panel width, window title width, the big close buttons etc. Repeat the same with Rachana 12 and see the difference


Actual results:
Meera font size is big and takes more spaces in application making the application look bad


Expected results:
Setting font size 12 should set the size as 12 and the size should be same as other fonts with same size.

Additional info:
None
Comment 1 Manilal 2009-09-16 02:06:30 EDT
Confirmed this bug in OpenOffice.org. Please find the attached screenshots.
Comment 2 Manilal 2009-09-16 02:08:16 EDT
Created attachment 361191 [details]
OpenOffice document using Meera, rachana and suruma fonts with size 12
Comment 3 Manilal 2009-09-16 02:12:44 EDT
Created attachment 361193 [details]
Desktop with Meera font as default (size 12)
Comment 4 Pravin Satpute 2009-09-29 07:22:57 EDT
It will be nice if you update this bug with version of following packages
fontconfig
smc-meera-fonts and metacity
Comment 5 Rajeesh 2009-09-29 07:38:06 EDT
Versions:
fontconfig-2.7.1-1.fc11.i586
metacity-2.26.0-1.fc11.i586
smc-meera-fonts-04.1-6.fc11.noarch
Comment 6 Pravin Satpute 2009-09-29 11:29:27 EDT
(In reply to comment #0)
> Description of problem:
> Meera font has a scaling property defined in
> /etc/fonts/conf.d/90-smc-fonts.conf file. It has a 1.2 times size scaling. But
> in Fedora 11 this scaling is not working properly. When Meera font is selected
> with size say, 12 for the applications, window titles etc, the entire desktop
> get ugly with expanded and overlapped titlebars or strings in application.


IMHO reason behind this is font metrics of Meera

Rachana: Ascent: 1638, Descent: 410
Meera:  Ascent: 1147, Descent: 901
Lohit:  Ascent: 650, Descent: 374

looking at this Meera requires bit more vertical length of title bar for proper rendering as compared to Lohit. With compared to Rachana it requires bit more space below the character.

this Descent values is proper for Meera as there are some ligature required this much below space

see http://pravins.fedorapeople.org/Meera/meera_with_characters_below_base_extending.png

about Panel menus getting overlap is because SPACE character 0x0020, 

Meera : width = 563
Lohit : width = 350
Rachana : width = 466

see http://pravins.fedorapeople.org/Meera/lohit_space.png
http://pravins.fedorapeople.org/Meera/meera_space.png

so obviously Meera required more horizontal space as well, and panel menus getting overlapped, it will be nice if we can reduce its space value little bit

There is problem with OpenOffice, it is somehow not using .conf file, i am looking into it
Comment 7 Rahul Bhalerao 2009-09-30 02:01:48 EDT
Has the ascent-descent values for meera been changed recently? If so, please revert back to last working values if the change was not deliberate.
Comment 8 Pravin Satpute 2009-10-06 04:39:57 EDT
*** Bug 526420 has been marked as a duplicate of this bug. ***
Comment 9 Pravin Satpute 2009-10-06 11:25:00 EDT
about underline presence in the windows title bar..
this is happening with glossy, clearlooks, fedora default theme and curvy looks

while digging more on this problem i found that when we remove 90-smc-fonts.conf
this problem is not coming, even i tried some other combination of scaling matrix of .conf file but still this problem is happening

so changing component to fontconfig
Comment 10 Behdad Esfahbod 2009-10-06 12:02:47 EDT
Has nothing to do with fontconfig.  I have no idea what the problem is, but it's definitely within 90-smc-fonts.conf as you said.
Comment 11 Pravin Satpute 2009-10-06 12:22:12 EDT
thanks behdad for quick comment, yep it looks like that

while chatting with  Matthias Clasen on same issue, we found

as problem is not coming with Crux theme but coming with other themes, he shown difference in crux and clearlooks theme

<mclasen> one thing I notice that might be relevant (not sure)
<mclasen> is that crux seems to have a version-2 metacity theme xml file (metacity-theme-2.xml
<mclasen> clearlooks only has version-1 file

just do move /usr/share/themes/Crux/metacity-1 folder to somewhere temporarily

problem will start occurring with Crux theme as well

so looks like we identified where problem is occurring, moving componant to metacity, might be then need to move to gnome-themese for quick fix

thanks Matthias

but now need to see what will be quick fix for this
Comment 12 Matthias Clasen 2009-10-06 13:16:37 EDT
What I meant was to go into the folder /usr/share/themes/Crux/metacity-1 
and move the file metacity-theme-2.xml to somewhere else, e.g. unused.xml
and see if the problem reproduces with the metacity-theme-1.xml thats in the same folder.
Comment 13 Pravin Satpute 2009-10-07 08:08:07 EDT
just moving metacity-theme-2.xml doesn't make any difference
Comment 14 Pravin Satpute 2009-10-09 04:42:32 EDT
upstream bug id

https://bugzilla.gnome.org/show_bug.cgi?id=597884
Comment 15 Suresh P 2009-10-12 04:11:06 EDT
The issue disappeared when the matrix multiplication directive for Meera font has changed.From the entry for edit matrix directive for the font, the 'times' element and its child 'name' with value 'matrix' are removed. I don't know whether this is the right method because haven't seen any documentation regarding this. I think fontconfig is not well-documented about this entry.

The directive before change => http://pastie.org/651165

The directive after change => http://pastie.org/651160

BTW, strangely, the changes effected thru' fontconfig is not available in OpenOffice or KDE.

suresh
Comment 16 Pravin Satpute 2009-10-12 07:08:56 EDT
thanks suresh for pointer 

http://pravins.fedorapeople.org/smc-meera-fonts-04.2-2.fc11.noarch.rpm

please see if things are better with this rpm, if yes i will build smc-meera package again

rpm should resolve border bug of gnome-theme as well must not affect meera scaling rule in gedit
Comment 17 Santhosh Thottingal 2009-10-12 09:53:49 EDT
I can confirm that the fix mentioned by Suresh works fine in gnome applications. I did not use the RPM, but just edited the configuration file.
But the changes did not work on KDE and openoffice.

I am changing the component to Fontconfig again
Comment 18 Pravin Satpute 2009-10-12 12:35:13 EDT
santhoh can you test rpm as well?, so i can push this package for f12

behdad,
fontconf scaling rules for meera not working in KDE and openoffice, is there anything more need to do other than adding .conf file?
Comment 19 Rajeesh 2009-10-12 14:51:01 EDT
Created attachment 364504 [details]
Gedit with Meera size 10
Comment 20 Rajeesh 2009-10-12 14:51:45 EDT
Created attachment 364505 [details]
Gedit with Rachana size 10
Comment 21 Rajeesh 2009-10-12 14:53:58 EDT
I have tested the RPM, and can confirm that the fontconfig rule doesn't work with OpenOffice. GNOME apps seems to work ok. But it looks like to me that Meera/Rachana size difference is still present. See the previous two screenshots, each with size 10. Window border theme is Glossy.
Comment 22 Nicolas Mailhot 2009-10-12 15:00:06 EDT
(In reply to comment #21)
> I have tested the RPM, and can confirm that the fontconfig rule doesn't work
> with OpenOffice. GNOME apps seems to work ok. But it looks like to me that
> Meera/Rachana size difference is still present. See the previous two
> screenshots, each with size 10. Window border theme is Glossy.  

OO.o is notoriously challenged by non-trivial text rendering; it's probably worth it to open a separate bug on OO.o so the RedHat OO.o maintainers can look at it

(QT is also often challenged, though less so, and I don't think anyone @rh is going to work on it)
Comment 23 Pravin Satpute 2009-10-14 03:44:00 EDT
built smc-fonts-04.2-2.fc12
requested releng for adding same in F12 Final, hope so will get that

as suggested by Nicholas, Better to open new bug for OO.o and QT
Comment 24 Ani Peter 2009-10-29 02:43:03 EDT
Tested latest rawhide (smc-fonts-04.2-2.fc12) and here are the results with Meera 10, Meera 12, comparing with Rachana 10 and Rachana 12 on Fedora default desktop:

Meera 10 -> underline appears on the gui and gedit title bar 
Meera 12 -> underline appears on the gui and gedit title bar and the close buttons become too larger in size. 
(above issues applicable to OO, FF and Qt as mentioned earlier)

Rachana 10 -> works well with no underline
Rachana 12 -> works well with no underline and buttons are normal in size.

Relevant screenshots attached for Meera 10, Meera 12, Rachana 10, Rachana 12.
Comment 25 Ani Peter 2009-10-29 02:45:23 EDT
Created attachment 366559 [details]
Screenshot with Meera 10
Comment 26 Ani Peter 2009-10-29 02:46:19 EDT
Created attachment 366560 [details]
Screenshot with Meera 12
Comment 27 Ani Peter 2009-10-29 02:47:55 EDT
Created attachment 366561 [details]
Screenshot with Rachana 10
Comment 28 Ani Peter 2009-10-29 02:48:49 EDT
Created attachment 366562 [details]
Screenshot with Rachana 12
Comment 29 Bug Zapper 2009-11-16 07:26:12 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 30 Pravin Satpute 2009-11-20 04:38:25 EST
(In reply to comment #15)
> The issue disappeared when the matrix multiplication directive for Meera font
> has changed.From the entry for edit matrix directive for the font, the 'times'
> element and its child 'name' with value 'matrix' are removed. I don't know
> whether this is the right method because haven't seen any documentation
> regarding this. I think fontconfig is not well-documented about this entry.
> 
> The directive before change => http://pastie.org/651165
> 
> The directive after change => http://pastie.org/651160

fontconfig rules dont work well if we remove
            <name>matrix</name>
above line from smc-fonts conf file
but yes underline issue go out.


so issue is still present
Comment 31 Ani Peter 2010-04-09 05:56:56 EDT
Created attachment 405501 [details]
Underline issue resolved - screenshot

Tested the updated gnome-themes-2.28.1-3.fc12 on F12. The underline issue has disappeared and all windows (oowriter, gnome-terminal, kwrite, gedit, firefox and evince) appears good to me. 

Screenshot for oowriter, gnome-terminal, kwrite, gedit, firefox attached for confirmation. Thanks Pravin.
Comment 32 Pravin Satpute 2010-05-14 01:04:18 EDT
i think we can close this bug now
I have already given reason's regarding extra title bar space, see comment #6 
if any issue regarding this please reopen bug

Note You need to log in before you can comment on or make changes to this bug.