Bug 523554 - Anaconda crashes when setting default OS in bootloader configuration
Summary: Anaconda crashes when setting default OS in bootloader configuration
Keywords:
Status: CLOSED DUPLICATE of bug 504969
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-15 23:02 UTC by Praveen A
Modified: 2009-09-16 13:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-16 13:26:44 UTC


Attachments (Terms of Use)
Screenshot of the crash (crashed for second time by following the same step) (188.77 KB, image/png)
2009-09-15 23:02 UTC, Praveen A
no flags Details
exception report from anaconda (182.34 KB, text/plain)
2009-09-15 23:02 UTC, Praveen A
no flags Details

Description Praveen A 2009-09-15 23:02:21 UTC
Created attachment 361158 [details]
Screenshot of the crash (crashed for second time by following the same step)

Description of problem:

When default OS choice is changed to windows on dual boot machine anaconda cannot set it back to Fedora.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Follow installer steps to bootloader configuration
2. Change default to the second OS (needs dual boot)
3. Try to select Fedora again (click on the check box first - won't work). Click on edit and select checkbox to make it default.
  
Actual results:

Anaconda crashed.

Expected results:

Should set the default OS correctly.

Additional info:

Exception report and screenshot of crash attached.

Comment 1 Praveen A 2009-09-15 23:02:57 UTC
Created attachment 361160 [details]
exception report from anaconda

Comment 2 Chris Lumens 2009-09-16 13:26:44 UTC

*** This bug has been marked as a duplicate of bug 504969 ***


Note You need to log in before you can comment on or make changes to this bug.