Bug 504969 - Ananconda crashes when changing default boot OS during installation
Ananconda crashes when changing default boot OS during installation
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 505028 505114 505318 507078 523554 524399 (view as bug list)
Depends On:
Blocks: 513462
  Show dependency treegraph
 
Reported: 2009-06-10 05:00 EDT by Wim Cos
Modified: 2010-06-28 08:51 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:51:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback of crash (207.99 KB, text/plain)
2009-06-10 13:42 EDT, Wim Cos
no flags Details
Another traceback of crash (221.43 KB, text/plain)
2009-06-10 13:43 EDT, Wim Cos
no flags Details

  None (edit)
Description Wim Cos 2009-06-10 05:00:06 EDT
Description of problem:
When installing Fedora 11 in a dual boot configuration with Windows 7 RC on the same disk, Ananconda crashes when you trying to modify the label for Fedora or changing the default boot target.

Fedora does install correctly when not changing anything in the default boot partition dialogue.

Version-Release number of selected component (if applicable):


How reproducible:
Every time you try to install Fedora 11.

Steps to Reproduce:
1. Boot install CD
2. Check box for reviewing partition layout
3. Change default boot target to "Other",
  
Actual results:
Crash and system shutdown

Expected results:
Change default boot partition and continue.

Additional info:
System was running on a 120GB OCZ Vertex SSD with firmware v1.10. First partition was 60GB for Windows 7 RC, second partition 60GB for Fedora.
Comment 1 Chris Lumens 2009-06-10 10:58:19 EDT
Please attach the complete traceback to this bug report.  Thanks.
Comment 2 Chris Lumens 2009-06-10 13:29:22 EDT
*** Bug 505114 has been marked as a duplicate of this bug. ***
Comment 3 Wim Cos 2009-06-10 13:42:03 EDT
Created attachment 347264 [details]
Traceback of crash
Comment 4 Wim Cos 2009-06-10 13:43:33 EDT
Created attachment 347265 [details]
Another traceback of crash
Comment 5 Chris Lumens 2009-06-10 14:10:17 EDT
When you hit this traceback, can you press "debug" to drop to the python debugger?  From there, type "up" to go up a frame so you're in the editEntry call, then paste into this bug report the results of the following:

print self.getSelected()

print dev

print devicePathToName(dev)

Thanks.  This will be very helpful in figuring out what's going on.  We should already be taking care of this problem.
Comment 6 Wim Cos 2009-06-10 15:15:51 EDT
OK here's the output:

print self.getSelected()
('mapper/vg_enterprise-lv_root', 'Fedora', True, True)

print dev
mapper/vg_enterprise-lv_root

print devicePathToName(dev)
*** NameError: name 'devicePathToName' is not defined
Comment 7 Chris Lumens 2009-06-11 09:54:33 EDT
*** Bug 505318 has been marked as a duplicate of this bug. ***
Comment 8 Jason Merrill 2009-06-11 10:15:33 EDT
I had a very similar experience: I accidentally changed the default partition to boot, and when I clicked the box by Fedora to change it back it cleared the checkbox for the other partition but didn't check the box for fedora, leaving me with no default selected.  I then went into Edit for the fedora partition, selected Default there and hit OK, and got a crash with the same traceback.
Comment 9 Andy Lindeberg 2009-06-22 10:37:19 EDT
*** Bug 507078 has been marked as a duplicate of this bug. ***
Comment 10 Risto Kankkunen 2009-07-10 19:50:13 EDT
I hit the same problem:

anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/osbootwidget.py", line 267, in editOther
    (oldshort, oldlong, oldisroot) = self.imagelist[oldDevice]
  File "/usr/lib/anaconda/iw/osbootwidget.py", line 334 ,in editEntry
    self.editOther(dev, label, isDefault, isRoot)
KeyError: 'mapper/vg_jabber-lv_root'

I checked self.imagelist and it was:

  self.imagelist == {'vg_jabber-lv_root' : ('linux', 'Fedora', 'ext4')}

So "imagelist" dictionary contains just the basename of the volume, but it is accessed with the "mapper/" prefix added.
Comment 11 Risto Kankkunen 2009-07-10 19:58:57 EDT
Some more details:

I did a pretty standard installation to a virtual machine using netinst.iso, edited hostname, reviewed partition settings and tried to change the Grub label.

Should be pretty easy to repro in 5 mins. If not, please tell and I can try again to record the exact steps.
Comment 12 Chris Lumens 2009-08-04 11:39:17 EDT
I just attempted to reproduce yet again with these steps and was unable to do so.  So yeah, the exact steps would be handy.
Comment 13 Chris Lumens 2009-09-16 09:26:37 EDT
*** Bug 505028 has been marked as a duplicate of this bug. ***
Comment 14 Chris Lumens 2009-09-16 09:26:44 EDT
*** Bug 523554 has been marked as a duplicate of this bug. ***
Comment 15 Phil Smith 2009-09-16 10:49:47 EDT
For clear instructions of how to crash (and later debug) when changing the "title" from "Fedora" to "Fedora 11" see below:
(more details in
https://bugzilla.redhat.com/show_bug.cgi?id=505028
)
0. Start with first disk (sda) containing Fedora 10 (and install on second disk: sdb)
1. Boot from normal Fedora 11 64 bit install DVD
2. 1st option for normal install
3. English
4. UK keyboard
5. Choose to Install
6. localhost... (the default)
7. Choose London or New York as timezone
8. Sys clock uses UTC (default)
9. enter password
10. Replace existing Linux system
11. Choose not to use (format) /dev/sda only /dev/sdb
12. Review and modify partitioning layout - check and don't change
12. Install boot loader on /dev/sda
13. NO boot loader password
14. Click on Fedora and Edit
15. Change from Fedora to Fedora 11
16. Exception
Exception occurred
An unhandled exception has accurred.  This is most likely ...  


I tried again with the alpha install DVD
 Fedora-12-Alpha-x86_64-DVD
and it worked OK.  No crash.
Did someone do something to fix it?
Comment 16 Chris Lumens 2009-09-16 11:15:40 EDT
No, I can't think of anything we've done to fix it but if you can verify it's fixed, I'll take that.
Comment 17 Chris Lumens 2009-09-21 09:48:15 EDT
*** Bug 524399 has been marked as a duplicate of this bug. ***
Comment 18 Scott Wimer 2010-01-25 01:33:40 EST
I've run into this before, and punted on the installation of Fedora 11.  After a few months had gone by, I forgot and tried to install Fedora 11 again.  This time, I actually bothered to see what the problem was.

I think I've figured it out.

The editOther() method assumes that the oldDevice parameter is a valid key in the self.imagelist dict (at line 267).  A look at self.imagelist in the debugger shows that the key(s) for this dict don't look like paths (no leading '/dev/' for example).

The getSelected() method in this file attempts to convert the device path that was stored in self.osStore (which is backing the self.osTreeView widget) into a device name from the path.  However, getSelected() only handles the removal of the '/dev/' prefix from the device path.  In the case of an LVM filesystem, the device name that would match the appropriate key in self.imagelist is prefixed by '/dev/mapper/'.  Hence, getSelected() returns a device name that starts with 'mapper/' and is therefor not a key in the self.imagelist dict.

One way to fix this would be to amend the getSelected() method as follows.

in /usr/lib/anaconda/iw/osbootwidget.py getSelected() line 296

Replace:
        theDev = dev[5:] # strip /dev/

With:
        if dev.startswith('/dev/mapper/'):
            theDev = dev[len('/dev/mapper/'):]
        elif dev.startswith('/dev/'):
            theDev = dev[len('/dev/'):]
        else:
            theDev = dev
Comment 19 Bug Zapper 2010-04-27 10:43:10 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 20 Bug Zapper 2010-06-28 08:51:12 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.