Bug 523597 - anaconda traceback w/ single drive from former dmraid RAID 0
Summary: anaconda traceback w/ single drive from former dmraid RAID 0
Keywords:
Status: CLOSED DUPLICATE of bug 518971
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 05:09 UTC by John Brier
Modified: 2013-08-14 23:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-16 18:46:53 UTC


Attachments (Terms of Use)
anaconda debug output (82.59 KB, text/plain)
2009-09-16 05:10 UTC, John Brier
no flags Details

Description John Brier 2009-09-16 05:09:25 UTC
Description of problem:

Anaconda had a traceback when finding storage. I have one disk installed in this system and it used to be a part of a dmraid (nvidia fake raid) RAID 0. Before the install it was formatted by Windows 7 RC installer and only had Windows 7, but apparently some of the nvidia/dmraid metadata was still on it. In the shell from anaconda I cleared the metadata like this:

dmraid -r /dev/sda{1?} -E

Then anaconda had no problems.

Version-Release number of selected component (if applicable):
12.15 ?

How reproducible:
probably 100% had I tried again

Steps to Reproduce:
1.boot F12 alpha on a system with a single disk from a former nvidia dmraid RAID 0

  
Actual results:


Expected results:
anaconda handles this properly and doesn't bork?

Additional info:

anaconda debug attached

Comment 1 John Brier 2009-09-16 05:10:29 UTC
Created attachment 361184 [details]
anaconda debug output

Comment 2 John Brier 2009-09-16 05:13:46 UTC
traceback may be useful for people searching Bugzilla:

anaconda 12.15 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 982, in __init__
    self._partedPartition = self.disk.partedDisk.getPartitionByPath(self.path)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1101, in addUdevPartitionDevice
    exists=True, parents=[disk])
  File "/usr/lib/anaconda/storage/devicetree.py", line 1258, in addUdevDevice
    device = self.addUdevPartitionDevice(info)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1864, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 293, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 92, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1201, in nextClicked
    self.anaconda.dispatch.gotoNext()
AttributeError: 'StorageDevice' object has no attribute 'partedDisk'


this also seems relevant:

[2009-09-16 00:36:11,787]    DEBUG: type detected on 'sda' is 'nvidia_raid_member'
[2009-09-16 00:36:11,790]    DEBUG: getFormat('nvidia_raid_member') returning DMRaidMember instance
[2009-09-16 00:36:11,860]    DEBUG: looking for device 'sda'...
[2009-09-16 00:36:11,861]    DEBUG: looking up parted Device: /dev/sda
[2009-09-16 00:36:11,864]    DEBUG: found StorageDevice instance (0x7fe56b15e790) --
  name = sda  status = True  parents = []
  kids = 0
  id = 1
  uuid = None  format = <storage.formats.dmraid.DMRaidMember object at 0x7fe55d371910>  size = 239366.931152
  major = 8  minor = 0  exists = True
  sysfs path = /devices/pci0000:00/0000:00:11.0/host0/target0:0:0/0:0:0:0/block/sda  label = None
  target size = 0  path = /dev/sda
  format args = []
[2009-09-16 00:36:11,868]    DEBUG: getFormat('None') returning DeviceFormat instance
[2009-09-16 00:36:11,871]    DEBUG: looking up parted Partition: /dev/sda1

Comment 3 Hans de Goede 2009-09-16 18:46:53 UTC
Hi,

The traceback you are seeing is fixed by this commit:
http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=76381b4cfafd4885a321525ef9968c26e6dcee58

(it was already reported in bug 518971)

As for how we handle disks with stale BIOS RAID metadata see bug 506861.

*** This bug has been marked as a duplicate of bug 518971 ***


Note You need to log in before you can comment on or make changes to this bug.