Bug 518971 - Fedora 12 Alpha installer crash
Summary: Fedora 12 Alpha installer crash
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:9de549005297f2aeb...
: 519101 520457 523597 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-24 12:36 UTC by Justin Clift
Modified: 2009-09-17 18:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-02 17:52:39 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (97.52 KB, text/plain)
2009-08-24 12:36 UTC, Justin Clift
no flags Details
Attached traceback automatically from anaconda. (83.62 KB, text/plain)
2009-09-17 18:12 UTC, orti1980
no flags Details

Description Justin Clift 2009-08-24 12:36:40 UTC
The following was filed automatically by anaconda:
anaconda 12.15 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 982, in __init__
    self._partedPartition = self.disk.partedDisk.getPartitionByPath(self.path)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1101, in addUdevPartitionDevice
    exists=True, parents=[disk])
  File "/usr/lib/anaconda/storage/devicetree.py", line 1258, in addUdevDevice
    device = self.addUdevPartitionDevice(info)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1864, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 293, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 92, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1201, in nextClicked
    self.anaconda.dispatch.gotoNext()
AttributeError: 'StorageDevice' object has no attribute 'partedDisk'

Comment 1 Justin Clift 2009-08-24 12:36:50 UTC
Created attachment 358446 [details]
Attached traceback automatically from anaconda.

Comment 2 Justin Clift 2009-08-24 12:59:27 UTC
This crash occured in the F12 Alpha installer when it was detecting storage devices.

There were 2 x 1TB Seagate 7200.12 drives, in a 2 partition Intel ICH10R "fake raid" RAID configuration containing and existing Centos 5.3 installation.

After deleting the fake raid partitions and setting the BIOS to AHCI mode, this crash no longer occured.

Comment 3 Andy Lindeberg 2009-08-25 14:13:57 UTC
*** Bug 519101 has been marked as a duplicate of this bug. ***

Comment 4 Winfrid Tschiedel 2009-08-25 14:34:32 UTC
Hi Andy,

Did you have a closer look at #519101 ?
I showed that manual activation with dmraid -ay avoids the crash
there is a problem with assignmnet of unformatted partitions
and there is at least for ESB2/ICH and LSI firmware a problem in firstboot.

Comment 5 Chris Lumens 2009-08-31 21:52:04 UTC
*** Bug 520457 has been marked as a duplicate of this bug. ***

Comment 6 Hans de Goede 2009-09-02 17:52:39 UTC
This should be fixed by this commit:
http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=76381b4cfafd4885a321525ef9968c26e6dcee58

Once a rawhide compose with anaconda-12.20-1 in the install.img has been done, you should be able to install from rawhide without issues.

Winfrid,

About bug 519101, the backtrace you posted there has the same root cause as this bug, so the duplicate marking is correct (and that backtrace should be fixed too).

I think their might still be other issues with the ESB2/ICH and LSI firmware, but please file a separate bug for those, and where possible one bug per issue.

Comment 7 Hans de Goede 2009-09-16 18:46:53 UTC
*** Bug 523597 has been marked as a duplicate of this bug. ***

Comment 8 orti1980 2009-09-17 18:12:37 UTC
Created attachment 361535 [details]
Attached traceback automatically from anaconda.


Note You need to log in before you can comment on or make changes to this bug.