Bug 523611 - kernel BUG at drivers/rtc/rtc-ps3.c:36 while booting RHEL6
Summary: kernel BUG at drivers/rtc/rtc-ps3.c:36 while booting RHEL6
Keywords:
Status: CLOSED DUPLICATE of bug 516218
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 07:24 UTC by Martin Banas
Modified: 2009-09-16 07:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-16 07:29:04 UTC


Attachments (Terms of Use)

Description Martin Banas 2009-09-16 07:24:31 UTC
Description of problem:

		Welcome to Red Hat Enterprise Linux
		Press 'I' to enter interactive startup.
Starting udev: ------------[ cut here ]------------
kernel BUG at drivers/rtc/rtc-ps3.c:36!
Oops: Exception in kernel mode, sig: 5 [#1]
SMP NR_CPUS=128 NUMA pSeries
Modules linked in: ipr pata_pdc2027x e1000
NIP: c00000000059fd3c LR: c00000000059fd34 CTR: c00000000059fd00
REGS: c00000015b113700 TRAP: 0700   Not tainted  (2.6.31-0.174.rc7.git2.fc12.ppc64)
MSR: 8000000000029032 <EE,ME,CE,IR,DR>  CR: 44222424  XER: 0000000f
TASK = c00000015cb9cfe0[399] 'hwclock' THREAD: c00000015b110000 CPU: 1
GPR00: c00000000059fd34 c00000015b113980 c000000001280610 fffffffffffffffe 
GPR04: c00000015b1139f8 0000000000000004 c00000015b113b64 0000000000000000 
GPR08: 0948000000000000 c000000001268fe8 c0000001595197d8 c00000015b1139f8 
GPR12: 0000000000004000 c0000000012d8500 00000fffe6905147 00000fffe6905018 
GPR16: 00000fffe69050f6 0000000000000000 000000004ab0588d 000000000005205a 
GPR20: 0000000000000001 0000000000000000 0000000000000000 0000000000000000 
GPR24: 0000000000000000 c000000000789370 ffffffffffffffea c00000015b113b40 
GPR28: c000000159519568 c00000015b113b40 c00000000121e600 c00000015b113980 
NIP [c00000000059fd3c] .ps3_get_time+0x3c/0x84
LR [c00000000059fd34] .ps3_get_time+0x34/0x84
Call Trace:
[c00000015b113980] [c00000000059fd34] .ps3_get_time+0x34/0x84 (unreliable)
[c00000015b113a20] [c000000000599634] .rtc_read_time+0xac/0xe8
[c00000015b113ac0] [c00000000059a224] .rtc_dev_ioctl+0x358/0x5a4
[c00000015b113bd0] [c0000000001e3410] .vfs_ioctl+0x70/0x10c
[c00000015b113c80] [c0000000001e3c48] .do_vfs_ioctl+0x6d8/0x748
[c00000015b113d70] [c0000000001e3d40] .SyS_ioctl+0x88/0xd0
[c00000015b113e30] [c0000000000085f0] syscall_exit+0x0/0x40
Instruction dump:
fba1ffe8 fbe1fff8 f821ff61 7c3f0b78 7c9d2378 60000000 60000000 387f0070 
389f0078 4baeb615 60000000 7c6307b4 <0b030000> eb9f0070 4baeffdd 60000000 
---[ end trace d75772e93fcbe94b ]---
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4

Version-Release number of selected component (if applicable):
RHEL6.0-20090915.0
kernel 2.6.31-0.174.rc7.git2.fc12.ppc64

How reproducible:
always

Steps to Reproduce:
1. install RHEL6.0-20090915.0 running default instalation
2. reboot into rescue mode, add "initrd" value to /etc/yaboot.conf (bug 519350)
3. reboot and try to boot your installed system
  
Actual results:
during the system boot kernel bug info is shown

Expected results:
There should be no kernel bug

Additional info:

Comment 2 Martin Banas 2009-09-16 07:29:04 UTC

*** This bug has been marked as a duplicate of bug 516218 ***


Note You need to log in before you can comment on or make changes to this bug.