Bug 516218 - IBM Power5 ppc64 system - kernel BUG at drivers/rtc/rtc-ps3.c:36!
Summary: IBM Power5 ppc64 system - kernel BUG at drivers/rtc/rtc-ps3.c:36!
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 516219 519240 523611 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-07 14:20 UTC by James Laska
Modified: 2013-09-02 06:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 522508 (view as bug list)
Environment:
Last Closed: 2009-08-27 18:17:37 UTC


Attachments (Terms of Use)

Description James Laska 2009-08-07 14:20:55 UTC
Description of problem:

Install F-12-Alpha on IBM power5 ppc64 system and it fails to boot with kernel trace.

Version-Release number of selected component (if applicable):
 * 2.6.31-0.125.rc5.git2.fc12.ppc64 


How reproducible:


Steps to Reproduce:
1. Install F-12-Alpha on IBM ppc64 system
  
Actual results:

Elapsed time since release of system processors: 4287 mins 0 secs

Config file read, 1024 bytes

Welcome to Fedora!
Hit <TAB> for boot options
Welcome to yaboot version 1.3.14 (Red Hat 1.3.14-14.fc12)
Enter "help" to get some basic usage information
boot: linux
Please wait, loading kernel...
   Elf64 kernel loaded...
Loading ramdisk...
ramdisk loaded at 03900000, size: 3791 Kbytes
OF stdout device is: /vdevice/vty@30000000
Preparing to boot Linux version 2.6.31-0.125.rc5.git2.fc12.ppc64 (mockbuild@ppc4.fedora.phx.redhat.com) (gcc version 4.4.1 20090725 (Red Hat 4.4.1-3) (GCC) ) #1 SMP Tue Aug 4 03:04:27 EDT 2009
Calling ibm,client-architecture...command line: root=/dev/mapper/vg_ibm505lp1-lv_root ro console=hvc0 rhgb quiet 
memory layout at init:
  alloc_bottom : 0000000003cb4000
  alloc_top    : 0000000008000000
  alloc_top_hi : 00000000f5000000
  rmo_top      : 0000000008000000
  ram_top      : 00000000f5000000
instantiating rtas at 0x00000000076a1000... done
boot cpu hw idx 0000000000000000
starting cpu hw idx 0000000000000002... done
starting cpu hw idx 0000000000000004... done
starting cpu hw idx 0000000000000006... done
copying OF device tree...
Building dt strings...
Building dt structure...
Device tree strings 0x0000000003db5000 -> 0x0000000003db634d
Device tree struct  0x0000000003db7000 -> 0x0000000003dca000
Calling quiesce...
returning from prom_init
Phyp-dump not supported on this hardware
		Welcome to Fedora 
		Press 'I' to enter interactive startup.
Starting udev: ------------[ cut here ]------------
kernel BUG at drivers/rtc/rtc-ps3.c:36!
Oops: Exception in kernel mode, sig: 5 [#1]
SMP NR_CPUS=128 NUMA pSeries
Modules linked in: ipr [last unloaded: scsi_wait_scan]
NIP: c00000000059e460 LR: c00000000059e458 CTR: c00000000059e424
REGS: c0000000edcc3570 TRAP: 0700   Not tainted  (2.6.31-0.125.rc5.git2.fc12.ppc64)
MSR: 8000000000029032 <EE,ME,CE,IR,DR>  CR: 44222424  XER: 00000000
TASK = c0000000edcb8000[233] 'hwclock' THREAD: c0000000edcc0000 CPU: 0
GPR00: c00000000059e458 c0000000edcc37f0 c00000000127e930 fffffffffffffffe 
GPR04: c0000000edcc3868 0000000000000004 c0000000edcc39d4 0000000000000000 
GPR08: 08b8000000000000 c000000001267318 c0000000ec5964e8 c0000000edcc3868 
GPR12: 0000000000004000 c0000000012d8300 0000000010019d40 00000000ffaccdbb 
GPR16: 0000000000000000 00000000ffaccc90 0000000000000000 0000000010020000 
GPR20: 0000000000000000 000000000009ecc4 000000004a7c35bc 0000000000000001 
GPR24: 0000000040247009 c000000000787358 ffffffffffffffea c0000000edcc39b0 
GPR28: c0000000ec596278 c0000000edcc39b0 c00000000121c870 c0000000edcc37f0 
NIP [c00000000059e460] .ps3_get_time+0x3c/0x84
LR [c00000000059e458] .ps3_get_time+0x34/0x84
Call Trace:
[c0000000edcc37f0] [c00000000059e458] .ps3_get_time+0x34/0x84 (unreliable)
[c0000000edcc3890] [c000000000597d58] .rtc_read_time+0xac/0xe8
[c0000000edcc3930] [c000000000598948] .rtc_dev_ioctl+0x358/0x5a4
[c0000000edcc3a40] [c0000000001e3c60] .vfs_ioctl+0x70/0x10c
[c0000000edcc3af0] [c0000000001e4498] .do_vfs_ioctl+0x6d8/0x748
[c0000000edcc3be0] [c0000000001e4590] .SyS_ioctl+0x88/0xd0
[c0000000edcc3ca0] [c0000000002262fc] .do_ioctl32_pointer+0x3c/0x5c
[c0000000edcc3d40] [c00000000022b224] .compat_sys_ioctl+0x43c/0x4c4
[c0000000edcc3e30] [c0000000000085f0] syscall_exit+0x0/0x40
Instruction dump:
fba1ffe8 fbe1fff8 f821ff61 7c3f0b78 7c9d2378 60000000 60000000 387f0070 
389f0078 4baece3d 60000000 7c6307b4 <0b030000> eb9f0070 4baf1805 60000000 
---[ end trace ed3854884192069a ]---


Expected results:

 * No call trace

Additional info:

 * System: ibm-505-lp1.test.redhat.com

Comment 1 Harald Hoyer 2009-08-11 11:07:49 UTC
*** Bug 516219 has been marked as a duplicate of this bug. ***

Comment 2 Chuck Ebbert 2009-08-25 20:45:14 UTC
*** Bug 519240 has been marked as a duplicate of this bug. ***

Comment 3 Chuck Ebbert 2009-08-25 20:48:16 UTC
Fix is here:
http://www.mail-archive.com/linuxppc-dev@lists.ozlabs.org/msg36409.html

Hopefully this will make 2.6.31-final...

Comment 4 Chuck Ebbert 2009-08-27 18:17:37 UTC
Fix is merged upstream.

Comment 5 Martin Banas 2009-09-16 07:29:04 UTC
*** Bug 523611 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.