Bug 523628 - guest kernel panic when boot rhel3.9-x86_64 with more than 4gb mem on AMD host
guest kernel panic when boot rhel3.9-x86_64 with more than 4gb mem on AMD host
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Gleb Natapov
Lawrence Lim
:
: 654550 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-16 04:48 EDT by Suqin Huang
Modified: 2014-03-25 21:01 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 15:36:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel panic (17.74 KB, image/png)
2009-09-16 04:48 EDT, Suqin Huang
no flags Details
Kernel panic: pci_map_single: high address but no IOMMU (8.83 KB, text/x-log)
2009-09-19 09:18 EDT, lihuang
no flags Details

  None (edit)
Description Suqin Huang 2009-09-16 04:48:36 EDT
Created attachment 361214 [details]
kernel panic

Description of problem:
kernel panic when boot rhel3.9-x86_64 on AMD host with smp or up kernel.

Version-Release number of selected component (if applicable):
kvm-83-105.el5_4.3
kvm-83-114.el5

How reproducible:
always

Steps to Reproduce:
1. Install rhel3.9-x86_64 on AMD host with iso or network or pxe.
CLI:
/usr/libexec/qemu-kvm -drive file=/data/images/rhel/rhel3.9-64-amd.raw,if=ide -dirve file=/data/images/rhel/boot.iso,index=2,media=cdrom -no-hpet -rtc-td-hack -smp 2 -m 4G -uuid `uuidgen` -net nic,model=e1000,macaddr=00:96:88:FE:DD:55,vlan=0 -net tap,vlan=0,script=/etc/qemu-ifup -cpu qemu64,+sse2 -boot d -monitor stdio -vnc :8 
2. boot vm 
3.
  
Actual results:


Expected results:
attach the error

Additional info:
1. this issue can be reproduced on kvm-83-105.el5_4.3 and kvm-83-114.el5
2. host:

processor	: 15
vendor_id	: AuthenticAMD
cpu family	: 16
model		: 2
model name	: Quad-Core AMD Opteron(tm) Processor 8356
3. rhel3.9-x86_64 can be installed and booted successfully on Intel host.
Comment 1 lihuang 2009-09-19 09:18:37 EDT
Created attachment 361763 [details]
Kernel panic: pci_map_single: high address but no IOMMU

with 2gb ram. vm starts normally

with 4gb ram. -> Kernel panic: pci_map_single: high address but no IOMMU.
( log is attached )
Comment 2 Gleb Natapov 2009-10-30 03:46:53 EDT
We don't emulate IOMMU and without it 4G of memory is not supported. Shouldn't work on Intel either. Can you provide dmesg on Intel host?
Comment 3 Gleb Natapov 2009-10-30 03:55:31 EDT
Actually vmware analyzed this problem for us: http://communities.vmware.com/thread/42332

"QA found that RedHat AS3 update2 and newer (up to and including latest
available at this moment, update7) do not work with hugemem on AMD
processors. It happens because RHAS3 amd64 kernels require either AMD's
IOMMU, or they'll crash. Workaround for these kernels is (hopefully)
to install *.ia32e.rpm package - like kernel-2.4.21-27.EL.ia32e.rpm.
But they won't work out of the box."
Comment 4 Dor Laor 2009-11-08 04:03:25 EST
Moving to on_qa. It should be closed as 'not a bug'
Comment 5 Suqin Huang 2009-11-17 02:20:53 EST
I check on StableSystem :x86-64-3as.ss.eng.bos.redhat.com, which memory is nearly 4G

.qa.[root@x86-64-3as root]# free -m
             total       used       free     shared    buffers     cached
Mem:          3899       1344       2555          0        201        657
-/+ buffers/cache:        486       3413
Swap:         1992          0       1992

.qa.[root@x86-64-3as root]# uname -a
Linux x86-64-3as.ss.eng.bos.redhat.com 2.4.21-63.ELsmp #1 SMP Wed Oct 28 23:07:38 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

.qa.[root@x86-64-3as root]# cat /proc/cpuinfo 
processor	: 1
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 5
model name	: AMD Opteron(tm) Processor 246
Comment 6 Gleb Natapov 2009-11-17 02:33:21 EST
What info do you need? Where is the question?
Comment 7 Suqin Huang 2009-11-17 03:22:09 EST
1. Guest can not boot with 4G mem
2. according to comment #5, rhel3.9 amd64 require either AMD's
IOMMU or they'll crash when boot with mem more than 2G, right?
3. physical machine can boot with 4G mem.

if 2 is correct, 3 is impossible.
3 is really exist,so 2 is incorrect.
Comment 8 Suqin Huang 2009-11-17 03:27:09 EST
(In reply to comment #7)
> 1. Guest can not boot with 4G mem
> 2. according to comment #5, rhel3.9 amd64 require either AMD's
> IOMMU or they'll crash when boot with mem more than 2G, right?
> 3. physical machine can boot with 4G mem.
> 
> if 2 is correct, 3 is impossible.
> 3 is really exist,so 2 is incorrect.  

Modify point 2
it should be: 4G not 2G

2. according to comment #5, rhel3.9 amd64 require either AMD's IOMMU or they'll crash when boot with 4G mem, right?
Comment 9 Gleb Natapov 2009-11-17 03:29:50 EST
(In reply to comment #7)
> 1. Guest can not boot with 4G mem
> 2. according to comment #5, rhel3.9 amd64 require either AMD's
> IOMMU or they'll crash when boot with mem more than 2G, right?
> 3. physical machine can boot with 4G mem.
> 
> if 2 is correct, 3 is impossible.
> 3 is really exist,so 2 is incorrect.  

Physical machine obviously has AMD IOMMU. 2 is correct and 3 is correct.
Comment 10 Gleb Natapov 2010-12-15 05:15:18 EST
*** Bug 654550 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.