Bug 654550 - Kernel panic when rhel3.9 64bit guest is booting up with 4G mem on AMD host.
Kernel panic when rhel3.9 64bit guest is booting up with 4G mem on AMD host.
Status: CLOSED DUPLICATE of bug 523628
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
All Linux
high Severity medium
: rc
: ---
Assigned To: Gleb Natapov
Virtualization Bugs
:
Depends On: 638489
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-11-18 02:47 EST by Golita Yue
Modified: 2013-12-08 19:51 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 638489
Environment:
Last Closed: 2010-12-15 05:15:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot-log_guest (7.56 KB, text/plain)
2010-11-18 03:39 EST, Golita Yue
no flags Details

  None (edit)
Comment 1 Golita Yue 2010-11-18 03:38:31 EST
Description of problem:
Install a rhel3u9 64bit guest on AMD host, when the guest is booting up, the
following is reported:
hda: lost interrupt
hda: lost interrupt
......
Kernel panic: pci_map_single: high address but no IOMMU.

Version-Release number of selected component (if applicable):
kvm-83-207.el5
kernel-2.6.18-231.el5

How reproducible:
Always

Steps to Reproduce:
1. Install a RHEL3U9 x86_64 guest on AMD host 
2. After installation is finished, the guest will reboot, check the boot up
process.

Actual results:
Kernel panic: pci_map_single: high address but no IOMMU.
Attached the boot-log-guest 

cmd:
/usr/libexec/qemu-kvm -m 4G -smp 1 -name r3.9-64-1 -uuid `uuidgen` -serial stdio -boot c -drive file=/mnt/r3.9-64.raw,boot=on,format=raw,cache=none,if=ide,werror=stop -net nic,macaddr=00:52:00:23:b5:50,model=rtl8139,vlan=0 -net tap,vlan=0,script=/etc/qemu-ifup -no-hpet -no-kvm-pit-reinjection -usbdevice tablet -rtc-td-hack -startdate now -cpu qemu64 -M rhel5.6.0 -notify all -vnc :1

Expected results:
The guest is booted up smoothly.

Additional info:
when vmem=2G  PASS
Comment 2 Golita Yue 2010-11-18 03:39:29 EST
Created attachment 461240 [details]
boot-log_guest
Comment 3 Gleb Natapov 2010-12-15 05:15:18 EST
Please search bugzilla for similar issues before opening new bugs.

*** This bug has been marked as a duplicate of bug 523628 ***

Note You need to log in before you can comment on or make changes to this bug.