Bug 523677 - add support for s390x
add support for s390x
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
s390x Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2009-09-16 08:39 EDT by Dan Horák
Modified: 2009-09-30 08:17 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-30 08:17:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch with s390x support (244.83 KB, patch)
2009-09-16 08:39 EDT, Dan Horák
no flags Details | Diff
update to spec (1.24 KB, text/plain)
2009-09-16 08:40 EDT, Dan Horák
no flags Details

  None (edit)
Description Dan Horák 2009-09-16 08:39:39 EDT
Created attachment 361265 [details]
patch with s390x support

Currently QEMU can't be built on s390x because mainly the tcg part is missing. It looks like that Ulrich Hecht from SUSE is working on full s390x support for upstream QEMU (see http://lists.gnu.org/archive/html/qemu-devel/2009-07/msg01910.html for recent patches). I took them and updated for qemu-kvm, the result is in attachment. I don't think there is an immediate need for a s390x emulator, but we need the other ones to be built on s390x.
Comment 1 Dan Horák 2009-09-16 08:40:21 EDT
Created attachment 361266 [details]
update to spec
Comment 3 Glauber Costa 2009-09-16 08:51:23 EDT
I am not that used to that platform, but as far as I understand, host and target support for s390 should be orthogonal.

What we need to support your case is pieces of patches 2 and 3.

Also, how urgent, and on which basis does your request come? If those patches are likely to be included upstream, they will eventually reach our package anyway
Comment 4 Dan Horák 2009-09-16 10:40:09 EDT
Some related discussion is in bug #523228 and it all depends on what will be supported configurations in RHEL-6.
Comment 5 Mark McLoughlin 2009-09-21 09:01:38 EDT
Please keep the Fedora request separate from the RHEL6 request

When this gets upstream, we'll certainly enable it in Fedora

I'm a bit reluctant to include the patch because, if for whatever reason, it stops working we'll just disable it again rather than trying to fix it. And I'm not keen on removing features once we've added them

Dan: would you be willing to maintain the patch for Fedora until it gets upstream? e.g. if we re-base to an upstream would you fix up the conflicts? Or if there are bugs, could we assign them to you?
Comment 6 Dan Horák 2009-09-30 08:17:59 EDT
(In reply to comment #5)
> Please keep the Fedora request separate from the RHEL6 request

We are trying to keep F-12 and RHEL-6 as close as possible due the limited resources we have.
 
> When this gets upstream, we'll certainly enable it in Fedora
> 
> I'm a bit reluctant to include the patch because, if for whatever reason, it
> stops working we'll just disable it again rather than trying to fix it. And I'm
> not keen on removing features once we've added them
>
> Dan: would you be willing to maintain the patch for Fedora until it gets
> upstream? e.g. if we re-base to an upstream would you fix up the conflicts? Or
> if there are bugs, could we assign them to you?  

I am able to maintain them, but because there is no immediate need for qemu on s390x, I am closing this request. I will track the situation in upstream and eventually open a new request, if some action from qemu maintainers will be needed.

Note You need to log in before you can comment on or make changes to this bug.