Bug 523846 - A4 only size Kmail will print (without 'size-changing' work-around, that is).
A4 only size Kmail will print (without 'size-changing' work-around, that is).
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Desktop, Patch, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-16 16:30 EDT by Lamar Owen
Modified: 2013-10-04 08:20 EDT (History)
11 users (show)

See Also:
Fixed In Version: qt-4.6.2-14.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-25 09:49:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Snap of system-config-printer properties box. (51.80 KB, image/png)
2009-09-16 16:30 EDT, Lamar Owen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 180051 None None None Never
KDE Software Compilation 185296 None None None Never
Qt Bug Tracker QTBUG-6471 None None None Never

  None (edit)
Description Lamar Owen 2009-09-16 16:30:22 EDT
Created attachment 361367 [details]
Snap of system-config-printer properties box.

Description of problem:
Regardless of locale setting, regardless of paper size setting, kmail sends A4 size pages to the printer.

Version-Release number of selected component (if applicable):
kdepim-4.3.1-1.fc11.i586

How reproducible:
Always.

Steps to Reproduce:
1.Select an e-mail message
2.Print the message.
3.Go to printer (HP Laserjet 8000) which is asking for A4 paper to be inserted in the tray.
  
Actual results:
Printer has to be manually overridden to print from letter size paper; the resulting printout is clipped off at the top and bottom (as printing an A4 sized page to a letter page would do).

Expected results:
Kmail should print the size set in the printer options.

Additional info:
Comment 1 Steven M. Parrish 2009-10-02 05:01:05 EDT
Thank you for taking the time to report this issue.

This is an issue that needs to be addressed by the upstream developers. Please report this at http://bugs.kde.org and then add the upstream report information to this report.  We will monitor the upstream report for a resolution to this issue, and will review any bug fixes that become available for consideration in future updates.

Setting status to NEEDINFO, and awaiting upstream bug report URL for tracking.

Thanks in advance.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Garry T. Williams 2009-10-21 14:49:53 EDT
I added a comment to

    https://bugs.kde.org/show_bug.cgi?id=185296

which happens to be a report about wrong paper size using okular.  I note that the exact same symptom happens with Kmail.

There seems to be common code used for both applications' printing function.
Comment 3 Rex Dieter 2009-10-21 14:56:30 EDT
Interesting comment.

Yes, it's common code.
Comment 4 Lamar Owen 2009-10-21 15:37:00 EDT
Glad to see this get some love.  It's been annoying as all get out, and has been that way for over a year.  Saw it when I was running Kubuntu prior to F11's release; hoped F11 would get rid of it, which it didn't.

Thanks, Gary, for commenting on the bug on the kde bugzilla.  I would have, but, honestly, I don't have time to track multiple bugzillas, and it wasn't at all clear where this bug should have been filed in the first place.  Already have too many logins to different places.  I've done my fair share of tracking bugs before in my five years maintaining the PostgreSQL.org RPM package set; I'm pretty familiar with the stuff.  But to what component should it be filed?  If I'm going to take the time to file a report, I want it to be in the right place and not annoy the wrong developer.

Speaking of annoying the wrong developer, I had read that particular bug number on the kde bugzilla previously, and, honestly, the developer attitude was pretty deplorable, especially with such a clear bug report.  It sounded like the developer figured that the user should track down all these dependencies for Okular himself, and bug the Qt people instead of him, and he's certainly not going to deal with the Qt people on the users' behalf.  At least that's the impression I got.

In my case, I see and live with this bug every single week as I go to print staff meeting notes (distributed via e-mail in the body of the e-mail as text) for our weekly staff meeting, and it's pretty embarrassing that, in the Windows users' eyes at least, "Linux can't even figure out how to print to the right size paper."

Having said all that, I would be glad to file a report to the correct place if someone could let me know where that place is and to what component it needs to be filed so that the right person will see it and fix it..... If there were a component dependency tree or something similar, that would help; but there isn't a such thing that I could find (other than going through the specfile myself and ferreting out the dependencies manually).
Comment 5 Rex Dieter 2009-10-21 15:51:45 EDT
Lamar, I hear ya.  This is an annoying one, but I believe Garry's inqusitive investgative work should yield results in the upstream bug.

I'll see if I can ping a kde-devel ninja to look at it.
Comment 6 EMR_Fedora 2010-02-01 09:29:34 EST
See http://bugreports.qt.nokia.com/browse/QTBUG-3567 for details. Any application that prints through QT will have a problem. So it might go further up than just KDE.
Comment 7 Kevin Kofler 2010-02-01 10:07:55 EST
See also https://bugs.kde.org/show_bug.cgi?id=180051
Comment 8 Kevin Kofler 2010-02-01 10:11:09 EST
Patch by Jeremy Sanders (from kde#180051) which makes the Qt print dialog default to the default settings from CUPS (where e.g. system-config-printer-kde stores them):
http://bugsfiles.kde.org/attachment.cgi?id=40415

IMHO we should apply this patch.
Comment 9 Ngo Than 2010-02-17 12:39:09 EST
the patch is included in qt-4.6.1-3 or newer.
Comment 10 Orion Poplawski 2010-03-04 19:00:08 EST
A patch has been posted to http://bugreports.qt.nokia.com/browse/QTBUG-6471 which fixed the problem for me.
Comment 11 Kevin Kofler 2010-03-04 19:11:00 EST
The thing is, there's already a patch in Qt 4.6.1-3 which is supposed to address the issue of CUPS settings not getting loaded. But the settings that patch loads are just 3 hardcoded settings, paper size is not a part of that. :-/

I wonder if we should drop that other CUPS settings patch or if both are needed.
Comment 12 Kevin Kofler 2010-03-04 19:12:39 EST
(And all builds newer than 4.6.1-3 also have that other CUPS settings patch, 4.6.2-3 fixes a crash bug in that patch.)
Comment 13 Lamar Owen 2010-03-24 13:56:02 EDT
Still having to use the 'manually set paper size to something, then back to letter' workaround, with the following package versions:
qt-4.6.2-8.fc12.i686
kdepim-4.4.1-2.fc12.i686

Just double-checked, and if I leave the paper size at the default, I get A4 sent to the printer.  Printer default is set for Letter in 'system-config-printers'.
Comment 14 Garry T. Williams 2010-04-14 11:41:53 EDT
I added a comment to:

    https://bugs.kde.org/show_bug.cgi?id=185296 

and I note that this seems to be the root cause:

    http://bugreports.qt.nokia.com/browse/QTBUG-6471 

and that qt 4.6.3 supposedly will contain a fix.
Comment 15 Lamar Owen 2010-04-14 12:55:39 EDT
Thanks for the update, and the link, and maybe it will get fixed.  Should be in the QT component, though, rather than kdepim....but how is a user to know this?  That's the thing that has been aggravating folks about this issue, as all the run-around that's gone around.
Comment 16 Lamar Owen 2010-04-14 13:00:59 EDT
Also, the QT bugtracker is not in the External Bugs dropdown to add a pointer to that bug listed above.
Comment 17 Ngo Than 2010-04-16 04:27:51 EDT
The new qt-4_6_2-14_fc11 will include the the upstream fix for this issue. Could you please download and test it whether it fixes the problem? thanks

http://koji.fedoraproject.org/koji/taskinfo?taskID=2118679
Comment 18 Garry T. Williams 2010-04-19 08:18:23 EDT
I installed qt-4.6.2-14.fc12.x86_64 (and dependencies) and this fixes the bug.

Yippie!  Thank you, Than.
Comment 19 Fedora Update System 2010-04-19 08:42:37 EDT
qt-4.6.2-14.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/qt-4.6.2-14.fc13
Comment 20 Fedora Update System 2010-04-19 08:43:37 EDT
qt-4.6.2-14.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/qt-4.6.2-14.fc12
Comment 21 Fedora Update System 2010-04-19 08:48:44 EDT
qt-4.6.2-14.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qt-4.6.2-14.fc11
Comment 22 Fedora Update System 2010-04-20 09:04:41 EDT
qt-4.6.2-14.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/qt-4.6.2-14.fc13
Comment 23 Fedora Update System 2010-04-20 09:29:58 EDT
qt-4.6.2-14.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/qt-4.6.2-14.fc12
Comment 24 Fedora Update System 2010-04-20 09:33:11 EDT
qt-4.6.2-14.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/qt-4.6.2-14.fc11
Comment 25 Fedora Update System 2010-04-25 09:49:10 EDT
qt-4.6.2-14.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 Fedora Update System 2010-04-26 22:28:05 EDT
qt-4.6.2-14.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Fedora Update System 2010-04-26 22:30:46 EDT
qt-4.6.2-14.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 28 Kevin Kofler 2010-10-07 12:14:38 EDT
FYI, the patch discussed in comment #8, comment #9 and comment #11 (which was applied in qt-4.6.1-3) actually fixes bug 480954.
Comment 29 Red Hat Bugzilla 2013-10-03 20:19:24 EDT
Removing external tracker bug with the id '6471' as it is not valid for this tracker

Note You need to log in before you can comment on or make changes to this bug.