Bug 587016 - KDE Print Dialogue Does Not Remember Previous Settings
KDE Print Dialogue Does Not Remember Previous Settings
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kdelibs (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ngo Than
Desktop QE
:
Depends On:
Blocks: 662543
  Show dependency treegraph
 
Reported: 2010-04-28 13:31 EDT by Colin Coles
Modified: 2013-03-21 05:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: kdelibs-4.3.4-15.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 04:31:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 480954 None None None Never
Red Hat Bugzilla 523846 None None None Never

  None (edit)
Description Colin Coles 2010-04-28 13:31:29 EDT
Description of problem:
In Konqueror (and most other kde applications) the printer settings previous selections are not automatically remembered next time printer dialogue is used nor is there a method to save the settings. This is both: time consuming when multiple pages with same settings requirements are printed and; a step backwards from the modus operandi of kde 3. It is an old bug present in Fedora 9 and later, just hoping reporting it here may make a difference.


Version-Release number of selected component (if applicable):

Konqueror Version 4.3.4 (KDE 4.3.4)

How reproducible:

Always


Steps to Reproduce:
1.Using Konqueror Browser
2.File => Print
3.Options => HTML Settings
4.Uncheck Print Images
5.Click Print
6.Then Repeat 2 and 3
  
Actual results:

Print Images Checked

Expected results:

Print Images Unchecked


Additional info:
This bug has been reported both to KDE and QT in the past. It'll be interesting to see if anything is done now it's in RHEL6
Comment 2 RHEL Product and Program Management 2010-04-28 14:56:52 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 7 Kevin Kofler 2010-10-07 12:02:32 EDT
Well, in Fedora, and AFAIK RHEL6 inherits the relevant patches from Fedora, the Qt/KDE print dialog should at least be honoring the settings you set as defaults in CUPS, thanks to this Qt patch:
http://pkgs.fedoraproject.org/gitweb/?p=qt.git;a=blob;f=qt-everywhere-opensource-src-4.6.2-cups.patch;h=e0305e11b89aa6332573a0e9bb955f38038a8123;hb=HEAD
(The patch comes from the KDE bug report and handles Duplex, Color/Grayscale and Collate.)
But it still won't remember previous settings in the dialog itself.

-- Kevin Kofler, comaintainer of Qt and KDE in Fedora
Comment 8 Kevin Kofler 2010-10-07 12:15:35 EDT
Linking the Fedora bug (bug 480954) as well.
Comment 9 Kevin Kofler 2010-10-07 12:18:41 EDT
AFAIK, RHEL6 also carries this backported patch:
http://pkgs.fedoraproject.org/gitweb/?p=qt.git;a=blob;f=qt-everywhere-opensource-src-4.6.2-cups-QTBUG-6471.patch;h=82e894d70d05f36f4e3d45f80196dda1746fdba6;hb=c8bc3519acee2e79f91f47c66ea4addf741fad91
from upstream Nokia which is included in 4.6.3 and newer releases of Qt.

This patch makes the Qt/KDE print dialog default to the paper size set in the CUPS settings. See Fedora bug 523846.
Comment 10 Kevin Kofler 2010-10-07 12:19:31 EDT
Oops, I meant to link the KDE bug, too, but somehow it got forgotten.
Comment 11 Kevin Kofler 2010-10-07 12:21:17 EDT
(Well, it's just getting ignored. Does Bugzilla not accept upstream bug references on RHEL bugs? Sorry for the bugspam.)
Comment 12 RHEL Product and Program Management 2011-01-07 10:32:51 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 19 errata-xmlrpc 2012-09-11 04:31:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1251.html

Note You need to log in before you can comment on or make changes to this bug.