Bug 523940 - segfault after xinit
Summary: segfault after xinit
Keywords:
Status: CLOSED DUPLICATE of bug 522909
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: rawhide
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-17 10:00 UTC by Marcela Mašláňová
Modified: 2018-04-11 07:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-17 14:26:19 UTC


Attachments (Terms of Use)
dmeg output (45.62 KB, text/plain)
2009-09-17 11:07 UTC, Marcela Mašláňová
no flags Details
log from X (104.61 KB, text/plain)
2009-09-17 11:07 UTC, Marcela Mašláňová
no flags Details

Description Marcela Mašláňová 2009-09-17 10:00:48 UTC
Description of problem:
segfault after startx or xinit. KDM or GDM doesn't start.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.13.0-0.4.20090908git651fe5a47.fc12.x86_64
xorg-x11-server-Xorg-1.6.99.901-2.fc12.x86_64

How reproducible:
(K|G)DM are not working. Try to start X with startx or xinit.

  
Actual results:
Fatal server error:
Server is already active for display 0
<------>If this server is no longer running, remove /tmp/.X0-lock
<------>and start again.


Please consult the The X.Org Foundation support.
<------> at http://bodhi.fedoraproject.org/
 for help..


Backtrace:
0: X (xorg_backtrace+0x28) [0x45e898]
1: X (0x400000+0x62229) [0x462229]
2: /lib64/libpthread.so.0 (0x33c1400000+0xf320) [0x33c140f320]
3: /usr/lib64/libpciaccess.so.0 (pci_device_vgaarb_fini+0xa) [0x33c2c03d0a]
4: X (ddxGiveUp+0x9) [0x46e469]
5: X (0x400000+0x6824d) [0x46824d]
6: X (0x400000+0x6893e) [0x46893e]
7: X (LockServer+0x351) [0x464741]
8: X (OsInit+0x326) [0x462086]
9: X (0x400000+0x21a66) [0x421a66]
10: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x33c081eb4d]
11: X (0x400000+0x21859) [0x421859]
Segmentation fault at address 0x18

FatalError re-entered, aborting
Caught signal 11 (Segmentation fault). Server aborting

No protocol specified
giving up.^
xinit:  Resource temporarily unavailable (errno 11):  unable to connect to X server^
xinit:  No such process (errno 3):  unexpected signal 2.

Expected results:
be able to log in with (K|G)DM.

Additional info:
I have no xorg.conf.
Output from lspci:
00:00.0 Host bridge: nVidia Corporation nForce3 250Gb Host Bridge (rev a1)
00:01.0 ISA bridge: nVidia Corporation nForce3 250Gb LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation nForce 250Gb PCI System Management (rev a1)
00:02.0 USB Controller: nVidia Corporation CK8S USB Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation CK8S USB Controller (rev a1)
00:02.2 USB Controller: nVidia Corporation nForce3 EHCI USB 2.0 Controller (rev a2)
00:05.0 Bridge: nVidia Corporation CK8S Ethernet Controller (rev a2)
00:08.0 IDE interface: nVidia Corporation CK8S Parallel ATA Controller (v2.5) (rev a2)
00:0a.0 IDE interface: nVidia Corporation nForce3 Serial ATA Controller (rev a2)
00:0b.0 PCI bridge: nVidia Corporation nForce3 250Gb AGP Host to PCI Bridge (rev a2)
00:0e.0 PCI bridge: nVidia Corporation nForce3 250Gb PCI-to-PCI Bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation G73 [GeForce 7600 GS] (rev a2)
02:09.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 08)

Comment 1 Marcela Mašláňová 2009-09-17 11:07:04 UTC
Created attachment 361477 [details]
dmeg output

Comment 2 Marcela Mašláňová 2009-09-17 11:07:27 UTC
Created attachment 361478 [details]
log from X

Comment 3 Matěj Cepl 2009-09-17 14:26:19 UTC

*** This bug has been marked as a duplicate of bug 522909 ***


Note You need to log in before you can comment on or make changes to this bug.