Bug 524080 - mdadm segfaults with --export
mdadm segfaults with --export
Status: CLOSED DUPLICATE of bug 526761
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-17 15:28 EDT by Allen Kistler
Modified: 2009-10-01 14:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-01 14:31:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Allen Kistler 2009-09-17 15:28:51 EDT
Description of problem:
During boot, udevd-work tries to run mdadm, but mdadm segfaults.  mdadm segfaults from the command line if run with the --export switch.  mdadm does not segfault if the --export switch is omitted.

Version-Release number of selected component (if applicable):
mdadm-3.0-3.fc12.i686

How reproducible:
Always

Steps to Reproduce:
1. Boot and watch the messages when/after udev starts
2. Or run "mdadm --detail --export /dev/md0" (for example)
  
Actual results:
Error messages during boot.  Segfault on the command line.
(See below.)

Expected results:
No error messages.  No segfaults.

Additional info:

At boot (excerpt):
------------------
		Welcome to Fedora
		Press 'I' to enter interactive startup.
Starting udev:
 udevd-work[431]: '/sbin/mdadm --detail --export /dev/md0' unexpected exit with status 0x000b
 udevd-work[418]: '/sbin/mdadm --detail --export /dev/md1' unexpected exit with status 0x000b
                                                            [OK]
Setting hostname vtest:                                     [OK]
Setting up Logical Volume Management:   2 logical volume(s) in volume group "vg0" now active
                                                            [OK]
Checking filesystems
/dev/mapper/vg0-f12: clean, 24640/242400 files, 181335/968704 blocks
/dev/md0: clean, 42/26104 files, 30987/104320 blocks
                                                            [OK]
Remounting root filesystem in read-write mode:              [OK]
 udevd-work[626]: '/sbin/mdadm --detail --export /dev/md0' unexpected exit with status 0x000b


From the command line:
----------------------
# mdadm --detail --export /dev/md0
MD_LEVEL=raid1
MD_DEVICES=2
MD_METADATA=0.90
MD_UUID=ae7e4c77:f1a38c74:b1d2a0df:58db6c17
Segmentation fault
Comment 1 Alexey Torkhov 2009-09-22 13:06:40 EDT
Seem to be duplicate of 523862.
Comment 2 Harald Hoyer 2009-10-01 14:31:28 EDT

*** This bug has been marked as a duplicate of bug 526761 ***

Note You need to log in before you can comment on or make changes to this bug.