Bug 526761 - mdadm segfaults
mdadm segfaults
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
rawhide
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
: 524080 (view as bug list)
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-10-01 13:26 EDT by Harald Hoyer
Modified: 2009-10-05 14:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-05 14:10:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2009-10-01 13:26:04 EDT
[root@localhost ~]# rpm -q mdadm
mdadm-3.0-4.fc12.i686

[root@localhost ~]# uname -r
2.6.31-2.fc12.i686

[root@localhost ~]# mdadm --export --detail /dev/md0
MD_LEVEL=raid5
MD_DEVICES=3
MD_METADATA=0.90
MD_UUID=5f25b866:114bb09e:bfe78010:bc810f04
Segmentation fault

[root@localhost ~]# gdb mdadm
GNU gdb (GDB) Fedora (6.8.91.20090917-2.fc12)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /sbin/mdadm...Reading symbols from /usr/lib/debug/sbin/mdadm.debug...done.
done.
(gdb) run mdadm --export --detail /dev/md0
Starting program: /sbin/mdadm mdadm --export --detail /dev/md0
warning: the debug information found in "/usr/lib/debug//lib/ld-2.10.90.so.debug" does not match "/lib/ld-linux.so.2" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug/lib/ld-2.10.90.so.debug" does not match "/lib/ld-linux.so.2" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug//lib/libc-2.10.90.so.debug" does not match "/lib/libc.so.6" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug/lib/libc-2.10.90.so.debug" does not match "/lib/libc.so.6" (CRC mismatch).

mdadm: error opening mdadm: No such file or directory
MD_LEVEL=raid5
MD_DEVICES=3
MD_METADATA=0.90
MD_UUID=5f25b866:114bb09e:bfe78010:bc810f04

Program received signal SIGSEGV, Segmentation fault.
0x003ed2a0 in __strlen_sse2 () from /lib/libc.so.6
Missing separate debuginfos, use: debuginfo-install glibc-2.10.90-22.i686
(gdb) bt
#0  0x003ed2a0 in __strlen_sse2 () from /lib/libc.so.6
#1  0x0808308e in set_member_info (st=<value optimized out>, ent=0x80b2170) at mapfile.c:306
#2  0x08083543 in RebuildMap () at mapfile.c:369
#3  0x08083b7d in map_read (melp=<value optimized out>) at mapfile.c:166
#4  0x08083cf0 in map_by_uuid (map=<value optimized out>, uuid=<value optimized out>) at mapfile.c:246
#5  0x0805c218 in Detail (dev=<value optimized out>, brief=<value optimized out>, export=<value optimized out>, test=<value optimized out>, 
    homehost=<value optimized out>) at Detail.c:175
#6  0x0804c4cd in main (argc=<value optimized out>, argv=<value optimized out>) at mdadm.c:1326
(gdb) quit
A debugging session is active.

	Inferior 1 [process 27983] will be killed.

Quit anyway? (y or n) y
[root@localhost ~]# cat /etc/mdadm.conf 
ARRAY /dev/md0 level=raid5 num-devices=3 UUID=5f25b866:114bb09e:bfe78010:bc810f04
[root@localhost ~]# ls -al /var/run/mdadm/
total 8
drwx------.  2 root root 4096 2009-09-17 13:47 .
drwxr-xr-x. 32 root root 4096 2009-10-01 19:21 ..
Comment 1 Harald Hoyer 2009-10-01 14:31:28 EDT
*** Bug 524080 has been marked as a duplicate of this bug. ***
Comment 2 Harald Hoyer 2009-10-01 14:33:42 EDT
this bug hits initramfs hard!
Comment 3 Harald Hoyer 2009-10-01 14:35:47 EDT
see also bug 523862
Comment 4 Hans de Goede 2009-10-01 16:51:44 EDT
This is fixed by this upstream commit:
http://neil.brown.name/git?p=mdadm;a=commitdiff;h=2b9aa337af7291d3f141322da96c9f667c99d53c

Also note upstream is already at 3.0.2, where as we are still on 3.0, please
update. Note that 3.0.2 does not have the above fix yet, so that is still needed.

When doing a new package please also include the patch for storing mdmon
state in /dev/.mdadm which I send you by mail, this is a must have for
Intel BIOS RAID support.

I discussed the /dev/.mdadm for mdmon state patch with upstream (Dan Williams)
at Plumbers, and he wants to fix things slightly different, by moving to a kernel socket so that the filesystem namespace one is in no longer matters. This will not
land in time for F-12 though, and he agreed that for F-12 the /dev/.mdadm for mdmon state patch is fine.

Please fix this all asap, and request the new packages to be tagged into F-12, we need this in place for the anaconda RAID test day coming up next week.
Comment 5 Hans de Goede 2009-10-02 16:01:04 EDT
The mdadm crash is fixed by mdadm-3.0.2-1.fc12
A tag request for including this in to F-12 is here:
https://fedorahosted.org/rel-eng/ticket/2294
Comment 6 matti aarnio 2009-10-02 19:54:23 EDT
This bug is also hitting my desktop post-initramfs.
I am waiting for a solution to appear on this, then I can start feeding odd XFS (the filesystem) locks acquisition issue.
Comment 7 Adam Williamson 2009-10-05 14:10:50 EDT
the build has been tagged, so can be CLOSED RAWHIDE.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.