Bug 524169 - Grsync hangs on start
Summary: Grsync hangs on start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: grsync
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Sebastian Vahl
QA Contact: Fedora Extras Quality Assurance
URL: http://opbyte.freeforums.org/grsync-g...
Whiteboard:
: 526714 528009 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-18 07:53 UTC by Mark F. Liu
Modified: 2009-10-09 03:38 UTC (History)
7 users (show)

Fixed In Version: 0.9.2-1.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-09 03:38:26 UTC


Attachments (Terms of Use)

Description Mark F. Liu 2009-09-18 07:53:12 UTC
Description of problem:
Grsync hangs on start, and you have to "ctrl+c" to cancel it.

Version-Release number of selected component (if applicable):
0.9.1

How reproducible:
Every time.

Steps to Reproduce:
1. Just start it.
2.
3.
  
Actual results:
It hangs on start.

Expected results:
It launches and I can use it. 

Additional info:

$ grsync

(grsync:16319): Gtk-CRITICAL **: gtk_combo_box_append_text: assertion `GTK_IS_LIST_STORE (combo_box->priv->model)' failed

(grsync:16319): Gtk-CRITICAL **: gtk_combo_box_append_text: assertion `GTK_IS_LIST

Comment 1 Mark F. Liu 2009-09-18 07:56:11 UTC
Well, all console output is here:


$ grsync

(grsync:16542): Gtk-CRITICAL **: gtk_combo_box_append_text: assertion `GTK_IS_LIST_STORE (combo_box->priv->model)' failed

(grsync:16542): Gtk-CRITICAL **: gtk_combo_box_append_text: assertion `GTK_IS_LIST_STORE (combo_box->priv->model)' failed
^C

Comment 2 James Ettle 2009-09-18 15:29:14 UTC
In the meantime, grsync-0.9.0-1.fc11.x86_64 seems to work, but with another failed assertion:

(grsync:32240): Gtk-CRITICAL **: gtk_combo_box_append_text: assertion `GTK_IS_LIST_STORE (combo_box->priv->model)' failed

Comment 3 James Ettle 2009-09-18 15:30:25 UTC
(In reply to comment #2)
> In the meantime, grsync-0.9.0-1.fc11.x86_64 seems to work

By "work", I mean start; a number of the dialogs seem defective.

Comment 4 Michael Cronenworth 2009-09-19 07:07:38 UTC
Added upstream URL where some people are working on a fix. Looks like the latest gtk2 update broke GtkBuilder or grsync was using GtkBuilder incorrectly and a bug got fixed. Downgrading to gtk2 < 2.16.6 might be a workaround.

Comment 5 G.Wolfe Woodbury 2009-09-24 09:07:25 UTC
also observed in rawhide 20090923 grsync

same symptoms, no other information available.

Comment 6 Sebastian Vahl 2009-09-25 21:54:20 UTC
Thanks for your report. I can also reproduce this on my local system. However, it seems we have to wait for a fix by upstream for this issue. But upstream states that he likely won't fix this until a new release of glade or gtk appears:
"I think I'll wait for a new glade or gtk release before going on, I fear I'm waisting my time trying to solve the bugs now." :(

Comment 7 antonio montagnani 2009-10-01 14:01:18 UTC
*** Bug 526714 has been marked as a duplicate of this bug. ***

Comment 8 antonio montagnani 2009-10-01 14:06:20 UTC
and then no Grsync??? what is the component to be downgraded??

Comment 9 Christoph Wickert 2009-10-05 17:00:15 UTC
0.9.2 was just released with the fix.

Comment 10 Fedora Update System 2009-10-05 22:37:15 UTC
grsync-0.9.2-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/grsync-0.9.2-1.fc11

Comment 11 Fedora Update System 2009-10-05 22:37:33 UTC
grsync-0.9.2-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/grsync-0.9.2-1.fc12

Comment 12 Christoph Wickert 2009-10-06 00:20:43 UTC
The F12 update was tagged for F12 Beta, so I deleted it from bodhi.

Comment 13 Fedora Update System 2009-10-07 03:12:12 UTC
grsync-0.9.2-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update grsync'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10304

Comment 14 chris desjardins 2009-10-08 15:24:27 UTC
*** Bug 528009 has been marked as a duplicate of this bug. ***

Comment 15 chris desjardins 2009-10-08 15:26:18 UTC
grsync-0.9.2-1.fc11 from testing solved the problem for me.

Comment 16 Fedora Update System 2009-10-09 03:38:19 UTC
grsync-0.9.2-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.